打印

安装多php版本出错

安装多php版本出错

系统: amazon linux

lnmp1.5的安装包 默认安装的php5.6的 完成后想安装php7.2版本,出现错误。
附件: 您所在的用户组无法下载或查看附件

TOP

引用:
/root/lnmp1.5/src/php-7.2.6/Zend/zend_operators.h: In function ‘void fast_long_sub_function(zval*, zval*, zval*)’:
/root/lnmp1.5/src/php-7.2.6/Zend/zend_operators.h:657:80: error: ‘__builtin_ssubl_overflow’ was not declared in this scope
  if (UNEXPECTED(__builtin_ssubl_overflow(Z_LVAL_P(op1), Z_LVAL_P(op2), &lresult))) {
                                                                                ^
/root/lnmp1.5/src/php-7.2.6/Zend/zend_portability.h:312:52: note: in definition of macro ‘UNEXPECTED’
# define UNEXPECTED(condition) __builtin_expect(!!(condition), 0)
                                                    ^
make: *** [ext/intl/intl_convertcpp.lo] Error 1
gcc -dumpversion 看一下,这个好像是和gcc版本有关系

LNMP付费问题排查/LNMP技术支持/Paypal信用卡代付/代购VPS,域名,软件等 QQ 503228080 旺旺 lzhenbao
军哥淘宝店铺
QQ/旺旺仅提供代购及付费代维/问题解决等服务,其他不回复!LNMP相关问题请在本论坛发帖,提问前先搜索,按https://bbs.vpser.net/thread-2555-1-1.html 要求反馈问题!

TOP

[root@homego]# gcc -dumpversion
7

TOP

[root@homego]# gcc -v
Using built-in specs.
COLLECT_GCC=gcc
COLLECT_LTO_WRAPPER=/usr/libexec/gcc/x86_64-amazon-linux/7/lto-wrapper
Target: x86_64-amazon-linux
Configured with: ../configure --enable-bootstrap --enable-languages=c,c++,lto --prefix=/usr --mandir=/usr/share/man --infodir=/usr/share/info --with-bugurl=http://bugzilla.redhat.com/bugzilla --enable-shared --enable-threads=posix --enable-checking=release --disable-multilib --with-system-zlib --enable-__cxa_atexit --disable-libunwind-exceptions --enable-gnu-unique-object --enable-linker-build-id --with-gcc-major-version-only --with-linker-hash-style=gnu --enable-plugin --enable-initfini-array --with-default-libstdcxx-abi=gcc4-compatible --without-isl --disable-libmpx --disable-libsanitizer --enable-gnu-indirect-function --disable-libcilkrts --disable-libatomic --disable-libquadmath --disable-libquadmath-suport --disable-libitm --disable-libgomp --with-tune=generic --with-arch_32=x86-64 --build=x86_64-amazon-linux
Thread model: posix
gcc version 7.2.1 20170915 (Red Hat 7.2.1-2) (GCC)

TOP

回复 3# 的帖子

有可能这个版本的gcc与php 7.2有兼容问题

LNMP付费问题排查/LNMP技术支持/Paypal信用卡代付/代购VPS,域名,软件等 QQ 503228080 旺旺 lzhenbao
军哥淘宝店铺
QQ/旺旺仅提供代购及付费代维/问题解决等服务,其他不回复!LNMP相关问题请在本论坛发帖,提问前先搜索,按https://bbs.vpser.net/thread-2555-1-1.html 要求反馈问题!

TOP

请问需要指定什么版本的gcc 才可以安装php 7.2

TOP

回复 6# 的帖子

这个不确定,我们这边的amazone linux 2上测试没有问题

LNMP付费问题排查/LNMP技术支持/Paypal信用卡代付/代购VPS,域名,软件等 QQ 503228080 旺旺 lzhenbao
军哥淘宝店铺
QQ/旺旺仅提供代购及付费代维/问题解决等服务,其他不回复!LNMP相关问题请在本论坛发帖,提问前先搜索,按https://bbs.vpser.net/thread-2555-1-1.html 要求反馈问题!

TOP