VPS侦探论坛

 找回密码
 注册
搜索
热搜: pathinfo
查看: 476|回复: 4

lnmp1.5 Error: Nginx install failed. 编译错误

[复制链接]
发表于 2018-8-24 15:29:27 | 显示全部楼层 |阅读模式



make[2]: Leaving directory `/root/lnmp1.5-full/src/openssl-1.0.2o'
Operating system: armv7l-whatever-linux2
You need Perl 5.
make[1]: *** [/root/lnmp1.5-full/src/openssl-1.0.2o/.openssl/include/openssl/ssl.h] Error 1
make[1]: Leaving directory `/root/lnmp1.5-full/src/nginx-1.14.0'
make: *** [build] Error 2

...
...
============================== Check install ==============================
Checking ...
Error: Nginx install failed.
MySQL: OK
PHP: OK
PHP-FPM: OK
Sorry, Failed to install LNMP!
Please visit https://bbs.vpser.net/forum-25-1.html feedback errors and logs.
You can download /root/lnmp-install.log from your server,and upload lnmp-install.log to LNMP Forum.

本帖子中包含更多资源

您需要 登录 才可以下载或查看,没有帐号?注册

x

美国VPS、VPN、域名代购:http://shop63846532.taobao.com/

发表于 2018-8-24 20:05:03 | 显示全部楼层



Downloading packages:
http://mirror.centos.org/altarch/7/os/armhfp/Packages/autoconf-2.69-11.el7.noarch.rpm: [Errno -1] Package does not match intended download. Suggestion: run yum --enablerepo=base clean metadata
Trying other mirror.
http://mirror.centos.org/altarch/7/os/armhfp/Packages/automake-1.13.4-3.el7.noarch.rpm: [Errno -1] Package does not match intended download. Suggestion: run yum --enablerepo=base clean metadata
Trying other mirror.
http://mirror.centos.org/altarch/7/os/armhfp/Packages/perl-Pod-Simple-3.28-4.el7.noarch.rpm: [Errno -1] Package does not match intended download. Suggestion: run yum --enablerepo=base clean metadata
Trying other mirror.
http://mirror.centos.org/altarch/7/os/armhfp/Packages/perl-Test-Harness-3.28-3.el7.noarch.rpm: [Errno -1] Package does not match intended download. Suggestion: run yum --enablerepo=base clean metadata
Trying other mirror.
http://mirror.centos.org/altarch/7/os/armhfp/Packages/perl-podlators-2.5.1-3.el7.noarch.rpm: [Errno -1] Package does not match intended download. Suggestion: run yum --enablerepo=base clean metadata
Trying other mirror.


Error downloading packages:
  1:perl-Pod-Simple-3.28-4.el7.noarch: [Errno 256] No more mirrors to try.
  perl-podlators-2.5.1-3.el7.noarch: [Errno 256] No more mirrors to try.
  automake-1.13.4-3.el7.noarch: [Errno 256] No more mirrors to try.
  perl-Test-Harness-3.28-3.el7.noarch: [Errno 256] No more mirrors to try.
  autoconf-2.69-11.el7.noarch: [Errno 256] No more mirrors to try.

你系统源有问题,无法正常安装依赖包

美国VPS、VPN、域名代购:http://shop63846532.taobao.com/

 楼主| 发表于 2018-8-25 16:58:00 | 显示全部楼层

回复 2# 的帖子




感谢,系统源的问题解决了。
因为我的系统源都是国外的,下载慢还会失败。
现在可以访问探针界面。但是重启lnmp的时候会提示
+-------------------------------------------+
|    Manager for LNMP, Written by Licess    |
+-------------------------------------------+
|              https://lnmp.org             |
+-------------------------------------------+
Stoping LNMP...
Stoping nginx...  done
Shutting down MySQL.. SUCCESS!
Gracefully shutting down php-fpm . done
Starting LNMP...
Starting nginx...  done
Starting MySQL.... SUCCESS!
Starting php-fpm Failed loading /usr/local/zend/ZendGuardLoader.so:  /usr/local/zend/ZendGuardLoader.so: cannot open shared object file: No such file or directory
done
Linux下Nginx+MySQL+PHP自动安装工具:https://lnmp.org/
 楼主| 发表于 2018-8-26 02:16:47 | 显示全部楼层



解决了,直接升到7.x就没问题了 谢谢。可能我系统php5.6 装的有问题
Linux下Nginx+MySQL+PHP自动安装工具:https://lnmp.org/
发表于 2018-8-26 10:01:54 | 显示全部楼层

回复 3# 的帖子


可能是安装过程中zendguardloader因未知原因没下载下来

美国VPS、VPN、域名代购:http://shop63846532.taobao.com/

您需要登录后才可以回帖 登录 | 注册

本版积分规则

小黑屋|手机版|Archiver|VPS侦探 ( 鲁ICP备16040043号-1 )

GMT+8, 2019-4-25 21:17 , Processed in 0.044568 second(s), 27 queries .

Powered by Discuz! X3.4

© 2001-2017 Comsenz Inc.

快速回复 返回顶部 返回列表