打印

安装lnmp1.5一直失败

安装lnmp1.5一直失败

天翼云服务器 Ubuntu 18.04  64位    lnmp1.5一键安装包
附件: 您所在的用户组无法下载或查看附件

TOP

引用:
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
g++ : Depends: g++-7 (>= 7.3.0-12~) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
。。。。。。
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
build-essential : Depends: g++ (>= 4:7.2) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
。。。。。。
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
g++ : Depends: g++-7 (>= 7.3.0-12~) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
。。。。。。
The following information may help to resolve the situation:

The following packages have unmet dependencies:
libncurses5-dev : Depends: libtinfo5 (= 6.1-1ubuntu1) but 6.1-1ubuntu1.18.04 is to be installed
                   Depends: libncurses5 (= 6.1-1ubuntu1) but 6.1-1ubuntu1.18.04 is to be installed
                   Depends: libtinfo-dev (= 6.1-1ubuntu1) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
。。。。。。。
The following information may help to resolve the situation:

The following packages have unmet dependencies:
libssl-dev : Depends: libssl1.1 (= 1.1.0g-2ubuntu4) but 1.1.0g-2ubuntu4.1 is to be installed
E: Unable to correct problems, you have held broken packages.
。。。。The following information may help to resolve the situation:

The following packages have unmet dependencies:
libglib2.0-dev : Depends: libglib2.0-0 (= 2.56.1-2ubuntu1) but 2.56.3-0ubuntu0.18.04.1 is to be installed
                  Depends: libglib2.0-bin (= 2.56.1-2ubuntu1)
E: Unable to correct problems, you have held broken packages.
。。。。。
The following information may help to resolve the situation:

The following packages have unmet dependencies:
libpng-dev : Depends: libpng16-16 (= 1.6.34-1) but 1.6.34-1ubuntu0.18.04.1 is to be installed
E: Unable to correct problems, you have held broken packages.
。。。。。。
The following information may help to resolve the situation:

The following packages have unmet dependencies:
libxml2-dev : Depends: libicu-dev but it is not going to be installed
               Depends: libxml2 (= 2.9.4+dfsg1-6.1ubuntu1) but 2.9.4+dfsg1-6.1ubuntu1.2 is to be installed
E: Unable to correct problems, you have held broken packages.
Reading package lists...
。。。。。。
The following packages have unmet dependencies:
libcurl4-gnutls-dev : Depends: libcurl3-gnutls (= 7.58.0-2ubuntu3.1) but 7.58.0-2ubuntu3.5 is to be installed
E: Unable to correct problems, you have held broken packages.
。。。。。。
The following packages have unmet dependencies:
libcurl4-openssl-dev : Depends: libcurl4 (= 7.58.0-2ubuntu3.1) but 7.58.0-2ubuntu3.5 is to be installed
E: Unable to correct problems, you have held broken packages.
等等非常多的软件包都有存在依赖关系混乱有可能之前设置源的时候不是系统对应的版本安装过,可以使用aptitude install 软件包名字 按提示进行修复

LNMP付费问题排查/LNMP技术支持/Paypal信用卡代付/代购VPS,域名,软件等 QQ 503228080 旺旺 lzhenbao
军哥淘宝店铺
QQ/旺旺仅提供代购及付费代维/问题解决等服务,其他不回复!LNMP相关问题请在本论坛发帖,提问前先搜索,按https://bbs.vpser.net/thread-2555-1-1.html 要求反馈问题!

TOP