打印

lnmp 1.5 不支持gbk编码的网站程序

lnmp 1.5 不支持gbk编码的网站程序

前天买了个阿里云的轻应用服务器,用的是centos 7.3 的系统,安装好lnmp 1.5后,却发觉环境只支持utf8编码的网站程序,gbk编码的网站程序死活都是显示乱码的。因为也是第一次用centos7.x的系统,当时以为是centos的原因。于是就重新安装了个centos 6.10的系统。安装好lnmp 1.5后,发现问题依旧,gbk编码的网站程序都是显示乱码的。我意识到,可能是lnmp1.5 安装包的问题了。因为相同的程序,我在centos 6.X 上安装过lnmp 1.4时,还有以前更早的lnmp 1.1时,系统都是可以完美支持gbk和utf8两种编码同时存在的。而现在的lnmp 1.5 却死活只能支持utf8的编码了。昨天搞了一天,今天又搞了一天,完全无法子让环境支持gbk编码了。

TOP

lnmp上不强制指定任何编码
出现乱码都是你程序上和数据库的编码不统一或者文件编码与实际程序编码不统一等原因造成的

LNMP付费问题排查/LNMP技术支持/Paypal信用卡代付/代购VPS,域名,软件等 QQ 503228080 旺旺 lzhenbao
军哥淘宝店铺
QQ/旺旺仅提供代购及付费代维/问题解决等服务,其他不回复!LNMP相关问题请在本论坛发帖,提问前先搜索,按https://bbs.vpser.net/thread-2555-1-1.html 要求反馈问题!

TOP