打印

lnmp1.5升级openssl报错

lnmp1.5升级openssl报错

lnmp1.5升级openssl报错
openssl版本:OpenSSL_1_1_1a
Nginx版本:1.14.2
系统:Centos 7.6 x64

TOP

lnmp.conf截图和nginx升级日志:

附件: 您所在的用户组无法下载或查看附件

TOP

大佬帮忙看一下啊qwq

TOP

你自己改的路径都不对,不会改就直接改include/version.sh 中的版本号

LNMP付费问题排查/LNMP技术支持/Paypal信用卡代付/代购VPS,域名,软件等 QQ 503228080 旺旺 lzhenbao
军哥淘宝店铺
QQ/旺旺仅提供代购及付费代维/问题解决等服务,其他不回复!LNMP相关问题请在本论坛发帖,提问前先搜索,按https://bbs.vpser.net/thread-2555-1-1.html 要求反馈问题!

TOP

我在把include/version.sh里的openssl版本改成1.1.1a依然安装失败。

还是得麻烦军哥帮忙看下
附件: 您所在的用户组无法下载或查看附件

TOP

回复 5# 的帖子

引用:
                 from /root/lnmp/src/lua-nginx-module-0.10.11/src/ddebug.h:13,
                 from /root/lnmp/src/lua-nginx-module-0.10.11/src/ngx_http_lua_module.c:11:
/root/lnmp/src/openssl-1.1.1a/.openssl/include/openssl/ssl.h:707:6: note: expected ‘struct SSL_SESSION * (*)(struct ssl_st *, const unsigned char *, int,  int *)’ but argument is of type ‘struct SSL_SESSION * (*)(struct SSL *, u_char *, int,  int *)’
void SSL_CTX_sess_set_get_cb(SSL_CTX *ctx,
      ^
cc1: all warnings being treated as errors
make[1]: *** [objs/addon/src/ngx_http_lua_module.o] Error 1
LuaNginxModule 模块版本改成 0.10.13

LNMP付费问题排查/LNMP技术支持/Paypal信用卡代付/代购VPS,域名,软件等 QQ 503228080 旺旺 lzhenbao
军哥淘宝店铺
QQ/旺旺仅提供代购及付费代维/问题解决等服务,其他不回复!LNMP相关问题请在本论坛发帖,提问前先搜索,按https://bbs.vpser.net/thread-2555-1-1.html 要求反馈问题!

TOP

安装成功,非常感谢dalao!

TOP