VPS侦探论坛

 找回密码
 注册
查看: 208|回复: 4

php7.0.12在LNMP1.4升级失败,着急

[复制链接]
发表于 2019-5-23 17:10:29 | 显示全部楼层 |阅读模式



include/main.sh: line 581: /usr/local/php/bin/php-config: No such file or directory
include/main.sh: line 582: /usr/local/php/bin/php-config: No such file or directory
Current PHP Version:
You can get version number from http://www.php.net/
Please enter a PHP Version you want:
Press any key to start...or Press Ctrl+c to cancel

Notice: php-7.0.21.tar.bz2 not found!!!download now...
--2019-05-23 17:04:43--  http://cn2.php.net/distributions/php-7.0.21.tar.bz2
Resolving cn2.php.net... 119.81.61.41, 2a02:cb40:200::1ad
Connecting to cn2.php.net|119.81.61.41|:80... connected.
HTTP request sent, awaiting response... 301 Moved Permanently
Location: https://www.php.net/distributions/php-7.0.21.tar.bz2 [following]
--2019-05-23 17:04:43--  https://www.php.net/distributions/php-7.0.21.tar.bz2
Resolving www.php.net... 119.81.61.41, 2a02:cb40:200::1ad
Connecting to www.php.net|119.81.61.41|:443... connected.
HTTP request sent, awaiting response... 416 Requested Range Not Satisfiable

    The file is already fully retrieved; nothing to do.

Download php-7.0.21.tar.bz2 successfully!
+-------------------------------------------+
|    Manager for LNMP, Written by Licess    |
+-------------------------------------------+
|              https://lnmp.org             |
+-------------------------------------------+
Stoping LNMP...
Stoping nginx...  done
Shutting down MySQL.[  OK  ]
/bin/lnmp: line 41: /etc/init.d/php-fpm: No such file or directory
mv: cannot stat `/etc/init.d/php-fpm': No such file or directory
[+] Installing 7.0.21
Check icu...
Loaded plugins: security
Setting up Install Process
Package libicu-devel-4.2.1-14.el6.x86_64 already installed and latest version
Nothing to do
Uncompress php-7.0.21.tar.bz2...
cd php-7.0.21...
checking for grep that handles long lines and -e... /bin/grep
checking for egrep... /bin/grep -E
checking for a sed that does not truncate output... /bin/sed
checking build system type... x86_64-unknown-linux-gnu
checking host system type... x86_64-unknown-linux-gnu
checking target system type... x86_64-unknown-linux-gnu
checking for cc... cc
checking whether the C compiler works... yes
checking for C compiler default output file name... a.out
checking for suffix of executables...
checking whether we are cross compiling... no
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether cc accepts -g... yes
checking for cc option to accept ISO C89... none needed
checking how to run the C preprocessor... cc -E
checking for icc... no
checking for suncc... no
checking whether cc understands -c and -o together... yes
checking how to run the C preprocessor... cc -E
checking for ANSI C header files... yes
checking for sys/types.h... yes
checking for sys/stat.h... yes
checking for stdlib.h... yes
checking for string.h... yes
checking for memory.h... yes
checking for strings.h... yes
checking for inttypes.h... yes
checking for stdint.h... yes
checking for unistd.h... yes
checking minix/config.h usability... no
checking minix/config.h presence... no
checking for minix/config.h... no
checking whether it is safe to define __EXTENSIONS__... yes
checking whether ln -s works... yes
checking for system library directory... lib
checking whether to enable runpaths... no
checking if compiler supports -R... no
checking if compiler supports -Wl,-rpath,... yes
checking for gawk... gawk
checking for bison... bison -y
checking for bison version... 2.4 (ok)
checking for re2c... no
configure: WARNING: You will need re2c 0.13.4 or later if you want to regenerate PHP parsers.
checking whether to enable computed goto gcc extension with re2c... no
checking whether to force non-PIC code in shared modules... no
checking whether /dev/urandom exists... yes
checking whether /dev/arandom exists... no
checking for global register variables support... no
checking for pthreads_cflags... -pthread
checking for pthreads_lib... pthread

Configuring SAPI modules
checking for Apache 2.0 handler-module support via DSO through APXS... no
checking for setproctitle... no
checking sys/pstat.h usability... no
checking sys/pstat.h presence... no
checking for sys/pstat.h... no
checking for PS_STRINGS... no
checking for CLI build... yes
checking for embedded SAPI library support... no
checking for FPM build... yes
checking for setenv... yes
checking for clearenv... yes
checking for setproctitle... (cached) no
checking for library containing socket... none required
checking for library containing inet_addr... none required
checking errno.h usability... yes
checking errno.h presence... yes
checking for errno.h... yes
checking fcntl.h usability... yes
checking fcntl.h presence... yes
checking for fcntl.h... yes
checking stdio.h usability... yes
checking stdio.h presence... yes
checking for stdio.h... yes
checking for stdlib.h... (cached) yes
checking for unistd.h... (cached) yes
checking sys/uio.h usability... yes
checking sys/uio.h presence... yes
checking for sys/uio.h... yes
checking sys/select.h usability... yes
checking sys/select.h presence... yes
checking for sys/select.h... yes
checking sys/socket.h usability... yes
checking sys/socket.h presence... yes
checking for sys/socket.h... yes
checking sys/time.h usability... yes
checking sys/time.h presence... yes
checking for sys/time.h... yes
checking arpa/inet.h usability... yes
checking arpa/inet.h presence... yes
checking for arpa/inet.h... yes
checking netinet/in.h usability... yes
checking netinet/in.h presence... yes
checking for netinet/in.h... yes
checking sysexits.h usability... yes
checking sysexits.h presence... yes
checking for sysexits.h... yes
checking for prctl... yes
checking for clock_gettime... no
checking for clock_gettime in -lrt... yes
checking for ptrace... yes
checking whether ptrace works... yes
checking for proc mem file... mem
checking if gcc supports __sync_bool_compare_and_swap... yes
checking for TCP_INFO... yes
checking for sysconf... yes
checking for times... yes
checking for kqueue... no
checking for port framework... no
checking for /dev/poll... no
checking for epoll... yes
checking for poll... yes
checking for select... yes
checking for apparmor... no
checking for LiteSpeed support... no
checking for phpdbg support... yes
checking for phpdbg web SAPI support... no
checking for phpdbg debug build... no
checking whether termios.h defines TIOCGWINSZ... no
checking whether sys/ioctl.h defines TIOCGWINSZ... yes
checking for CGI build... yes
checking for socklen_t in sys/socket.h... yes
checking for sun_len in sys/un.h... no
checking whether cross-process locking is required by accept()... no
checking for chosen SAPI module... none
checking for executable SAPI binaries...  cli fpm phpdbg cgi

美国VPS、VPN、域名代购:http://shop63846532.taobao.com/

 楼主| 发表于 2019-5-23 17:11:53 | 显示全部楼层

checking whether to enable XMLWriter support... yes
checking for xml2-config path... (cached) /usr/bin/xml2-config
checking whether libxml build works... (cached) yes
checking for XSL support... yes
configure: error: xslt-config not found. Please reinstall the libxslt >= 1.1.0 distribution
make: *** No targets specified and no makefile found.  Stop.
make: *** No rule to make target `install'.  Stop.
Copy new php configure file...
Modify php.ini......
include/upgrade_php.sh: line 116: pear: command not found
include/upgrade_php.sh: line 117: pecl: command not found
include/php.sh: line 29: php: command not found
curl: (7) couldn't connect to host
Install ZendGuardLoader for PHP 7...
unavailable now.
Write ZendGuardLoader to php.ini...
Creating new php-fpm configure file...
Copy php-fpm init.d file...
cp: cannot stat `/root/lnmp1.4-full/src/php-7.0.21/sapi/fpm/init.d.php-fpm': No such file or directory
chmod: cannot access `/etc/init.d/php-fpm': No such file or directory
+-------------------------------------------+
|    Manager for LNMP, Written by Licess    |
+-------------------------------------------+
|              https://lnmp.org             |
+-------------------------------------------+
Starting LNMP...
Starting nginx...  done
Starting MySQL..[  OK  ]
/bin/lnmp: line 27: /etc/init.d/php-fpm: No such file or directory
======== upgrade php failed ======
upgrade php log: /root/upgrade_lnmp_php.log
You upload upgrade_lnmp_php.log to LNMP Forum for help.

美国VPS、VPN、域名代购:http://shop63846532.taobao.com/

 楼主| 发表于 2019-5-23 17:12:28 | 显示全部楼层



出错的地方在二楼部分,麻烦查看
美国VPS推荐: 遨游主机LinodeLOCVPSKVMLAVPS2EZ搬瓦工80VPSVultr美国VPS主机中国VPS推荐: 阿里云腾讯云。LNMP付费服务(代装/问题排查)QQ 503228080
 楼主| 发表于 2019-5-23 17:15:21 | 显示全部楼层



sdstu 发表于 2019-5-23 17:12
出错的地方在二楼部分,麻烦查看


本帖子中包含更多资源

您需要 登录 才可以下载或查看,没有帐号?注册

x
Linux下Nginx+MySQL+PHP自动安装工具:https://lnmp.org/
发表于 2019-5-23 19:49:51 | 显示全部楼层



1.4的升级脚本不完善可以尝试使用1.5或1.6的
也可以yum或apt-get 安装 libxslt-devel 或 libxslt-dev 后再试试

美国VPS、VPN、域名代购:http://shop63846532.taobao.com/

您需要登录后才可以回帖 登录 | 注册

本版积分规则

小黑屋|手机版|Archiver|VPS侦探 ( 鲁ICP备16040043号-1 )

GMT+8, 2019-8-24 00:44 , Processed in 0.048852 second(s), 27 queries .

Powered by Discuz! X3.4

© 2001-2017 Comsenz Inc.

快速回复 返回顶部 返回列表