VPS侦探论坛

 找回密码
 注册
查看: 167|回复: 1

ubuntu16.04下安装lnmp PHP安装失败

[复制链接]
发表于 2019-6-1 09:53:51 | 显示全部楼层 |阅读模式

系统64位,自己搭建主机
Add php-fpm service at system startup...
update-rc.d: error: initscript does not exist: /etc/init.d/php-fpm
include/end.sh: 行 54: /etc/init.d/php-fpm: 没有那个文件或目录
============================== Check install ==============================
Checking ...
Nginx: OK
MySQL: OK
Error: PHP install failed.

本帖子中包含更多资源

您需要 登录 才可以下载或查看,没有帐号?注册

x

美国VPS、VPN、域名代购:http://shop63846532.taobao.com/

发表于 2019-6-1 10:03:41 | 显示全部楼层



有一些软件包无法被安装。如果您用的是 unstable 发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们已被从新到(Incoming)目录移出。
下列信息可能会对解决问题有所帮助:

下列软件包有未满足的依赖关系:
libpng12-dev : 依赖: libpng12-0 (= 1.2.54-1ubuntu1) 但是 1.2.54-1ubuntu1.1 正要被安装
E: 无法修正错误,因为您要求某些软件包保持现状,就是它们破坏了软件包间的依赖关系。
正在读取软件包列表...
正在分析软件包的依赖关系树...
正在读取状态信息...
有一些软件包无法被安装。如果您用的是 unstable 发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们已被从新到(Incoming)目录移出。
下列信息可能会对解决问题有所帮助:

下列软件包有未满足的依赖关系:
libxml2-dev : 依赖: libxml2 (= 2.9.3+dfsg1-1) 但是 2.9.3+dfsg1-1ubuntu0.6 正要被安装
               依赖: libicu-dev 但是它将不会被安装
E: 无法修正错误,因为您要求某些软件包保持现状,就是它们破坏了软件包间的依赖关系。
。。。。。
下列软件包有未满足的依赖关系:
libpng12-dev : 依赖: libpng12-0 (= 1.2.54-1ubuntu1) 但是 1.2.54-1ubuntu1.1 正要被安装
E: 无法修正错误,因为您要求某些软件包保持现状,就是它们破坏了软件包间的依赖关系。
等等

你系统上一部分软件一般关系有问题导致的

美国VPS、VPN、域名代购:http://shop63846532.taobao.com/

您需要登录后才可以回帖 登录 | 注册

本版积分规则

小黑屋|手机版|Archiver|VPS侦探 ( 鲁ICP备16040043号-1 )

GMT+8, 2019-8-25 05:30 , Processed in 0.040777 second(s), 27 queries .

Powered by Discuz! X3.4

© 2001-2017 Comsenz Inc.

快速回复 返回顶部 返回列表