VPS侦探论坛

 找回密码
 注册
搜索
查看: 110|回复: 2

求助 PHP安装失败

[复制链接]
发表于 2019-6-9 15:42:43 | 显示全部楼层 |阅读模式



vultr的服务器
CPU:1 vCore
RAM:1024 MB
Storage:25 GB SSD
OS:Ubuntu 19.04 x64


感谢帮助!!


本帖子中包含更多资源

您需要 登录 才可以下载或查看,没有帐号?注册

x
Linux下Nginx+MySQL+PHP自动安装工具:https://lnmp.org/
发表于 2019-6-9 19:42:01 | 显示全部楼层

/root/lnmp1.6/src/php-5.6.40/ext/intl/intl_convertcpp.cpp:62:26: error: request for member ‘length’ in ‘from’, which is of non-class type ‘const int’
  int32_t capacity = from.length() * 3 + 1;
                          ^~~~~~
/root/lnmp1.6/src/php-5.6.40/ext/intl/intl_convertcpp.cpp:64:11: error: request for member ‘isEmpty’ in ‘from’, which is of non-class type ‘const int’
  if (from.isEmpty()) {
           ^~~~~~~
/root/lnmp1.6/src/php-5.6.40/ext/intl/intl_convertcpp.cpp:74:31: error: request for member ‘getBuffer’ in ‘from’, which is of non-class type ‘const int’
  const UChar *utf16buf = from.getBuffer();
                               ^~~~~~~~~
/root/lnmp1.6/src/php-5.6.40/ext/intl/intl_convertcpp.cpp:76:69: error: request for member ‘length’ in ‘from’, which is of non-class type ‘const int’
  u_strToUTF8WithSub(*res, capacity - 1, &actual_len, utf16buf, from.length(),
                                                                     ^~~~~~
make: *** [Makefile:932: ext/intl/intl_convertcpp.lo] Error 1

php 7.0及以下版本都已经停止支持和更新了
低于php 7.1的版本无法在ubuntu 19.04这种非常新的linux发行版上安装

美国VPS、VPN、域名代购:http://shop63846532.taobao.com/

 楼主| 发表于 2019-6-10 18:28:40 | 显示全部楼层

licess 发表于 2019-6-9 19:42
php 7.0及以下版本都已经停止支持和更新了
低于php 7.1的版本无法在ubuntu 19.04这种非常新的linux发行版 ...

非常感谢!!
美国VPS推荐: 遨游主机LinodeLOCVPSKVMLAVPS2EZ搬瓦工80VPSVultr美国VPS主机中国VPS推荐: 阿里云腾讯云。LNMP付费服务(代装/问题排查)QQ 503228080
您需要登录后才可以回帖 登录 | 注册

本版积分规则

小黑屋|手机版|Archiver|VPS侦探 ( 鲁ICP备16040043号-1 )

GMT+8, 2019-6-27 09:07 , Processed in 0.041965 second(s), 27 queries .

Powered by Discuz! X3.4

© 2001-2017 Comsenz Inc.

快速回复 返回顶部 返回列表