VPS侦探论坛

 找回密码
 注册
查看: 334|回复: 5

安装最新的lnmp1.6的php失败,跪求大神解惑

[复制链接]
发表于 2019-6-10 22:55:45 | 显示全部楼层 |阅读模式



collect2: error: ld returned 1 exit status
Makefile:293: recipe for target 'sapi/cli/php' failed
make: *** [sapi/cli/php] Error 1

本帖子中包含更多资源

您需要 登录 才可以下载或查看,没有帐号?注册

x
Linux下Nginx+MySQL+PHP自动安装工具:https://lnmp.org/
发表于 2019-6-11 09:12:40 | 显示全部楼层

/home/hwanginsitein/lnmp1.6/src/php-7.2.19/ext/intl/breakiterator/codepointiterator_internal.cpp:46: undefined reference to `icu_63::BreakIterator::~BreakIterator()'
ext/intl/breakiterator/.libs/codepointiterator_internal.o: In function `PHP::CodePointBreakIterator::clone() const':
/home/hwanginsitein/lnmp1.6/src/php-7.2.19/ext/intl/breakiterator/codepointiterator_internal.cpp:95: undefined reference to `icu_63::UMemory:perator new(unsigned long)'
/home/hwanginsitein/lnmp1.6/src/php-7.2.19/ext/intl/breakiterator/codepointiterator_internal.cpp:95: undefined reference to `icu_63::UMemory:perator delete(void*)'
ext/intl/breakiterator/.libs/codepointiterator_internal.o: In function `PHP::CodePointBreakIterator::createBufferClone(void*, int&, UErrorCode&)':
/home/hwanginsitein/lnmp1.6/src/php-7.2.19/ext/intl/breakiterator/codepointiterator_internal.cpp:257: undefined reference to `icu_63::UMemory:perator new(unsigned long)'
/home/hwanginsitein/lnmp1.6/src/php-7.2.19/ext/intl/breakiterator/codepointiterator_internal.cpp:257: undefined reference to `icu_63::UMemory:perator delete(void*)'
ext/intl/breakiterator/.libs/codepointiterator_internal.o: In function `PHP::CodePointBreakIterator::getUText(UText*, UErrorCode&) const':
/home/hwanginsitein/lnmp1.6/src/php-7.2.19/ext/intl/breakiterator/codepointiterator_internal.cpp:111: undefined reference to `utext_clone_63'
ext/intl/breakiterator/.libs/codepointiterator_internal.o: In function `PHP::CodePointBreakIterator::~CodePointBreakIterator()':
/home/hwanginsitein/lnmp1.6/src/php-7.2.19/ext/intl/breakiterator/codepointiterator_internal.cpp:69: undefined reference to `icu_63::BreakIterator::~BreakIterator()'
ext/intl/breakiterator/.libs/codepointiterator_internal.o: In function `PHP::CodePointBreakIterator::~CodePointBreakIterator()':
/home/hwanginsitein/lnmp1.6/src/php-7.2.19/ext/intl/breakiterator/codepointiterator_internal.cpp:75: undefined reference to `icu_63::UMemory:perator delete(void*)'
ext/intl/breakiterator/.libs/codepointiterator_internal.o.data.rel.ro._ZTIN3PHP22CodePointBreakIteratorE[_ZTIN3PHP22CodePointBreakIteratorE]+0x10): undefined reference to `typeinfo for icu_63::BreakIterator'
ext/intl/breakiterator/.libs/codepointiterator_internal.o.data.rel.ro._ZTVN3PHP22CodePointBreakIteratorE[_ZTVN3PHP22CodePointBreakIteratorE]+0xa8): undefined reference to `icu_63::BreakIterator::getRuleStatus() const'
ext/intl/breakiterator/.libs/codepointiterator_internal.o.data.rel.ro._ZTVN3PHP22CodePointBreakIteratorE[_ZTVN3PHP22CodePointBreakIteratorE]+0xb0): undefined reference to `icu_63::BreakIterator::getRuleStatusVec(int*, int, UErrorCode&)'
ext/xmlrpc/libxmlrpc/.libs/encodings.o: In function `convert':
/home/hwanginsitein/lnmp1.6/src/php-7.2.19/ext/xmlrpc/libxmlrpc/encodings.c:65: undefined reference to `libiconv_open'
/home/hwanginsitein/lnmp1.6/src/php-7.2.19/ext/xmlrpc/libxmlrpc/encodings.c:73: undefined reference to `libiconv'
/home/hwanginsitein/lnmp1.6/src/php-7.2.19/ext/xmlrpc/libxmlrpc/encodings.c:93: undefined reference to `libiconv_close'
/home/hwanginsitein/lnmp1.6/src/php-7.2.19/ext/xmlrpc/libxmlrpc/encodings.c:93: undefined reference to `libiconv_close'
/home/hwanginsitein/lnmp1.6/src/php-7.2.19/ext/xmlrpc/libxmlrpc/encodings.c:93: undefined reference to `libiconv_close'

这个问题本身安装脚本就有对这个适配,还是报错的话就没办法了,换个php版本或者ubuntu的版本试试
美国VPS推荐: 遨游主机LinodeLOCVPSKVMLAVPS2EZ搬瓦工80VPSVultr美国VPS主机中国VPS推荐: 阿里云腾讯云。LNMP付费服务(代装/问题排查)QQ 503228080
 楼主| 发表于 2019-6-11 09:31:28 | 显示全部楼层



我前段时间安装php7.3.6成功了,但是发现php7.3.6有bug,然后打算退回别的版本,结果就是这个样子
Linux下Nginx+MySQL+PHP自动安装工具:https://lnmp.org/
 楼主| 发表于 2019-6-13 23:34:45 | 显示全部楼层



configure 的时候 去掉 --enable-intl  就安装成功了,请问下军哥为什么吗?

美国VPS、VPN、域名代购:http://shop63846532.taobao.com/

发表于 2019-6-14 13:36:12 | 显示全部楼层


hwanginsitein 发表于 2019-6-13 23:34
configure 的时候 去掉 --enable-intl  就安装成功了,请问下军哥为什么吗?

不需要icu的话可以去掉,有可能你系统上的icu版本与php有兼容问题
你的是什么linux发行版,什么版本的?

美国VPS、VPN、域名代购:http://shop63846532.taobao.com/

 楼主| 发表于 2019-8-8 10:19:00 | 显示全部楼层

licess 发表于 2019-6-14 13:36
不需要icu的话可以去掉,有可能你系统上的icu版本与php有兼容问题
你的是什么linux发行版,什么版本的? ...

我的是ubuntu18.04

美国VPS、VPN、域名代购:http://shop63846532.taobao.com/

您需要登录后才可以回帖 登录 | 注册

本版积分规则

小黑屋|手机版|Archiver|VPS侦探 ( 鲁ICP备16040043号-1 )

GMT+8, 2019-8-25 12:06 , Processed in 0.043568 second(s), 27 queries .

Powered by Discuz! X3.4

© 2001-2017 Comsenz Inc.

快速回复 返回顶部 返回列表