VPS侦探论坛

 找回密码
 注册
查看: 196|回复: 1

lnmp 1.6 Bug,装PHP 7.3.6,php-v却显示PHP 5.4.16

[复制链接]
发表于 2019-6-12 22:02:49 | 显示全部楼层 |阅读模式


军哥好:

不知道是lnmp 1.6安装脚本的Bug还是我的个例,安装时选择的 PHP 版本为 7.3.6 ,然后打算安装 Flarum ,运行 Composer 后报错,提示PHP 版本过低

flarum/core v0.1.0-beta.8.1 requires php >=7.1 -> your PHP version (5.4.16) does not satisfy that requirement.

然后我才检查PHP的版本号,显示:

# php -v
PHP 5.4.16 (cli) (built: Oct 30 2018 19:30:51)
Copyright (c) 1997-2013 The PHP Group
Zend Engine v2.4.0, Copyright (c) 1998-2013 Zend Technologies

# php-fpm -v
PHP 7.3.6 (fpm-fcgi) (built: Jun 10 2019 10:08:18)
Copyright (c) 1997-2018 The PHP Group
Zend Engine v3.3.6, Copyright (c) 1998-2018 Zend Technologies
    with Zend OPcache v7.3.6, Copyright (c) 1999-2018, by Zend Technologies

接着我又到另外一台用lnmp 1.5 安装包的机器上运行命令如下:

# php -v
PHP 7.3.1 (cli) (built: Jan 17 2019 11:56:45) ( NTS )
Copyright (c) 1997-2018 The PHP Group
Zend Engine v3.3.1, Copyright (c) 1998-2018 Zend Technologies
    with Zend OPcache v7.3.1, Copyright (c) 1999-2018, by Zend Technologies

# php-fpm -v
PHP 7.3.1 (fpm-fcgi) (built: Jan 17 2019 11:57:08)
Copyright (c) 1997-2018 The PHP Group
Zend Engine v3.3.1, Copyright (c) 1998-2018 Zend Technologies
    with Zend OPcache v7.3.1, Copyright (c) 1999-2018, by Zend Technologies

不知道这是不是 lnmp 1.6 的bug?

美国VPS推荐: 遨游主机LinodeLOCVPSKVMLAVPS2EZ搬瓦工80VPSVultr美国VPS主机中国VPS推荐: 阿里云腾讯云。LNMP付费服务(代装/问题排查)QQ 503228080
发表于 2019-6-13 09:18:48 | 显示全部楼层


PHP 5.4.16 (cli) (built: Oct 30 2018 19:30:51)
这么古老的php 5.4版本是不可能出现在lnmp 1.6中的,而且上面的编译时间是2018年10月30号,肯定是你通过apt-get或yum等方式安装的

美国VPS、VPN、域名代购:http://shop63846532.taobao.com/

您需要登录后才可以回帖 登录 | 注册

本版积分规则

小黑屋|手机版|Archiver|VPS侦探 ( 鲁ICP备16040043号-1 )

GMT+8, 2019-8-19 04:40 , Processed in 0.042963 second(s), 26 queries .

Powered by Discuz! X3.4

© 2001-2017 Comsenz Inc.

快速回复 返回顶部 返回列表