VPS侦探论坛

 找回密码
 注册
搜索
查看: 172|回复: 2

lnmp1.6 腾讯云 安装php失败

[复制链接]
发表于 2019-6-15 02:23:30 | 显示全部楼层 |阅读模式

lnmp1.6 腾讯云 安装php失败

看不出什么原因,用腾讯云的源和阿里的源都是这个问题

请大神解惑


本帖子中包含更多资源

您需要 登录 才可以下载或查看,没有帐号?注册

x
Linux下Nginx+MySQL+PHP自动安装工具:https://lnmp.org/
发表于 2019-6-15 09:48:49 | 显示全部楼层

/root/lnmp1.6/lnmp1.6/src/php-5.6.40/ext/intl/intl_convertcpp.cpp:28:25: note: suggested alternative:
In file included from /root/lnmp1.6/lnmp1.6/src/php-5.6.40/ext/intl/intl_convertcpp.h:26:0,
                 from /root/lnmp1.6/lnmp1.6/src/php-5.6.40/ext/intl/intl_convertcpp.cpp:21:
/usr/include/unicode/unistr.h:289:20: note:   ‘icu_63::UnicodeString’
class U_COMMON_API UnicodeString : public Replaceable
                    ^
/root/lnmp1.6/lnmp1.6/src/php-5.6.40/ext/intl/intl_convertcpp.cpp:28:40: error: ‘ret’ was not declared in this scope
int intl_stringFromChar(UnicodeString &ret, char *str, int32_t str_len, UErrorCode *status)
                                        ^
/root/lnmp1.6/lnmp1.6/src/php-5.6.40/ext/intl/intl_convertcpp.cpp:28:45: error: expected primary-expression before ‘char’
int intl_stringFromChar(UnicodeString &ret, char *str, int32_t str_len, UErrorCode *status)
                                             ^
/root/lnmp1.6/lnmp1.6/src/php-5.6.40/ext/intl/intl_convertcpp.cpp:28:64: error: expected primary-expression before ‘str_len’
int intl_stringFromChar(UnicodeString &ret, char *str, int32_t str_len, UErrorCode *status)
                                                                ^
/root/lnmp1.6/lnmp1.6/src/php-5.6.40/ext/intl/intl_convertcpp.cpp:28:84: error: expected primary-expression before ‘*’ token
int intl_stringFromChar(UnicodeString &ret, char *str, int32_t str_len, UErrorCode *status)
                                                                                    ^
/root/lnmp1.6/lnmp1.6/src/php-5.6.40/ext/intl/intl_convertcpp.cpp:28:85: error: ‘status’ was not declared in this scope
int intl_stringFromChar(UnicodeString &ret, char *str, int32_t str_len, UErrorCode *status)
                                                                                     ^
Makefile:964: recipe for target 'ext/intl/intl_convertcpp.lo' failed
make: *** [ext/intl/intl_convertcpp.lo] Error 1

你系统自带的icu版本是64.1太高,php 5.6已经停止支持,只能换php 7.1及以上版本或者更换其他低ubuntu版本或linux发行版但是正常ubuntu 16.04上自带的icu是55.1

美国VPS、VPN、域名代购:http://shop63846532.taobao.com/

您需要登录后才可以回帖 登录 | 注册

本版积分规则

小黑屋|手机版|Archiver|VPS侦探 ( 鲁ICP备16040043号-1 )

GMT+8, 2019-7-18 03:49 , Processed in 0.216556 second(s), 27 queries .

Powered by Discuz! X3.4

© 2001-2017 Comsenz Inc.

快速回复 返回顶部 返回列表