VPS侦探论坛

 找回密码
 注册
查看: 140|回复: 2

lnmp1.6正式版,编译redis,swoole安装都不生效

[复制链接]
发表于 2019-7-22 17:42:09 | 显示全部楼层 |阅读模式


Lnmp1.6编译phpredis和swoole扩展。
1,成功编译,成功make 和 makeinstall
2.在扩展文件夹 no-......./中也有  redis.so  swoole.so
3.也修改了php.ini ,增加了  extension=redis.so   和  extension=swoole.so
4.尝试仅重启php 和 重启整个lnmp 以及重启 系统

启动lnmp都会提示这两个扩展 initialize 有问题,求解!!!
美国VPS推荐: 遨游主机LinodeLOCVPSKVMLAVPS2EZ搬瓦工80VPSVultr美国VPS主机中国VPS推荐: 阿里云腾讯云。LNMP付费服务(代装/问题排查)QQ 503228080
 楼主| 发表于 2019-7-22 22:37:41 | 显示全部楼层

Starting php-fpm [22-Jul-2019 22:37:17] NOTICE: PHP message: PHP Warning:  PHP Startup: redis: Unable to initialize module
Module compiled with module API=20170718
PHP    compiled with module API=20180731
These options need to match
in Unknown on line 0
done
Linux下Nginx+MySQL+PHP自动安装工具:https://lnmp.org/
发表于 2019-7-22 22:41:16 | 显示全部楼层

不清楚错误信息没法说
Linux下Nginx+MySQL+PHP自动安装工具:https://lnmp.org/
您需要登录后才可以回帖 登录 | 注册

本版积分规则

小黑屋|手机版|Archiver|VPS侦探 ( 鲁ICP备16040043号-1 )

GMT+8, 2019-8-22 13:58 , Processed in 0.074546 second(s), 26 queries .

Powered by Discuz! X3.4

© 2001-2017 Comsenz Inc.

快速回复 返回顶部 返回列表