VPS侦探论坛

 找回密码
 注册
查看: 218|回复: 3

centos7 安装lnmp,其中php安装失败

[复制链接]
发表于 2019-8-2 14:08:09 | 显示全部楼层 |阅读模式



centos7 安装lnmp,其中php安装失败

本帖子中包含更多资源

您需要 登录 才可以下载或查看,没有帐号?注册

x
美国VPS推荐: 遨游主机LinodeLOCVPSKVMLAVPS2EZ搬瓦工80VPSVultr美国VPS主机中国VPS推荐: 阿里云腾讯云。LNMP付费服务(代装/问题排查)QQ 503228080
 楼主| 发表于 2019-8-2 14:09:14 | 显示全部楼层


这个是安装日志,lnmp-install.log
Linux下Nginx+MySQL+PHP自动安装工具:https://lnmp.org/
 楼主| 发表于 2019-8-2 15:16:43 | 显示全部楼层



这个是安装日志

本帖子中包含更多资源

您需要 登录 才可以下载或查看,没有帐号?注册

x
美国VPS推荐: 遨游主机LinodeLOCVPSKVMLAVPS2EZ搬瓦工80VPSVultr美国VPS主机中国VPS推荐: 阿里云腾讯云。LNMP付费服务(代装/问题排查)QQ 503228080
发表于 2019-8-2 17:16:08 | 显示全部楼层



Loading mirror speeds from cached hostfile
Resolving Dependencies
--> Running transaction check
---> Package openssl-devel.x86_64 1:1.0.2k-12.el7 will be installed
--> Processing Dependency: krb5-devel(x86-64) for package: 1penssl-devel-1.0.2k-12.el7.x86_64
--> Running transaction check
---> Package krb5-devel.x86_64 0:1.15.1-19.el7 will be installed
--> Processing Dependency: libkadm5(x86-64) = 1.15.1-19.el7 for package: krb5-devel-1.15.1-19.el7.x86_64
--> Processing Dependency: krb5-libs(x86-64) = 1.15.1-19.el7 for package: krb5-devel-1.15.1-19.el7.x86_64
--> Processing Dependency: libverto-devel for package: krb5-devel-1.15.1-19.el7.x86_64
--> Processing Dependency: libselinux-devel for package: krb5-devel-1.15.1-19.el7.x86_64
--> Processing Dependency: keyutils-libs-devel for package: krb5-devel-1.15.1-19.el7.x86_64
--> Running transaction check
---> Package keyutils-libs-devel.x86_64 0:1.5.8-3.el7 will be installed
---> Package krb5-libs.x86_64 0:1.15.1-8.el7 will be updated
---> Package krb5-libs.x86_64 0:1.15.1-19.el7 will be an update
---> Package libkadm5.x86_64 0:1.15.1-19.el7 will be installed
---> Package libselinux-devel.x86_64 0:2.5-12.el7 will be installed
--> Processing Dependency: libselinux(x86-64) = 2.5-12.el7 for package: libselinux-devel-2.5-12.el7.x86_64
--> Processing Dependency: libsepol-devel(x86-64) >= 2.5-6 for package: libselinux-devel-2.5-12.el7.x86_64
--> Processing Dependency: pkgconfig(libsepol) for package: libselinux-devel-2.5-12.el7.x86_64
---> Package libverto-devel.x86_64 0:0.2.5-4.el7 will be installed
--> Running transaction check
---> Package libselinux-devel.x86_64 0:2.5-12.el7 will be installed
--> Processing Dependency: libselinux(x86-64) = 2.5-12.el7 for package: libselinux-devel-2.5-12.el7.x86_64
---> Package libsepol-devel.x86_64 0:2.5-8.1.el7 will be installed
--> Processing Dependency: libsepol(x86-64) = 2.5-8.1.el7 for package: libsepol-devel-2.5-8.1.el7.x86_64
--> Finished Dependency Resolution
Error: Package: libselinux-devel-2.5-12.el7.x86_64 (base)
           Requires: libselinux(x86-64) = 2.5-12.el7
           Installed: libselinux-2.5-14.1.el7.x86_64 (@base)
               libselinux(x86-64) = 2.5-14.1.el7
           Available: libselinux-2.5-12.el7.x86_64 (base)
               libselinux(x86-64) = 2.5-12.el7
Error: Package: libsepol-devel-2.5-8.1.el7.x86_64 (base)
           Requires: libsepol(x86-64) = 2.5-8.1.el7
           Installed: libsepol-2.5-10.el7.x86_64 (@base)
               libsepol(x86-64) = 2.5-10.el7
           Available: libsepol-2.5-8.1.el7.x86_64 (base)
               libsepol(x86-64) = 2.5-8.1.el7
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest

你系统依赖关系有问题

可以尝试 yum install yum-utils
然后 package-cleanup --cleandupes
yum clean all
然后 yum install openssl-devel 看能否正常安装
Linux下Nginx+MySQL+PHP自动安装工具:https://lnmp.org/
您需要登录后才可以回帖 登录 | 注册

本版积分规则

小黑屋|手机版|Archiver|VPS侦探 ( 鲁ICP备16040043号-1 )

GMT+8, 2019-10-16 16:41 , Processed in 0.045996 second(s), 30 queries .

Powered by Discuz! X3.4

© 2001-2017 Comsenz Inc.

快速回复 返回顶部 返回列表