VPS侦探论坛

 找回密码
 注册
查看: 281|回复: 1

安装php 7.2.19的时候出错,麻烦大神看下?

[复制链接]
发表于 2019-8-8 00:15:13 | 显示全部楼层 |阅读模式



configure: error: libxml2 not found. Please check your libxml2 installation.
报错内容上看是libxml2,可是我执行apt-get install libxml2-dev 之后,显示已经安装了的

本帖子中包含更多资源

您需要 登录 才可以下载或查看,没有帐号?注册

x
美国VPS推荐: 遨游主机LinodeLOCVPSKVMLAVPS2EZ搬瓦工80VPSVultr美国VPS主机中国VPS推荐: 阿里云腾讯云。LNMP付费服务(代装/问题排查)QQ 503228080
发表于 2019-8-8 10:35:59 | 显示全部楼层


Get:14 http://mirrors.aliyun.com/ubuntu bionic-security/universe amd64 Packages [577 kB]
Get:15 http://mirrors.aliyun.com/ubuntu bionic-security/universe Translation-en [189 kB]
Get:15 http://mirrors.aliyun.com/ubuntu bionic-security/universe Translation-en [189 kB]
Get:15 http://mirrors.aliyun.com/ubuntu bionic-security/universe Translation-en [189 kB]
Ign:15 http://mirrors.aliyun.com/ubuntu bionic-security/universe Translation-en
Get:15 http://mirrors.aliyun.com/ubuntu bionic-security/universe Translation-en [189 kB]
Err:15 http://mirrors.aliyun.com/ubuntu bionic-security/universe Translation-en
  File has unexpected size (188912 != 189156). Mirror sync in progress? [IP: 112.13.73.62 80]
  Hashes of expected file:
   - Filesize:189156 [weak]
   - SHA256:0fe1f995cae1b727674d458c007585c17aa710f9b94b8ff020e0e08dfccefeea
   - SHA1:a159adb152e1076eea1e6b23baefedd7e078b4a2 [weak]
   - MD5Sum:f2b510fd8057610d673e748dfe86f442 [weak]
  Release file created at: Tue, 06 Aug 2019 17:09:49 +0000
Err:19 http://packages.microsoft.com/repos/vscode stable InRelease
  Could not connect to packages.microsoft.com:80 (13.76.190.189), connection timed out
Reading package lists...
W: Failed to fetch http://packages.microsoft.com/repos/vscode/dists/stable/InRelease  Could not connect to packages.microsoft.com:80 (13.76.190.189), connection timed out
E: Failed to fetch http://mirrors.aliyun.com/ubuntu ... n/Translation-en.xz  File has unexpected size (188912 != 189156). Mirror sync in progress? [IP: 112.13.73.62 80]
   Hashes of expected file:
    - Filesize:189156 [weak]
    - SHA256:0fe1f995cae1b727674d458c007585c17aa710f9b94b8ff020e0e08dfccefeea
    - SHA1:a159adb152e1076eea1e6b23baefedd7e078b4a2 [weak]
    - MD5Sum:f2b510fd8057610d673e748dfe86f442 [weak]
   Release file created at: Tue, 06 Aug 2019 17:09:49 +0000
W: Some index files failed to download. They have been ignored, or old ones used instead.
Reading package lists...
Building dependency tree...
Reading state information...
libc-ares-dev is already the newest version (1.14.0-1).
0 upgraded, 0 newly installed, 0 to remove and 18 not upgraded.
Reading package lists...
Building dependency tree...
Reading state information...
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
libicu-dev : Depends: libicu-le-hb-dev but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
Reading package lists...
Building dependency tree...
Reading state information...
e2fsprogs is already the newest version (1.44.1-1ubuntu1.1).
0 upgraded, 0 newly installed, 0 to remove and 18 not upgraded.
Reading package lists...
Building dependency tree...
Reading state information...

No apt package "libxslt", but there is a snap with that name.
Try "snap install libxslt"

E: Unable to locate package libxslt
Reading package lists...
Building dependency tree...
Reading state information...
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
libxslt1-dev : Depends: libxml2-dev (>= 2.6.26) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
Reading package lists...
Building dependency tree...
Reading state information...
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
libc-client2007e-dev : Depends: libssl-dev but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

按日志看你系统依赖包关系有问题,都报错了,你执行上面的命令肯定是安装不上的

可以尝试使用 aptitude install 日志中报错的软件依赖包进行修复
Linux下Nginx+MySQL+PHP自动安装工具:https://lnmp.org
您需要登录后才可以回帖 登录 | 注册

本版积分规则

小黑屋|手机版|Archiver|VPS侦探 ( 鲁ICP备16040043号-1 )

GMT+8, 2019-10-20 00:02 , Processed in 0.048349 second(s), 27 queries .

Powered by Discuz! X3.4

© 2001-2017 Comsenz Inc.

快速回复 返回顶部 返回列表