VPS侦探论坛

 找回密码
 注册
查看: 179|回复: 1

lnmp1.6安装php7.3.8失败

[复制链接]
发表于 2019-8-19 21:27:51 | 显示全部楼层 |阅读模式



请军哥看看。centos6.10、gcc6.5.0,使用lnmp1.6安装php7.3.8失败

/bin/sh /usr/src/lnmp1.6/src/php-7.3.8/libtool --silent --preserve-dup-deps --mode=compile cc -DZEND_ENABLE_STATIC_TSRMLS_CACHE=1 -Iext/standard/ -I/usr/src/lnmp1.6/src/php-7.3.8/ext/standard/ -DPHP_ATOM_INC -I/usr/src/lnmp1.6/src/php-7.3.8/include -I/usr/src/lnmp1.6/src/php-7.3.8/main -I/usr/src/lnmp1.6/src/php-7.3.8 -I/usr/src/lnmp1.6/src/php-7.3.8/ext/date/lib -I/usr/include/libxml2 -I/usr/local/freetype/include/freetype2 -I/usr/src/lnmp1.6/src/php-7.3.8/ext/mbstring/oniguruma -I/usr/src/lnmp1.6/src/php-7.3.8/ext/mbstring/libmbfl -I/usr/src/lnmp1.6/src/php-7.3.8/ext/mbstring/libmbfl/mbfl -I/usr/src/lnmp1.6/src/php-7.3.8/ext/sqlite3/libsqlite -I/usr/src/lnmp1.6/src/php-7.3.8/ext/zip/lib -I/usr/src/lnmp1.6/src/php-7.3.8/TSRM -I/usr/src/lnmp1.6/src/php-7.3.8/Zend    -I/usr/local/include -g -O2 -fvisibility=hidden -DZEND_SIGNALS   -c /usr/src/lnmp1.6/src/php-7.3.8/ext/standard/base64.c -o ext/standard/base64.lo
/tmp/cc3GFatd.s: Assembler messages:
/tmp/cc3GFatd.s:538: Error: no such instruction: `vpermd (%rbx),%ymm1,%ymm1'
/tmp/cc3GFatd.s:569: Error: suffix or operands invalid for `vpshufb'
/tmp/cc3GFatd.s:588: Error: suffix or operands invalid for `vpand'
/tmp/cc3GFatd.s:594: Error: suffix or operands invalid for `vpmulhuw'
/tmp/cc3GFatd.s:600: Error: suffix or operands invalid for `vpand'
/tmp/cc3GFatd.s:606: Error: suffix or operands invalid for `vpmullw'
/tmp/cc3GFatd.s:612: Error: suffix or operands invalid for `vpor'
/tmp/cc3GFatd.s:622: Error: suffix or operands invalid for `vpcmpgtb'
/tmp/cc3GFatd.s:628: Error: suffix or operands invalid for `vpsubusb'
/tmp/cc3GFatd.s:634: Error: suffix or operands invalid for `vpsubb'
/tmp/cc3GFatd.s:640: Error: suffix or operands invalid for `vpshufb'
/tmp/cc3GFatd.s:646: Error: suffix or operands invalid for `vpaddb'
/tmp/cc3GFatd.s:1214: Error: suffix or operands invalid for `vpcmpeqb'
/tmp/cc3GFatd.s:1234: Error: suffix or operands invalid for `vpaddb'
/tmp/cc3GFatd.s:1240: Error: suffix or operands invalid for `vpshufb'
/tmp/cc3GFatd.s:1247: Error: suffix or operands invalid for `vpaddb'
/tmp/cc3GFatd.s:1256: Error: suffix or operands invalid for `vpmaddubsw'
/tmp/cc3GFatd.s:1263: Error: suffix or operands invalid for `vpmaddwd'
/tmp/cc3GFatd.s:1269: Error: suffix or operands invalid for `vpshufb'
/tmp/cc3GFatd.s:1275: Error: no such instruction: `vpermd %ymm0,%ymm7,%ymm0'
/tmp/cc3GFatd.s:1306: Error: suffix or operands invalid for `vpsrld'
/tmp/cc3GFatd.s:1313: Error: suffix or operands invalid for `vpand'
/tmp/cc3GFatd.s:1318: Error: suffix or operands invalid for `vpand'
/tmp/cc3GFatd.s:1324: Error: suffix or operands invalid for `vpshufb'
/tmp/cc3GFatd.s:1329: Error: suffix or operands invalid for `vpshufb'
make: *** [ext/standard/base64.lo] Error 1

美国VPS推荐: 遨游主机LinodeLOCVPSKVMLAVPS2EZ搬瓦工80VPSVultr美国VPS主机中国VPS推荐: 阿里云腾讯云。LNMP付费服务(代装/问题排查)QQ 503228080
发表于 2019-8-20 10:51:02 | 显示全部楼层

不大清楚原因,有可能自行升级gcc有问题,换centos 7试试
Linux下Nginx+MySQL+PHP自动安装工具:https://lnmp.org/
您需要登录后才可以回帖 登录 | 注册

本版积分规则

小黑屋|手机版|Archiver|VPS侦探 ( 鲁ICP备16040043号-1 )

GMT+8, 2019-9-16 13:02 , Processed in 0.042934 second(s), 26 queries .

Powered by Discuz! X3.4

© 2001-2017 Comsenz Inc.

快速回复 返回顶部 返回列表