VPS侦探论坛

 找回密码
 注册
查看: 249|回复: 1

升级完 PHP 7.3.0 之后phpmyadmin提示错误,求助军哥

[复制链接]
发表于 2019-8-27 15:03:20 | 显示全部楼层 |阅读模式



本帖最后由 cyclists 于 2019-8-27 15:08 编辑

可以打开并登录phpmyadmin,但是会提示错误信息

Warning in ./libraries/config/FormDisplay.php#661
"continue" targeting switch is equivalent to "break". Did you mean to use "continue 2"?

Backtrace

./vendor/composer/ClassLoader.php#414: include()
./vendor/composer/ClassLoader.php#301: Composer\Autoload\includeFile(string '/home/web/mysql/vendor/composer/../..//libraries/config/FormDisplay.php')
Composer\Autoload\ClassLoader->loadClass(string 'PMA\\libraries\\config\\FormDisplay')
./libraries/config/PageSettings.php#76: spl_autoload_call(string 'PMA\\libraries\\config\\FormDisplay')
./libraries/config/PageSettings.php#230: PMA\libraries\config\PageSettings->__construct(
string 'Navi_panel',
string 'pma_navigation_settings',
)
./libraries/navigation/Navigation.php#66: PMA\libraries\config\PageSettings::getNaviSettings()
./libraries/Header.php#425: PMA\libraries\navigation\Navigation->getDisplay()
./libraries/Response.php#260: PMA\libraries\Header->getDisplay()
./libraries/Response.php#273: PMA\libraries\Response->_getDisplay()
./libraries/Response.php#432: PMA\libraries\Response->_htmlResponse()
PMA\libraries\Response->response()


是不兼容还是怎么回事?

phpmyadmin版本信息: 4.7.3


MYSQL版本5.5.6


FormDisplay.php源码已上传到附件,军哥帮忙看看怎么回事。

本帖子中包含更多资源

您需要 登录 才可以下载或查看,没有帐号?注册

x
美国VPS推荐: 遨游主机LinodeLOCVPSKVMLAVPS2EZ搬瓦工80VPSVultr美国VPS主机中国VPS推荐: 阿里云腾讯云。LNMP付费服务(代装/问题排查)QQ 503228080
发表于 2019-8-27 19:20:51 | 显示全部楼层


提示行这个地方把 continue 改成 continue 2 应该就可以

兼容性问题,目前phpmyadmin好像和php 7.3 未完全兼容
Linux下Nginx+MySQL+PHP自动安装工具:https://lnmp.org/
您需要登录后才可以回帖 登录 | 注册

本版积分规则

小黑屋|手机版|Archiver|VPS侦探 ( 鲁ICP备16040043号-1 )

GMT+8, 2019-9-22 16:47 , Processed in 0.042901 second(s), 27 queries .

Powered by Discuz! X3.4

© 2001-2017 Comsenz Inc.

快速回复 返回顶部 返回列表