VPS侦探论坛

 找回密码
 注册
查看: 295|回复: 5

麻烦老大看下lnmp安装完一直提示php失败

[复制链接]
发表于 2019-10-12 15:14:02 | 显示全部楼层 |阅读模式



麻烦老大看下lnmp安装完一直提示php失败
开始安装的是1.6的  然后安装失败  我就按照网上说的换成了1.5的,但是安装完还是提示失败
============================Install PHPMyAdmin=================================
============================phpMyAdmin install completed=======================
iptables: Saving firewall rules to /etc/sysconfig/iptables: [  确定  ]
Add Startup and Starting LNMP...
Add nginx service at system startup...
Starting nginx... nginx (pid 31426 31424) already running.
Add mysql service at system startup...
Starting MySQL... ERROR! The server quit without updating PID file (/usr/local/mysql/var/MiWiFi-R3-srv.pid).
Add php-fpm service at system startup...
error reading information on service php-fpm: No such file or directory
error reading information on service php-fpm: No such file or directory
include/end.sh: line 54: /etc/init.d/php-fpm: No such file or directory
============================== Check install ==============================
Checking ...
Nginx: OK
MySQL: OK
Error: PHP install failed.
Sorry, Failed to install LNMP!
Please visit https://bbs.vpser.net/forum-25-1.html feedback errors and logs.
You can download /root/lnmp-install.log from your server,and upload lnmp-install.log to LNMP Forum.
[root@MiWiFi-R3-srv lnmp1.5]#


本帖子中包含更多资源

您需要 登录 才可以下载或查看,没有帐号?注册

x
美国VPS推荐: 遨游主机LinodeLOCVPSKVMLAVPS2EZ搬瓦工80VPSVultr美国VPS主机中国VPS推荐: 阿里云腾讯云。LNMP付费服务(代装/问题排查)QQ 503228080
发表于 2019-10-12 17:13:03 | 显示全部楼层


Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
* base: mirror.jdcloud.com
* extras: mirror.jdcloud.com
* updates: mirror.jdcloud.com
Resolving Dependencies
There are unfinished transactions remaining. You might consider running yum-complete-transaction, or "yum-complete-transaction --cleanup-only" and "yum history redo last", first to finish them. If those don't work you'll have to try removing/installing packages by hand (maybe package-cleanup can help).
The program yum-complete-transaction is found in the yum-utils package.
--> Running transaction check
---> Package openssl-devel.x86_64 1:1.0.2k-19.el7 will be installed
--> Processing Dependency: krb5-devel(x86-64) for package: 1:openssl-devel-1.0.2k-19.el7.x86_64
--> Running transaction check
---> Package krb5-devel.x86_64 0:1.15.1-37.el7_7.2 will be installed
--> Processing Dependency: libkadm5(x86-64) = 1.15.1-37.el7_7.2 for package: krb5-devel-1.15.1-37.el7_7.2.x86_64
--> Processing Dependency: krb5-libs(x86-64) = 1.15.1-37.el7_7.2 for package: krb5-devel-1.15.1-37.el7_7.2.x86_64
--> Processing Dependency: libverto-devel for package: krb5-devel-1.15.1-37.el7_7.2.x86_64
--> Processing Dependency: libselinux-devel for package: krb5-devel-1.15.1-37.el7_7.2.x86_64
--> Processing Dependency: keyutils-libs-devel for package: krb5-devel-1.15.1-37.el7_7.2.x86_64
--> Processing Dependency: libkdb5.so.8()(64bit) for package: krb5-devel-1.15.1-37.el7_7.2.x86_64
--> Running transaction check
---> Package keyutils-libs-devel.x86_64 0:1.5.8-3.el7 will be installed
---> Package krb5-libs.x86_64 0:1.11.3-49.el7 will be updated
---> Package krb5-libs.x86_64 0:1.15.1-37.el7_7.2 will be an update
---> Package libkadm5.x86_64 0:1.15.1-37.el7_7.2 will be installed
---> Package libselinux-devel.x86_64 0:2.5-14.1.el7 will be installed
--> Processing Dependency: libselinux(x86-64) = 2.5-14.1.el7 for package: libselinux-devel-2.5-14.1.el7.x86_64
--> Processing Dependency: libsepol-devel(x86-64) >= 2.5-10 for package: libselinux-devel-2.5-14.1.el7.x86_64
--> Processing Dependency: pkgconfig(libsepol) for package: libselinux-devel-2.5-14.1.el7.x86_64
---> Package libverto-devel.x86_64 0:0.2.5-4.el7 will be installed
--> Running transaction check
---> Package libselinux.x86_64 0:2.2.2-6.el7 will be updated
--> Processing Dependency: libselinux = 2.2.2-6.el7 for package: libselinux-utils-2.2.2-6.el7.x86_64
--> Processing Dependency: libselinux = 2.2.2-6.el7 for package: libselinux-python-2.2.2-6.el7.x86_64
---> Package libselinux.x86_64 0:2.5-14.1.el7 will be an update
--> Processing Dependency: libsepol(x86-64) >= 2.5-10 for package: libselinux-2.5-14.1.el7.x86_64
--> Processing Dependency: libsepol.so.1(LIBSEPOL_1.0)(64bit) for package: libselinux-2.5-14.1.el7.x86_64
---> Package libsepol-devel.x86_64 0:2.5-10.el7 will be installed
--> Running transaction check
---> Package libselinux-python.x86_64 0:2.2.2-6.el7 will be updated
---> Package libselinux-python.x86_64 0:2.5-14.1.el7 will be an update
---> Package libselinux-utils.x86_64 0:2.2.2-6.el7 will be updated
---> Package libselinux-utils.x86_64 0:2.5-14.1.el7 will be an update
---> Package libsepol.x86_64 0:2.1.9-3.el7 will be updated
---> Package libsepol.x86_64 0:2.5-10.el7 will be an update
--> Processing Conflict: libselinux-2.5-14.1.el7.x86_64 conflicts systemd < 219-20
--> Processing Conflict: libselinux-2.5-14.1.el7.x86_64 conflicts selinux-policy-base < 3.13.1-66
--> Restarting Dependency Resolution with new changes.
--> Running transaction check
---> Package libselinux.x86_64 0:2.2.2-6.el7 will be updated
---> Package libselinux.x86_64 0:2.2.2-6.el7 will be updated
---> Package selinux-policy-targeted.noarch 0:3.12.1-153.el7 will be updated
---> Package selinux-policy-targeted.noarch 0:3.13.1-252.el7.1 will be an update
--> Processing Dependency: selinux-policy = 3.13.1-252.el7.1 for package: selinux-policy-targeted-3.13.1-252.el7.1.noarch
--> Processing Dependency: selinux-policy = 3.13.1-252.el7.1 for package: selinux-policy-targeted-3.13.1-252.el7.1.noarch
--> Processing Dependency: policycoreutils >= 2.5-24 for package: selinux-policy-targeted-3.13.1-252.el7.1.noarch
--> Running transaction check
---> Package policycoreutils.x86_64 0:2.2.5-11.el7 will be updated
---> Package policycoreutils.x86_64 0:2.5-33.el7 will be an update
--> Processing Dependency: libsemanage >= 2.5-14 for package: policycoreutils-2.5-33.el7.x86_64
--> Processing Dependency: libsemanage.so.1(LIBSEMANAGE_1.1)(64bit) for package: policycoreutils-2.5-33.el7.x86_64
---> Package selinux-policy.noarch 0:3.12.1-153.el7 will be updated
---> Package selinux-policy.noarch 0:3.13.1-252.el7.1 will be an update
--> Running transaction check
---> Package libsemanage.x86_64 0:2.1.10-16.el7 will be updated
---> Package libsemanage.x86_64 0:2.5-14.el7 will be an update
--> Processing Conflict: libselinux-2.5-14.1.el7.x86_64 conflicts systemd < 219-20
--> Finished Dependency Resolution
Error: libselinux conflicts with systemd-208-11.el7.x86_64
You could try using --skip-broken to work around the problem
** Found 20 pre-existing rpmdb problem(s), 'yum check' output follows:
centos-release-7-7.1908.0.el7.centos.x86_64 is a duplicate with centos-release-7-0.1406.el7.centos.2.3.x86_64
cryptsetup-libs-2.0.3-5.el7.x86_64 is a duplicate with cryptsetup-libs-1.6.3-2.el7.x86_64
7:device-mapper-1.02.158-2.el7.x86_64 is a duplicate with 7:device-mapper-1.02.84-14.el7.x86_64
7:device-mapper-libs-1.02.158-2.el7.x86_64 is a duplicate with 7:device-mapper-libs-1.02.84-14.el7.x86_64
dracut-033-564.el7.x86_64 is a duplicate with dracut-033-161.el7.x86_64
dracut-config-rescue-033-564.el7.x86_64 is a duplicate with dracut-config-rescue-033-161.el7.x86_64
dracut-network-033-564.el7.x86_64 is a duplicate with dracut-network-033-161.el7.x86_64
expat-2.1.0-10.el7_3.x86_64 is a duplicate with expat-2.1.0-8.el7.x86_64
glib2-2.56.1-5.el7.x86_64 is a duplicate with glib2-2.36.3-5.el7.x86_64
initscripts-9.49.47-1.el7.x86_64 has installed conflicts redhat-release < ('0', '7.5', '0.11'): centos-release-7-0.1406.el7.centos.2.3.x86_64
initscripts-9.49.47-1.el7.x86_64 is a duplicate with initscripts-9.49.17-1.el7.x86_64
kmod-20-25.el7.x86_64 is a duplicate with kmod-14-9.el7.x86_64
libblkid-2.23.2-61.el7.x86_64 is a duplicate with libblkid-2.23.2-16.el7.x86_64
libmount-2.23.2-61.el7.x86_64 is a duplicate with libmount-2.23.2-16.el7.x86_64
libuuid-2.23.2-61.el7.x86_64 is a duplicate with libuuid-2.23.2-16.el7.x86_64
systemd-219-67.el7_7.1.x86_64 has installed conflicts dracut < ('0', '033', '243'): dracut-033-161.el7.x86_64
systemd-219-67.el7_7.1.x86_64 has installed conflicts initscripts < ('0', '9.49.28', '1'): initscripts-9.49.17-1.el7.x86_64
systemd-219-67.el7_7.1.x86_64 is a duplicate with systemd-208-11.el7.x86_64
systemd-libs-219-67.el7_7.1.x86_64 is a duplicate with systemd-libs-208-11.el7.x86_64
util-linux-2.23.2-61.el7.x86_64 is a duplicate with util-linux-2.23.2-16.el7.x86_64

你系统yum有问题
可以尝试
yum install yum-utils
yum-complete-transaction --cleanup-only
package-cleanup --dupes
package-cleanup --problems
确保正常后可以 yum install openssl-devel 进行测试,正常安装的话再安装lnmp
Linux下Nginx+MySQL+PHP自动安装工具:https://lnmp.org
 楼主| 发表于 2019-10-17 17:25:48 | 显示全部楼层



licess 发表于 2019-10-12 17:13
你系统yum有问题
可以尝试
yum install yum-utils

谢谢老大  按照你说的  已经好啦
美国VPS推荐: 遨游主机LinodeLOCVPSKVMLAVPS2EZ搬瓦工80VPSVultr美国VPS主机中国VPS推荐: 阿里云腾讯云。LNMP付费服务(代装/问题排查)QQ 503228080
 楼主| 发表于 2019-10-17 17:54:52 | 显示全部楼层



licess 发表于 2019-10-12 17:13
你系统yum有问题
可以尝试
yum install yum-utils

---> Package selinux-policy-targeted.noarch 0:3.12.1-153.el7 will be updated
---> Package selinux-policy-targeted.noarch 0:3.13.1-252.el7.1 will be an update
--> Processing Dependency: selinux-policy = 3.13.1-252.el7.1 for package: selinux-policy-targeted-3.13.1-252.el7.1.noarch
--> Processing Dependency: selinux-policy = 3.13.1-252.el7.1 for package: selinux-policy-targeted-3.13.1-252.el7.1.noarch
--> Processing Dependency: policycoreutils >= 2.5-24 for package: selinux-policy-targeted-3.13.1-252.el7.1.noarch
--> Running transaction check
---> Package policycoreutils.x86_64 0:2.2.5-11.el7 will be updated
---> Package policycoreutils.x86_64 0:2.5-33.el7 will be an update
--> Processing Dependency: libsemanage >= 2.5-14 for package: policycoreutils-2.5-33.el7.x86_64
--> Processing Dependency: libsemanage.so.1(LIBSEMANAGE_1.1)(64bit) for package: policycoreutils-2.5-33.el7.x86_64
---> Package selinux-policy.noarch 0:3.12.1-153.el7 will be updated
---> Package selinux-policy.noarch 0:3.13.1-252.el7.1 will be an update
--> Running transaction check
---> Package libsemanage.x86_64 0:2.1.10-16.el7 will be updated
---> Package libsemanage.x86_64 0:2.5-14.el7 will be an update
--> Processing Conflict: libselinux-2.5-14.1.el7.x86_64 conflicts systemd < 219-20
--> Finished Dependency Resolution
Error: libselinux conflicts with systemd-208-11.el7.x86_64
You could try using --skip-broken to work around the problem
** Found 20 pre-existing rpmdb problem(s), 'yum check' output follows:
centos-release-7-7.1908.0.el7.centos.x86_64 is a duplicate with centos-release-7-0.1406.el7.centos.2.3.x86_64
cryptsetup-libs-2.0.3-5.el7.x86_64 is a duplicate with cryptsetup-libs-1.6.3-2.el7.x86_64
7:device-mapper-1.02.158-2.el7.x86_64 is a duplicate with 7:device-mapper-1.02.84-14.el7.x86_64
7:device-mapper-libs-1.02.158-2.el7.x86_64 is a duplicate with 7:device-mapper-libs-1.02.84-14.el7.x86_64
dracut-033-564.el7.x86_64 is a duplicate with dracut-033-161.el7.x86_64
dracut-config-rescue-033-564.el7.x86_64 is a duplicate with dracut-config-rescue-033-161.el7.x86_64
dracut-network-033-564.el7.x86_64 is a duplicate with dracut-network-033-161.el7.x86_64
expat-2.1.0-10.el7_3.x86_64 is a duplicate with expat-2.1.0-8.el7.x86_64
glib2-2.56.1-5.el7.x86_64 is a duplicate with glib2-2.36.3-5.el7.x86_64
initscripts-9.49.47-1.el7.x86_64 has installed conflicts redhat-release < ('0', '7.5', '0.11'): centos-release-7-0.1406.el7.centos.2.3.x86_64
initscripts-9.49.47-1.el7.x86_64 is a duplicate with initscripts-9.49.17-1.el7.x86_64
kmod-20-25.el7.x86_64 is a duplicate with kmod-14-9.el7.x86_64
libblkid-2.23.2-61.el7.x86_64 is a duplicate with libblkid-2.23.2-16.el7.x86_64
libmount-2.23.2-61.el7.x86_64 is a duplicate with libmount-2.23.2-16.el7.x86_64
libuuid-2.23.2-61.el7.x86_64 is a duplicate with libuuid-2.23.2-16.el7.x86_64
systemd-219-67.el7_7.1.x86_64 has installed conflicts dracut < ('0', '033', '243'): dracut-033-161.el7.x86_64
systemd-219-67.el7_7.1.x86_64 has installed conflicts initscripts < ('0', '9.49.28', '1'): initscripts-9.49.17-1.el7.x86_64
systemd-219-67.el7_7.1.x86_64 is a duplicate with systemd-208-11.el7.x86_64
systemd-libs-219-67.el7_7.1.x86_64 is a duplicate with systemd-libs-208-11.el7.x86_64
util-linux-2.23.2-61.el7.x86_64 is a duplicate with util-linux-2.23.2-16.el7.x86_64
[root@MiWiFi-R3-srv lnmp1.6]#
又提示这个
Linux下Nginx+MySQL+PHP自动安装工具:https://lnmp.org
发表于 2019-10-17 19:25:10 | 显示全部楼层

yq5858588 发表于 2019-10-17 17:54
---> Package selinux-policy-targeted.noarch 0:3.12.1-153.el7 will be updated
---> Package selinux- ...

那就不清楚了,这种错误就是前面的修复方法

美国VPS、VPN、域名代购:http://shop63846532.taobao.com/

发表于 2019-10-18 20:49:54 | 显示全部楼层

yq5858588 发表于 2019-10-17 17:54
---> Package selinux-policy-targeted.noarch 0:3.12.1-153.el7 will be updated
---> Package selinux- ...

我倒是有个想法,就是你先手动按脚本中的yum依次安装一下所有的依赖包,再分步执行一下看看到哪步出的错!
yum update
++++++ 更新完系统后直接执行下面的 for 循环,如果你用的是系统终端界面,防止输出信息过多影响查询 ,可以尝试将输出的信息重定向到一个文件中,> /root/yum-install.log
for packages in make cmake gcc gcc-c++ gcc-g77 flex bison file libtool libtool-libs autoconf kernel-devel patch wget crontabs libjpeg libjpeg-devel libpng libpng-devel libpng10 libpng10-devel gd gd-devel libxml2 libxml2-devel zlib zlib-devel glib2 glib2-devel unzip tar bzip2 bzip2-devel libzip-devel libevent libevent-devel ncurses ncurses-devel curl curl-devel libcurl libcurl-devel e2fsprogs e2fsprogs-devel krb5 krb5-devel libidn libidn-devel openssl openssl-devel vim-minimal gettext gettext-devel ncurses-devel gmp-devel pspell-devel unzip libcap diffutils ca-certificates net-tools libc-client-devel psmisc libXpm-devel git-core c-ares-devel libicu-devel libxslt libxslt-devel xz expat-devel libaio-devel rpcgen libtirpc-devel perl python-devel cyrus-sasl-devel;
    do yum -y install $packages; done
您需要登录后才可以回帖 登录 | 注册

本版积分规则

小黑屋|手机版|Archiver|VPS侦探 ( 鲁ICP备16040043号-1 )

GMT+8, 2019-11-14 03:29 , Processed in 0.063521 second(s), 27 queries .

Powered by Discuz! X3.4

© 2001-2017 Comsenz Inc.

快速回复 返回顶部 返回列表