VPS侦探论坛

 找回密码
 注册
查看: 208|回复: 2

虚拟机centos8安装多次失败

[复制链接]
发表于 2019-10-14 10:18:10 | 显示全部楼层 |阅读模式



Checking ...
Error: Nginx install failed.
Error: MySQL install failed.
Error: PHP install failed.
Sorry, Failed to install LNMP!
Please visit https://bbs.vpser.net/forum-25-1.html feedback errors and logs.
You can download /root/lnmp-install.log from your server,and upload lnmp-install.log to LNMP Forum.


这个是安装日志,谢谢




本帖子中包含更多资源

您需要 登录 才可以下载或查看,没有帐号?注册

x
美国VPS推荐: 遨游主机LinodeLOCVPSKVMLAVPS2EZ搬瓦工80VPSVultr美国VPS主机中国VPS推荐: 阿里云腾讯云。LNMP付费服务(代装/问题排查)QQ 503228080
发表于 2019-10-14 12:28:50 | 显示全部楼层


Last metadata expiration check: 0:00:07 ago on Mon 14 Oct 2019 10:09:57 AM CST.
Error:
Problem: conflicting requests
  - nothing provides glibc-devel >= 2.2.90-12 needed by gcc-8.2.1-3.5.el8.x86_64
(try to add '--skip-broken' to skip uninstallable packages or '--nobest' to use not only best candidate packages)
Waiting for process with pid 6738 to finish.
Last metadata expiration check: 0:00:02 ago on Mon 14 Oct 2019 10:10:13 AM CST.
Error:
Problem: package gcc-c++-8.2.1-3.5.el8.x86_64 requires gcc = 8.2.1-3.5.el8, but none of the providers can be installed
  - conflicting requests
  - nothing provides glibc-devel >= 2.2.90-12 needed by gcc-8.2.1-3.5.el8.x86_64
(try to add '--skip-broken' to skip uninstallable packages or '--nobest' to use not only best candidate packages)
Last metadata expiration check: 0:00:04 ago on Mon 14 Oct 2019 10:10:13 AM CST.
No match for argument: gcc-g77
Error: Unable to find a match
Last metadata expiration check: 0:00:06 ago on Mon 14 Oct 2019 10:10:13 AM CST.
Error:
Problem: conflicting requests
  - nothing provides m4 needed by flex-2.6.1-9.el8.x86_64
(try to add '--skip-broken' to skip uninstallable packages or '--nobest' to use not only best candidate packages)
Last metadata expiration check: 0:00:08 ago on Mon 14 Oct 2019 10:10:13 AM CST.
Error:
Problem: conflicting requests
  - nothing provides m4 >= 1.4 needed by bison-3.0.4-10.el8.x86_64
(try to add '--skip-broken' to skip uninstallable packages or '--nobest' to use not only best candidate packages)
Last metadata expiration check: 0:00:11 ago on Mon 14 Oct 2019 10:10:13 AM CST.
Package file-5.33-8.el8.x86_64 is already installed.
Dependencies resolved.
Nothing to do.
Complete!

你系统上各种依赖关系有问题,导致无法安装依赖包所有肯定是无法安装的可以按上面的提示修复看看
Linux下Nginx+MySQL+PHP自动安装工具:https://lnmp.org
 楼主| 发表于 2019-10-14 14:40:08 | 显示全部楼层



谢谢,安装了gcc后可以了
美国VPS推荐: 遨游主机LinodeLOCVPSKVMLAVPS2EZ搬瓦工80VPSVultr美国VPS主机中国VPS推荐: 阿里云腾讯云。LNMP付费服务(代装/问题排查)QQ 503228080
您需要登录后才可以回帖 登录 | 注册

本版积分规则

小黑屋|手机版|Archiver|VPS侦探 ( 鲁ICP备16040043号-1 )

GMT+8, 2019-11-14 03:29 , Processed in 0.043973 second(s), 27 queries .

Powered by Discuz! X3.4

© 2001-2017 Comsenz Inc.

快速回复 返回顶部 返回列表