VPS侦探论坛

 找回密码
 注册
查看: 152|回复: 3

直接删除默认PHP,发现无法安装了

[复制链接]
发表于 2019-10-29 16:33:11 | 显示全部楼层 |阅读模式



本来是多版本PHP,在默认版本7.0基础上,安装了php7.1,後来发现7.0版本问题多,改用7.1,想趁这时候将默认版本7.0卸载再安装,因为怕升级会导致一些未知错误,所以直接删除,结果悲催了,用./install.sh mphp不能安装了。
现在想重新安装7.0的新版本,之前是lnmp1.5的旧版本,请问军哥,怎么样才能安装?
美国VPS推荐: 遨游主机LinodeLOCVPSKVMLAVPS2EZ搬瓦工80VPSVultr美国VPS主机中国VPS推荐: 阿里云腾讯云。LNMP付费服务(代装/问题排查)QQ 503228080
发表于 2019-10-29 17:09:06 | 显示全部楼层


升级php本来就是和重新安装是一样的,php不像mysql、nginx之类的会有数据
./install.sh mphp 是安装多php版本的和你相把7.0改成7.1没关系
直接官网看php升级教程,使用 ./upgrade.sh php 进行升级
Linux下Nginx+MySQL+PHP自动安装工具:https://lnmp.org
 楼主| 发表于 2019-10-29 18:39:07 | 显示全部楼层



licess 发表于 2019-10-29 17:09
升级php本来就是和重新安装是一样的,php不像mysql、nginx之类的会有数据
./install.sh mphp 是安装多php版 ...

军哥你好,我已经删除了原来默认的php7.0,已经无法升级了,请问有什么办法可以重新安装7.0吗
美国VPS推荐: 遨游主机LinodeLOCVPSKVMLAVPS2EZ搬瓦工80VPSVultr美国VPS主机中国VPS推荐: 阿里云腾讯云。LNMP付费服务(代装/问题排查)QQ 503228080
发表于 2019-10-30 11:31:52 | 显示全部楼层



yanqzh 发表于 2019-10-29 18:39
军哥你好,我已经删除了原来默认的php7.0,已经无法升级了,请问有什么办法可以重新安装7.0吗 ...

升级php本来就相当于一次重新安装,虽然输入版本号之前报错,但是不管你删没删都不影响
Linux下Nginx+MySQL+PHP自动安装工具:https://lnmp.org
您需要登录后才可以回帖 登录 | 注册

本版积分规则

小黑屋|手机版|Archiver|VPS侦探 ( 鲁ICP备16040043号-1 )

GMT+8, 2019-11-23 01:51 , Processed in 0.044080 second(s), 26 queries .

Powered by Discuz! X3.4

© 2001-2017 Comsenz Inc.

快速回复 返回顶部 返回列表