VPS侦探论坛

 找回密码
 注册
查看: 136|回复: 1

lnmp1.6的php7所有版本都无法完整运行discuzx

[复制链接]
发表于 2019-11-4 11:47:06 | 显示全部楼层 |阅读模式



军哥你好!现在服务器lnmp版本已经升级为lnmp1.6,之前php7.0.13是lnmp1.4下的版本,lnmp升级到1.6后,PHP并没有升级,发现网站时常有函数报错,但discuz搭建的网站运行还比较完整,而后来安装lnmp1.6的PHP7.1.29版本运行,发现之前的函数报错不再存在,但是同时出现其他问题,网站一些功能无法使用,于是删除lnmp1.4安装的php7.0.13,重新安装了lnmp1.6下的php7.0.33,但发现与以PHP7.1.29运行时一样,网站依旧是存在同样的功能不能使用的问题。
我现在想下载lnmp1.5来安装其他版本的PHP7,请问军哥,我直接下载完整版本的lnmp1.5後,在其解压 目录下运行./install.sh mphp安装其他PHP版本,会出现与lnmp1.6不兼容的情况吗?
美国VPS推荐: 遨游主机LinodeLOCVPSKVMLAVPS2EZ搬瓦工80VPSVultr美国VPS主机中国VPS推荐: 阿里云腾讯云。LNMP付费服务(代装/问题排查)QQ 503228080
发表于 2019-11-5 10:59:04 | 显示全部楼层


不清楚你的升级是只 ./upgrade1.x-1.6.sh 吗?如果只是这样,php、nginx之类的都不会升级,./upgrade1.x-1.6.sh 只升级管理脚本和安装必要的依赖包
你discuz x是什么版本?什么功能不正常?我们也用的discuz x 3.4+php 7.3 功能正常
./install.sh mphp 是安装另外一个独立运行的php版本,适应不同程序对php版本的需求
Linux下Nginx+MySQL+PHP自动安装工具:https://lnmp.org
您需要登录后才可以回帖 登录 | 注册

本版积分规则

小黑屋|手机版|Archiver|VPS侦探 ( 鲁ICP备16040043号-1 )

GMT+8, 2019-11-20 07:09 , Processed in 0.042359 second(s), 26 queries .

Powered by Discuz! X3.4

© 2001-2017 Comsenz Inc.

快速回复 返回顶部 返回列表