VPS侦探论坛

 找回密码
 注册
查看: 172|回复: 1

lnmp1.2想把php升级到5.5,按教程操作,提示错误信息

[复制链接]
发表于 2019-11-27 17:54:44 | 显示全部楼层 |阅读模式



lnmp1.2想把php升级到5.5,按教程操作,提示错误信息如下:请问如何处理

./upgrade.sh php
+-----------------------------------------------------------------------+
|            Upgrade script for LNMP V1.2, Written by Licess            |
+-----------------------------------------------------------------------+
|     A tool to upgrade Nginx,MySQL/Mariadb,PHP for LNMP/LNMPA/LAMP     |
+-----------------------------------------------------------------------+
|          For more information please visit http://www.lnmp.org        |
+-----------------------------------------------------------------------+
Current PHP Version:5.3.29
You can get version number from http://www.php.net/
Please enter a PHP Version you want: 5.5.37

Press any key to start...or Press Ctrl+c to cancel

Error: php-5.5.37.tar.gz not found!!!download now...
--2019-11-27 17:45:25--  http://www.php.net/distributions/php-5.5.37.tar.gz
Resolving www.php.net... 185.85.0.29, 2a02:cb40:200::1ad
Connecting to www.php.net|185.85.0.29|:80... connected.
HTTP request sent, awaiting response... 301 Moved Permanently
Location: https://www.php.net/distributions/php-5.5.37.tar.gz [following]
--2019-11-27 17:45:26--  https://www.php.net/distributions/php-5.5.37.tar.gz
Connecting to www.php.net|185.85.0.29|:443... connected.
ERROR: cannot verify www.php.net's certificate, issued by `/C=US/O=DigiCert Inc/OU=www.digicert.com/CN=Thawte TLS RSA CA G1':
  Unable to locally verify the issuer's authority.
To connect to www.php.net insecurely, use `--no-check-certificate'.
--2019-11-27 17:45:28--  http://museum.php.net/php5/php-5.5.37.tar.gz
Resolving museum.php.net... 185.85.0.29, 2a02:cb40:200::1ad
Connecting to museum.php.net|185.85.0.29|:80... connected.
HTTP request sent, awaiting response... 301 Moved Permanently
Location: https://museum.php.net/php5/php-5.5.37.tar.gz [following]
--2019-11-27 17:45:28--  https://museum.php.net/php5/php-5.5.37.tar.gz
Connecting to museum.php.net|185.85.0.29|:443... connected.
ERROR: cannot verify museum.php.net's certificate, issued by `/C=US/O=DigiCert Inc/OU=www.digicert.com/CN=Thawte TLS RSA CA G1':
  Unable to locally verify the issuer's authority.
To connect to museum.php.net insecurely, use `--no-check-certificate'.
You enter PHP Version was:5.5.37
Error! You entered a wrong version number, please check!


美国VPS推荐: 遨游主机LinodeLOCVPSKVMLAVPS2EZ搬瓦工80VPSVultr美国VPS主机中国VPS推荐: 阿里云腾讯云。LNMP付费服务(代装/问题排查)QQ 503228080
发表于 2019-11-27 19:23:47 | 显示全部楼层


你系统上ca过旧,yum install ca-certificates -y 更新一下应该就可以了。
也可以编辑 include/upgrade_php.sh 查找 wget -c 全部替换为 wget -c --no-check-certificate
Linux下Nginx+MySQL+PHP自动安装工具:https://lnmp.org
您需要登录后才可以回帖 登录 | 注册

本版积分规则

小黑屋|手机版|Archiver|VPS侦探 ( 鲁ICP备16040043号-1 )

GMT+8, 2020-3-30 11:29 , Processed in 0.052081 second(s), 26 queries .

Powered by Discuz! X3.4

Copyright © 2001-2020, Tencent Cloud.

快速回复 返回顶部 返回列表