VPS侦探论坛

 找回密码
 注册
查看: 137|回复: 5

lnmp1.6下安装多版本PHP时,给其中的PHP版本安装扩展失败

[复制链接]
发表于 2019-12-1 18:10:30 | 显示全部楼层 |阅读模式




lnmp1.6下安装多版本PHP时,给其中的PHP版本安装扩展失败。
具体是centos 6.7,用的是lnmp1.6-full,安装了php7.0,php7.1,php7.2,php7.3。前面两个版本php7.0,php7.1安装memcached和imagick都成功,就是后面两个php7.2,php7.3都无法安装。

之前在php7.2,php7.3下安装memcached失败,刚刚在PHP7.3下安装imagick失败,提示以下:
Package libwebp-devel-0.4.3-3.el6.x86_64 already installed and latest version
Nothing to do
ImageMagick already exists.
imagick-3.4.4.tgz [found]
Uncompress imagick-3.4.4.tgz...
cd imagick-3.4.4...
Configuring for:
PHP Api Version:         20180731
Zend Module Api No:      20180731
Zend Extension Api No:   320180731
configure.ac:3: error: Autoconf version 2.68 or higher is required
configure.ac:3: the top level
autom4te: /usr/bin/m4 failed with exit status: 63
include/imageMagick.sh: line 52: ./configure: 没有那个文件或目录
make: *** 没有指明目标并且找不到 makefile。 停止。
make: *** 没有指明目标并且找不到 makefile。 停止。
make: *** 没有规则可以创建目标“install”。 停止。
imagick install failed!


美国VPS推荐: 遨游主机LinodeLOCVPSKVMLAVPS2EZ搬瓦工80VPSVultr美国VPS主机中国VPS推荐: 阿里云腾讯云。LNMP付费服务(代装/问题排查)QQ 503228080
 楼主| 发表于 2019-12-1 18:12:16 | 显示全部楼层


无法安装imagick问题还不大,无法安装memcached的话,会导致数据库压力太大
Linux下Nginx+MySQL+PHP自动安装工具:https://lnmp.org
发表于 2019-12-2 08:46:54 | 显示全部楼层



configure.ac:3: error: Autoconf version 2.68 or higher is required
上面已经有错误提示了
centos 6自带的autoconf好像是2.63,肯定是不行的

你都已经上php 7.*了,系统也得更少,最少centos 7起步了
可以尝试升级系统或者自己编译安装个新版的autoconf
wget http://ftp.gnu.org/gnu/autoconf/autoconf-2.69.tar.gz
tar zxf autoconf-2.69.tar.gz
cd autoconf-2.69
./configure --prefix=/usr
make && make install
美国VPS推荐: 遨游主机LinodeLOCVPSKVMLAVPS2EZ搬瓦工80VPSVultr美国VPS主机中国VPS推荐: 阿里云腾讯云。LNMP付费服务(代装/问题排查)QQ 503228080
 楼主| 发表于 前天 20:29 | 显示全部楼层



licess 发表于 2019-12-2 08:46
configure.ac:3: error: Autoconf version 2.68 or higher is required
上面已经有错误提示了
centos 6自带 ...

军哥你好!很感谢你的回复,刚利用你的办法,升级了autoconf,然后安装memcached成功了,但是重启php-fpm後,发现discuzx的“性能优化-内存优化”项里,memcache依然是“php扩展环境”对memcache“不支持”。
奇怪的是,通过phpinfo.php查看,发现memcached已经列于扩展中。
Linux下Nginx+MySQL+PHP自动安装工具:https://lnmp.org
 楼主| 发表于 前天 20:43 | 显示全部楼层

licess 发表于 2019-12-2 08:46
configure.ac:3: error: Autoconf version 2.68 or higher is required
上面已经有错误提示了
centos 6自带 ...

因为之前也安装了PHP7.2版本,所以刚刚尝试切换到php7.2,发现安装的memcached扩展支持了

美国VPS、VPN、域名代购:http://shop63846532.taobao.com/

发表于 昨天 09:54 | 显示全部楼层

php有memcached和memcache两种php扩展,都是不同的
您需要登录后才可以回帖 登录 | 注册

本版积分规则

小黑屋|手机版|Archiver|VPS侦探 ( 鲁ICP备16040043号-1 )

GMT+8, 2019-12-12 08:08 , Processed in 0.051346 second(s), 26 queries .

Powered by Discuz! X3.4

Copyright © 2001-2020, Tencent Cloud.

快速回复 返回顶部 返回列表