VPS侦探论坛

 找回密码
 注册
查看: 496|回复: 7

1.6 centos8 安装 imagick 报错,啥问题?

[复制链接]
发表于 2019-12-15 19:44:34 | 显示全部楼层 |阅读模式



Starting MySQL. SUCCESS!
Starting php-fpm [15-Dec-2019 19:39:21] NOTICE: PHP message: PHP Warning:  PHP Startup: Unable to load dynamic library '/usr/local/php/lib/php/extensions/no-debug-non-zts-20170718/imagick.so' (tried: /usr/local/php/lib/php/extensions/no-debug-non-zts-20170718/imagick.so (/usr/lib64/libfontconfig.so.1: undefined symbol: FT_Done_MM_Var), /usr/local/php/lib/php/extensions/no-debug-non-zts-20170718//usr/local/php/lib/php/extensions/no-debug-non-zts-20170718/imagick.so.so (/usr/local/php/lib/php/extensions/no-debug-non-zts-20170718//usr/local/php/lib/php/extensions/no-debug-non-zts-20170718/imagick.so.so: cannot open shared object file: No such file or directory)) in Unknown on line 0
done

按照脚本安装,重启的时候报错,可能啥原因?

/usr/local/php/lib/php/extensions/no-debug-non-zts-20170718/imagick.so 是有的


美国VPS推荐: 遨游主机LinodeLOCVPSKVMLAVPS2EZ搬瓦工80VPSVultr美国VPS主机中国VPS推荐: 阿里云腾讯云。LNMP付费服务(代装/问题排查)QQ 503228080
发表于 2019-12-16 14:01:10 | 显示全部楼层


可能是centos8与这个有兼容问题
Linux下Nginx+MySQL+PHP自动安装工具:https://lnmp.org
 楼主| 发表于 2019-12-16 15:06:42 | 显示全部楼层



那就是 imagick  的安装包可能针对centos8有点问题咯,能自己装么?有手工安装的指导么?

谢谢
美国VPS推荐: 遨游主机LinodeLOCVPSKVMLAVPS2EZ搬瓦工80VPSVultr美国VPS主机中国VPS推荐: 阿里云腾讯云。LNMP付费服务(代装/问题排查)QQ 503228080
发表于 2019-12-16 20:10:27 | 显示全部楼层



phpbird 发表于 2019-12-16 15:06
那就是 imagick  的安装包可能针对centos8有点问题咯,能自己装么?有手工安装的指导么?

谢谢 ...

手动安装参考脚本就是了,这个和安装包没关系是系统依赖包和imagick或imagemagick有问题
Linux下Nginx+MySQL+PHP自动安装工具:https://lnmp.org
发表于 2020-4-8 16:36:48 | 显示全部楼层

这个问题有解了吗

美国VPS、VPN、域名代购:http://shop63846532.taobao.com/

发表于 2020-4-8 20:17:40 | 显示全部楼层

hutaoseven 发表于 2020-4-8 16:36
这个问题有解了吗

centos8与imagick或imagemagick的兼容性问题,暂时无解,除非imagick或imagemagick与其做适配
发表于 2020-4-9 19:30:27 | 显示全部楼层

hutaoseven 发表于 2020-4-8 16:36
这个问题有解了吗

目前改问题已修复,使用最新的1.7重新安装即可
美国VPS推荐: 遨游主机LinodeLOCVPSKVMLAVPS2EZ搬瓦工80VPSVultr美国VPS主机中国VPS推荐: 阿里云腾讯云。LNMP付费服务(代装/问题排查)QQ 503228080
发表于 2020-4-16 15:45:58 | 显示全部楼层



licess 发表于 2020-4-9 19:30
目前改问题已修复,使用最新的1.7重新安装即可

全新安装没问题。

之前安装过,报错然后卸载,现在用新脚本再安装还是报错,是要卸载哪个已安装的依赖重试吗

补充内容 (2020-4-16 16:05):
我尝试如下执行命令

yum remove -y libwebp-devel

然后安装成功了
Linux下Nginx+MySQL+PHP自动安装工具:https://lnmp.org
您需要登录后才可以回帖 登录 | 注册

本版积分规则

小黑屋|手机版|Archiver|VPS侦探 ( 鲁ICP备16040043号-1 )

GMT+8, 2020-7-7 19:44 , Processed in 0.056414 second(s), 26 queries .

Powered by Discuz! X3.4

Copyright © 2001-2020, Tencent Cloud.

快速回复 返回顶部 返回列表