VPS侦探论坛

 找回密码
 注册
查看: 262|回复: 6

lamp全部安装失败,求帮助!

[复制链接]
发表于 2019-12-20 23:48:39 | 显示全部楼层 |阅读模式



CentOS-6.8-x86_64    Linux itop 2.6.32-642.el6.x86_64 #1 SMP Tue May 10 17:27:01 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux

本帖子中包含更多资源

您需要 登录 才可以下载或查看,没有帐号?注册

x
美国VPS推荐: 遨游主机LinodeLOCVPSKVMLAVPS2EZ搬瓦工80VPSVultr美国VPS主机中国VPS推荐: 阿里云腾讯云。LNMP付费服务(代装/问题排查)QQ 503228080
发表于 2019-12-21 19:38:57 | 显示全部楼层


Error: Package: libgcj-4.4.7-17.el6.x86_64 (@anaconda-CentOS-201605220104.x86_64/6.8)
           Requires: libgmp.so.3()(64bit)
           Removing: gmp-4.3.1-10.el6.x86_64 (@anaconda-CentOS-201605220104.x86_64/6.8)
               libgmp.so.3()(64bit)
           Updated By: 1:gmp-6.0.0-15.el7.x86_64 (local-media)
               Not found
Error: Package: ppl-0.10.2-11.el6.x86_64 (@anaconda-CentOS-201605220104.x86_64/6.8)
           Requires: libgmp.so.3()(64bit)
           Removing: gmp-4.3.1-10.el6.x86_64 (@anaconda-CentOS-201605220104.x86_64/6.8)
               libgmp.so.3()(64bit)
           Updated By: 1:gmp-6.0.0-15.el7.x86_64 (local-media)
               Not found
Error: Package: python-crypto-2.0.1-22.el6.x86_64 (@anaconda-CentOS-201605220104.x86_64/6.8)
           Requires: python(abi) = 2.6
           Removing: python-2.6.6-64.el6.x86_64 (@anaconda-CentOS-201605220104.x86_64/6.8)
               python(abi) = 2.6
           Updated By: python-2.7.5-76.el7.x86_64 (local-media)
               python(abi) = 2.7
               python(abi) = 2.7
Error: Package: notify-python-0.1.1-10.el6.x86_64 (@anaconda-CentOS-201605220104.x86_64/6.8)
           Requires: libnotify.so.1()(64bit)
           Removing: libnotify-0.5.0-1.el6.x86_64 (@anaconda-CentOS-201605220104.x86_64/6.8)
               libnotify.so.1()(64bit)
           Updated By: libnotify-0.7.7-1.el7.x86_64 (local-media)
               Not found
Error: Package: notify-python-0.1.1-10.el6.x86_64 (@anaconda-CentOS-201605220104.x86_64/6.8)
           Requires: python(abi) = 2.6
           Removing: python-2.6.6-64.el6.x86_64 (@anaconda-CentOS-201605220104.x86_64/6.8)
               python(abi) = 2.6
           Updated By: python-2.7.5-76.el7.x86_64 (local-media)
               python(abi) = 2.7
               python(abi) = 2.7
Error: Package: hal-info-20090716-5.el6.noarch (@anaconda-CentOS-201605220104.x86_64/6.8)
           Requires: hal >= 0.5.10
           Removing: hal-0.5.14-14.el6.x86_64 (@anaconda-CentOS-201605220104.x86_64/6.8)
               hal = 0.5.14-14.el6
           Obsoleted By: systemd-219-62.el7.x86_64 (local-media)
               Not found
Error: Package: 2:vim-enhanced-7.4.629-5.el6.x86_64 (@anaconda-CentOS-201605220104.x86_64/6.8)
           Requires: perl(:MODULE_COMPAT_5.10.1)
           Removing: 4:perl-5.10.1-141.el6_7.1.x86_64 (@anaconda-CentOS-201605220104.x86_64/6.8)
               perl(:MODULE_COMPAT_5.10.1)
           Updated By: 4:perl-5.16.3-293.el7.x86_64 (local-media)
               Not found
You could try using --skip-broken to work around the problem
** Found 12 pre-existing rpmdb problem(s), 'yum check' output follows:
autoconf-2.69-11.el7.noarch is a duplicate with autoconf-2.63-5.1.el6.noarch
bash-4.2.46-31.el7.x86_64 has installed conflicts filesystem < ('0', '3', None): filesystem-2.4.30-3.el6.x86_64
bison-3.0.4-2.el7.x86_64 is a duplicate with bison-2.4.1-5.el6.x86_64
diffutils-3.3-4.el7.x86_64 is a duplicate with diffutils-2.8.1-28.el6.x86_64
flex-2.5.37-6.el7.x86_64 is a duplicate with flex-2.5.35-9.el6.x86_64
libidn-1.28-4.el7.x86_64 is a duplicate with libidn-1.18-2.el6.x86_64
m4-1.4.16-10.el7.x86_64 is a duplicate with m4-1.4.13-5.el6.x86_64
ncurses-base-5.9-14.20130511.el7_4.noarch has installed conflicts filesystem < ('0', '3', None): filesystem-2.4.30-3.el6.x86_64
nspr-4.19.0-1.el7_5.x86_64 has installed conflicts filesystem < ('0', '3', None): filesystem-2.4.30-3.el6.x86_64
nss-softokn-freebl-3.36.0-5.el7_5.i686 has installed conflicts filesystem < ('0', '3', None): filesystem-2.4.30-3.el6.x86_64
nss-softokn-freebl-3.36.0-5.el7_5.x86_64 has installed conflicts filesystem < ('0', '3', None): filesystem-2.4.30-3.el6.x86_64
2:tar-1.26-35.el7.x86_64 is a duplicate with 2:tar-1.23-14.el6.x86_64

你系统yum都不能正常工作肯定是无法安装,安装要求上有说明
而且安装脚本可能被修改过或者动过,只有部分返回信息
Linux下Nginx+MySQL+PHP自动安装工具:https://lnmp.org
 楼主| 发表于 2019-12-21 23:39:20 | 显示全部楼层



licess 发表于 2019-12-21 19:38
你系统yum都不能正常工作肯定是无法安装,安装要求上有说明
而且安装脚本可能被修改过或者动过,只有部分 ...

我是centos6.8  没有外网 需要无网安装lamp
我用的是这个方法:
CentOS 使用光盘ISO镜像搭建本地源实现离线/无网络yum安装软件或lnmp
完整版:
http://soft.vpser.net/lnmp/lnmp1.6-full.tar.gz
文件大小:677MB MD5:84ccc974c42b43747c0f799573a3abe3
1、下载CentOS光盘镜像
下面以CentOS 7 为例,目前是国内环境,我们使用国内163源的镜像 http://mirrors.163.com/centos/7/isos/x86_64/ ,当然阿里云、华中科大的源都行。
下载地址:http://mirrors.163.com/centos/7/isos/x86_64/CentOS-7-x86_64-Everything-1810.iso
美国VPS推荐: 遨游主机LinodeLOCVPSKVMLAVPS2EZ搬瓦工80VPSVultr美国VPS主机中国VPS推荐: 阿里云腾讯云。LNMP付费服务(代装/问题排查)QQ 503228080
 楼主| 发表于 2019-12-21 23:40:39 | 显示全部楼层



licess 发表于 2019-12-21 19:38
你系统yum都不能正常工作肯定是无法安装,安装要求上有说明
而且安装脚本可能被修改过或者动过,只有部分 ...

请问如果解决系统yum问题。
安装脚本我没有修改和动过。
Linux下Nginx+MySQL+PHP自动安装工具:https://lnmp.org
发表于 2019-12-22 17:08:04 | 显示全部楼层

AH540603277 发表于 2019-12-21 23:40
请问如果解决系统yum问题。
安装脚本我没有修改和动过。

按3楼你说的,你是centos 6,而你用centos 7的光盘源肯定是会造成系统依赖关系混乱而无法正常安装

美国VPS、VPN、域名代购:http://shop63846532.taobao.com/

 楼主| 发表于 2019-12-22 18:00:12 来自手机 | 显示全部楼层

licess 发表于 2019-12-22 17:08
按3楼你说的,你是centos 6,而你用centos 7的光盘源肯定是会造成系统依赖关系混乱而无法正常安装 ...

我用6自带的光盘镜像也还是不行,请问该如何解决呢
发表于 2019-12-23 11:17:16 | 显示全部楼层

AH540603277 发表于 2019-12-22 18:00
我用6自带的光盘镜像也还是不行,请问该如何解决呢

需要你自己修复依赖关系混乱的问题或最简单的方法重装,正常设置源
美国VPS推荐: 遨游主机LinodeLOCVPSKVMLAVPS2EZ搬瓦工80VPSVultr美国VPS主机中国VPS推荐: 阿里云腾讯云。LNMP付费服务(代装/问题排查)QQ 503228080
您需要登录后才可以回帖 登录 | 注册

本版积分规则

小黑屋|手机版|Archiver|VPS侦探 ( 鲁ICP备16040043号-1 )

GMT+8, 2020-1-21 01:47 , Processed in 0.050181 second(s), 27 queries .

Powered by Discuz! X3.4

Copyright © 2001-2020, Tencent Cloud.

快速回复 返回顶部 返回列表