VPS侦探论坛

 找回密码
 注册
查看: 392|回复: 1

各位有升级PHP-7.4.1版本的吗?Libzip的问题是怎么解决的?

[复制链接]
发表于 2020-1-8 19:46:12 | 显示全部楼层 |阅读模式



CentOS 7 想升级安装 7.4.1版本的PHP尝鲜,结果碰到了这个问题
  1. checking whether to build with XSL support... yes
  2. checking for libxslt >= 1.1.0... yes
  3. checking for libexslt... yes
  4. checking whether to enable zend-test extension... no
  5. checking for zip archive read/write support... yes
  6. checking for libzip >= 0.11... no
  7. configure: error: Package requirements (libzip >= 0.11) were not met:

  8. Requested 'libzip >= 0.11' but version of libzip is 0.10.1

  9. Consider adjusting the PKG_CONFIG_PATH environment variable if you
  10. installed software in a non-standard prefix.

  11. Alternatively, you may set the environment variables LIBZIP_CFLAGS
  12. and LIBZIP_LIBS to avoid the need to call pkg-config.
  13. See the pkg-config man page for more details.
复制代码
提示libzip版本过低要大于0.11,yum remove libzip后在网上找了一个1.2.0编译安装了一下没好用,编译官网的libzip-1.5.20也不成,编译完是不是哪里不对呢? 链接完文件后始终找不到linzip,是库文件没链接正确,还是哪里有问题呢?请高人指点...
美国VPS推荐: 遨游主机LinodeLOCVPSKVMLAVPS2EZ搬瓦工80VPSVultr美国VPS主机中国VPS推荐: 阿里云腾讯云。LNMP付费服务(代装/问题排查)QQ 503228080
发表于 2020-1-9 14:06:57 | 显示全部楼层


使用lnmp 1.7进行升级或安装php 7.4
Linux下Nginx+MySQL+PHP自动安装工具:https://lnmp.org
您需要登录后才可以回帖 登录 | 注册

本版积分规则

小黑屋|手机版|Archiver|VPS侦探 ( 鲁ICP备16040043号-1 )

GMT+8, 2020-4-3 02:57 , Processed in 0.041708 second(s), 26 queries .

Powered by Discuz! X3.4

Copyright © 2001-2020, Tencent Cloud.

快速回复 返回顶部 返回列表