VPS侦探论坛

 找回密码
 注册
查看: 194|回复: 4

求问:lnmp1.5 多版本php 如果安装php7.3?

[复制链接]
发表于 2020-1-16 17:19:28 | 显示全部楼层 |阅读模式



当前使用的是lnmp1.5版本
php使用的是多版本模式 已安装php5.3和php7.1
现在需要增加安装php7.3版本.要如何操作./install.sh mphp 下只有7.2
是要先把lnmp1.5 升级到1.6?然后在用./install.sh mphp安装php7.3?这样升级会不会影响原有配置



美国VPS推荐: 遨游主机LinodeLOCVPSKVMLAVPS2EZ搬瓦工80VPSVultr美国VPS主机中国VPS推荐: 阿里云腾讯云。LNMP付费服务(代装/问题排查)QQ 503228080
发表于 2020-1-16 19:48:23 | 显示全部楼层


下载1.6或1.7安装包,然后 ./install.sh mphp 安装所需的多php版本
然后运行安装包下的 ./upgrade1.x-1.6.sh 或 upgrade1.x-1.7.sh
Linux下Nginx+MySQL+PHP自动安装工具:https://lnmp.org
 楼主| 发表于 2020-1-17 09:41:23 | 显示全部楼层



是指先用1.6或者1.7的安装包里的./install.sh mphp 安装PHP7.3....然后在升级lnmp版本?
美国VPS推荐: 遨游主机LinodeLOCVPSKVMLAVPS2EZ搬瓦工80VPSVultr美国VPS主机中国VPS推荐: 阿里云腾讯云。LNMP付费服务(代装/问题排查)QQ 503228080
 楼主| 发表于 2020-1-17 09:41:40 | 显示全部楼层



licess 发表于 2020-1-16 19:48
下载1.6或1.7安装包,然后 ./install.sh mphp 安装所需的多php版本
然后运行安装包下的 ./upgrade1.x-1.6.s ...

是指先用1.6或者1.7的安装包里的./install.sh mphp 安装PHP7.3....然后在升级lnmp版本?
Linux下Nginx+MySQL+PHP自动安装工具:https://lnmp.org
发表于 2020-1-17 12:33:23 | 显示全部楼层

两个步骤没有先后顺序
upgrade1.x-1.6.sh 只是lnmp管理脚本和依赖包升级工具不是lnmp整体升级工具

美国VPS、VPN、域名代购:http://shop63846532.taobao.com/

您需要登录后才可以回帖 登录 | 注册

本版积分规则

小黑屋|手机版|Archiver|VPS侦探 ( 鲁ICP备16040043号-1 )

GMT+8, 2020-4-1 08:53 , Processed in 0.050937 second(s), 26 queries .

Powered by Discuz! X3.4

Copyright © 2001-2020, Tencent Cloud.

快速回复 返回顶部 返回列表