VPS侦探论坛

 找回密码
 注册
查看: 557|回复: 5

centos8安装lnmp1.7失败

[复制链接]
发表于 2020-2-7 12:54:08 | 显示全部楼层 |阅读模式



真不好意思,又来麻烦军哥了。虚拟机安装centos8,安装lnmp1.7失败了。安装的lnmpa , 安装都显示成功了,最后提示check install的时候提示php和apache失败。


安装日志:http://tmp.link/f/5e3ced71e3686


美国VPS推荐: 遨游主机LinodeLOCVPSKVMLAVPS2EZ搬瓦工80VPSVultr美国VPS主机中国VPS推荐: 阿里云腾讯云。LNMP付费服务(代装/问题排查)QQ 503228080
发表于 2020-2-7 20:24:41 | 显示全部楼层


因为你自己直接修改脚本添加了 --enable-imap 的php编译参数,但是你并未为其提前安装或在脚本中加入该模块的依赖包
但是呢这个centos8上 libc-client-devel         uw-imap-devel 这些都没有,然后这就尴尬了,更尴尬的是使用年久失修的源码imap-2007f在新linux发行版会各种报错
Linux下Nginx+MySQL+PHP自动安装工具:https://lnmp.org
 楼主| 发表于 2020-2-8 12:21:21 | 显示全部楼层



原来如此,怪不得在php目录下编译imap也会报错。 但是在ubuntu18下面就可以通过。  那这个以后会添加依赖包支持吗? 另外想提一个建议,IMAP这个模块比较常用,建议添加到默认安装里面,像opcache那样默认不启动也行啊。
美国VPS推荐: 遨游主机LinodeLOCVPSKVMLAVPS2EZ搬瓦工80VPSVultr美国VPS主机中国VPS推荐: 阿里云腾讯云。LNMP付费服务(代装/问题排查)QQ 503228080
发表于 2020-2-8 19:57:42 | 显示全部楼层



liren60 发表于 2020-2-8 12:21
原来如此,怪不得在php目录下编译imap也会报错。 但是在ubuntu18下面就可以通过。  那这个以后会添加依赖包 ...

centos官方都没发centos 8的php-imap的包,我就更无能为力,需要imap-2007f方面或有其他人对imap-2007f进行适配
Linux下Nginx+MySQL+PHP自动安装工具:https://lnmp.org
 楼主| 发表于 2020-2-8 21:08:47 | 显示全部楼层

还好ubuntu18可以用imap, 看来centos对php不太友好,估计现在都向python转了

美国VPS、VPN、域名代购:http://shop63846532.taobao.com/

 楼主| 发表于 2020-2-14 15:20:02 | 显示全部楼层

找到一个解决办法,拷贝Ubuntu下面的libc-client.so到centos依赖库文件夹,然后就可以编译imap模块了。
您需要登录后才可以回帖 登录 | 注册

本版积分规则

小黑屋|手机版|Archiver|VPS侦探 ( 鲁ICP备16040043号-1 )

GMT+8, 2020-9-29 20:38 , Processed in 0.054874 second(s), 26 queries .

Powered by Discuz! X3.4

Copyright © 2001-2020, Tencent Cloud.

快速回复 返回顶部 返回列表