VPS侦探论坛

 找回密码
 注册
查看: 268|回复: 3

PHP7.3中php.ini的output_buffering = on 设置无效的问题

[复制链接]
发表于 2020-2-8 12:30:25 | 显示全部楼层 |阅读模式



                                我在VM虚拟机ubuntu18环境下配置的php.ini中找到
output_buffering
将其设置为output_buffering = on
然后重启服务后查看phpinfo发现output_buffering = 1
设置成output_buffering = 4096则显示正常的output_buffering = 4096
谁知道是怎么回事吗?是不是lnmp安装的php不能设置为output_buffering = on
                           
美国VPS推荐: 遨游主机LinodeLOCVPSKVMLAVPS2EZ搬瓦工80VPSVultr美国VPS主机中国VPS推荐: 阿里云腾讯云。LNMP付费服务(代装/问题排查)QQ 503228080
 楼主| 发表于 2020-2-8 13:46:20 | 显示全部楼层


怪异啊,我查看了php.sh安装脚本文件,发现脚本默认设置的也是output_buffering = on,  为什么安装完成之后就变成了4096,而且改回on无用?
Linux下Nginx+MySQL+PHP自动安装工具:https://lnmp.org
发表于 2020-2-8 19:57:34 | 显示全部楼层



https://www.php.net/manual/en/ou ... ni.output-buffering

一共就3个值:
0 或Off 禁用
On 启用,不指定大小,前台显示就是1
大于1的数,就是你设置的指定大小

lnmp都采用的Production的设置,所以都是4096的默认值
修改后是不会自动生效的,如lnmp模式需要重启php-fpm,lamp/lnmpa模式需要重启apache才会生效,且重启过程中没有报错项目
美国VPS推荐: 遨游主机LinodeLOCVPSKVMLAVPS2EZ搬瓦工80VPSVultr美国VPS主机中国VPS推荐: 阿里云腾讯云。LNMP付费服务(代装/问题排查)QQ 503228080
 楼主| 发表于 2020-2-8 20:58:50 | 显示全部楼层



本帖最后由 liren60 于 2020-2-8 21:03 编辑

我猜想也是如此,被那个程序误导了,我下了一个国外的开源php,他检测推荐环境一直要求output_buffering = on
我怎么设置on也是显示1,然后他还是提示我的值是1,不是要求的“on”。 害我以为哪里错了,没想到外国人也这么不严谨啊。

顺便问一下,我设置两个能不能有用,用于满足那个变态检测的要求。

output_buffering=On
output_buffering=“On”

这样会有用吗? 这样弄了以后好像PHPinfo能显示output_buffering=On,但是不知道实际output_buffering=?
Linux下Nginx+MySQL+PHP自动安装工具:https://lnmp.org
您需要登录后才可以回帖 登录 | 注册

本版积分规则

小黑屋|手机版|Archiver|VPS侦探 ( 鲁ICP备16040043号-1 )

GMT+8, 2020-7-15 15:48 , Processed in 0.091249 second(s), 26 queries .

Powered by Discuz! X3.4

Copyright © 2001-2020, Tencent Cloud.

快速回复 返回顶部 返回列表