VPS侦探论坛

 找回密码
 注册
查看: 296|回复: 5

求助,Lnmp1.4升级PHP7.2.28失败

[复制链接]
发表于 2020-3-10 21:40:05 | 显示全部楼层 |阅读模式



请教军哥,先从Lnmp1.2升级到1.4后再升级PHP,提示失败,请问该如何升级?显示的出错信息如下:
  1. +-----------------------------------------------------------------------+
  2. |            Upgrade script for LNMP V1.4, Written by Licess            |
  3. +-----------------------------------------------------------------------+
  4. |     A tool to upgrade Nginx,MySQL/Mariadb,PHP for LNMP/LNMPA/LAMP     |
  5. +-----------------------------------------------------------------------+
  6. |           For more information please visit https://lnmp.org          |
  7. +-----------------------------------------------------------------------+
  8. Current PHP Version:5.2.17p1
  9. You can get version number from https://www.php.net/
  10. Please enter a PHP Version you want: 7.2.28

  11. Press any key to start...or Press Ctrl+c to cancel
  12. Notice: php-7.2.28.tar.bz2 not found!!!download now...
  13. --2020-03-10 17:40:33--  https://www.php.net/distributions/php-7.2.28.tar.bz2
  14. Resolving www.php.net... 185.85.0.29, 2a02:cb40:200::1ad
  15. Connecting to www.php.net|185.85.0.29|:443... connected.
  16. ERROR: cannot verify www.php.net鈙 certificate, issued by ?C=US/O=DigiCert Inc/OU=www.digicert.com/CN=Thawte TLS RSA CA G1?
  17.   Unable to locally verify the issuer鈙 authority.
  18. To connect to www.php.net insecurely, use ?-no-check-certificate?
  19. --2020-03-10 17:40:34--  https://www.php.net/distributions/php-7.2.28.tar.bz2
  20. Resolving www.php.net... 185.85.0.29, 2a02:cb40:200::1ad
  21. Connecting to www.php.net|185.85.0.29|:443... connected.
  22. ERROR: cannot verify www.php.net鈙 certificate, issued by ?C=US/O=DigiCert Inc/OU=www.digicert.com/CN=Thawte TLS RSA CA G1?
  23.   Unable to locally verify the issuer鈙 authority.
  24. To connect to www.php.net insecurely, use ?-no-check-certificate?
  25. --2020-03-10 17:40:34--  https://museum.php.net/php5/php-7.2.28.tar.bz2
  26. Resolving museum.php.net... 185.85.0.29, 2a02:cb40:200::1ad
  27. Connecting to museum.php.net|185.85.0.29|:443... connected.
  28. ERROR: cannot verify museum.php.net鈙 certificate, issued by ?C=US/O=DigiCert Inc/OU=www.digicert.com/CN=Thawte TLS RSA CA G1?
  29.   Unable to locally verify the issuer鈙 authority.
  30. To connect to museum.php.net insecurely, use ?-no-check-certificate?
  31. You enter PHP Version was:7.2.28
  32. Error! You entered a wrong version number, please check!
复制代码


美国VPS推荐: 遨游主机LinodeLOCVPSKVMLAVPS2EZ搬瓦工80VPSVultr美国VPS主机中国VPS推荐: 阿里云腾讯云。LNMP付费服务(代装/问题排查)QQ 503228080
发表于 2020-3-11 10:36:37 | 显示全部楼层


php 7.2是在lnmp 1.5时才发布的,所以1.4并不支持,升级php 7.2至少是1.5才行
php 7.4至少是lnmp 1.7才行
Linux下Nginx+MySQL+PHP自动安装工具:https://lnmp.org
 楼主| 发表于 2020-3-11 23:00:28 | 显示全部楼层



licess 发表于 2020-3-11 10:36
php 7.2是在lnmp 1.5时才发布的,所以1.4并不支持,升级php 7.2至少是1.5才行
php 7.4至少是lnmp 1.7才行 ...

感谢军哥的回复和解答,请问1.4可以自动升级到1.5吗?
美国VPS推荐: 遨游主机LinodeLOCVPSKVMLAVPS2EZ搬瓦工80VPSVultr美国VPS主机中国VPS推荐: 阿里云腾讯云。LNMP付费服务(代装/问题排查)QQ 503228080
 楼主| 发表于 2020-3-12 01:30:29 | 显示全部楼层



用1.4升级的办法升级了1.5的版本
wget -c http://soft.vpser.net/lnmp/lnmp1.5.tar.gz && tar zxf lnmp1.5.tar.gz && cd lnmp1.5 && ./upgrade1.x-1.5.sh
然后进入该目录cd /root/lnmp1.5
执行PHP升级命令./upgrade.sh php 7.2.28升级错误,没有安装成功,改用7.2.0升级成功。
升级执行./upgrade.sh的时候要注意将里面的http://修改为https://就是下载php版本压缩包的地址,否则提示找不到。
由于是1.2的LNMP到现在好多年了,为了升级DSICUZ X3.4才伤筋动骨做升级系统的危险的事情,因为X3.4在5.2PHP下页面是空白。

新问题来了,升级了PHP7.2后老帖提示:找不到帖子,正在排查中....
Linux下Nginx+MySQL+PHP自动安装工具:https://lnmp.org
发表于 2020-3-12 09:22:25 | 显示全部楼层

XinBIM 发表于 2020-3-12 01:30
用1.4升级的办法升级了1.5的版本
wget -c http://soft.vpser.net/lnmp/lnmp1.5.tar.gz && tar zxf lnmp1.5. ...

发错误日志看一下

美国VPS、VPN、域名代购:http://shop63846532.taobao.com/

 楼主| 发表于 2020-3-22 22:54:55 | 显示全部楼层

军哥,您好!和升级PHP没有关系,丢失了帖子的表,后来补充好了。
您需要登录后才可以回帖 登录 | 注册

本版积分规则

小黑屋|手机版|Archiver|VPS侦探 ( 鲁ICP备16040043号-1 )

GMT+8, 2020-6-4 05:58 , Processed in 0.106306 second(s), 26 queries .

Powered by Discuz! X3.4

Copyright © 2001-2020, Tencent Cloud.

快速回复 返回顶部 返回列表