VPS侦探论坛

 找回密码
 注册
查看: 75|回复: 5

在ubuntu上安装多php环境出现php7安装失败

[复制链接]
发表于 2020-3-12 17:01:01 | 显示全部楼层 |阅读模式



在ubuntu上安装多php环境出现php7安装失败,附上安装日志,请问怎么解决?

本帖子中包含更多资源

您需要 登录 才可以下载或查看,没有帐号?注册

x
美国VPS推荐: 遨游主机LinodeLOCVPSKVMLAVPS2EZ搬瓦工80VPSVultr美国VPS主机中国VPS推荐: 阿里云腾讯云。LNMP付费服务(代装/问题排查)QQ 503228080
 楼主| 发表于 2020-3-12 19:03:02 | 显示全部楼层


checking libxml2 install dir... /usr
checking for xml2-config path... /usr/bin/xml2-config
checking whether libxml build works... no
configure: error: build test failed.  Please check the config.log for details.
make: *** No targets specified and no makefile found.  Stop.
make: *** No targets specified and no makefile found.  Stop.
make: *** No rule to make target 'install'.  Stop.
@军哥 更新了一些库以后,第二次安装php7.3,完全没有办法下去了,这是不是要清理什么东西才能继续执行吗?附带安装日志

本帖子中包含更多资源

您需要 登录 才可以下载或查看,没有帐号?注册

x
Linux下Nginx+MySQL+PHP自动安装工具:https://lnmp.org
发表于 2020-3-12 19:10:12 | 显示全部楼层



/www/lnmp1.6/src/php-7.3.6/ext/intl/intl_convertcpp.cpp:43:9: error: ‘u_strFromUTF8WithSub_63’ was not declared in this scope
   status);
         ^
/www/lnmp1.6/src/php-7.3.6/ext/intl/intl_convertcpp.cpp: In function ‘zend_string* intl_charFromString(const icu_63::UnicodeString&, UErrorCode*)’:
/www/lnmp1.6/src/php-7.3.6/ext/intl/intl_convertcpp.cpp:75:8: error: ‘UChar’ does not name a type
  const UChar *utf16buf = from.getBuffer();
        ^
/www/lnmp1.6/src/php-7.3.6/ext/intl/intl_convertcpp.cpp:77:61: error: ‘utf16buf’ was not declared in this scope
  u_strToUTF8WithSub(ZSTR_VAL(u8res), capacity, &actual_len, utf16buf, from.length(),
                                                             ^
Makefile:1196: recipe for target 'ext/intl/intl_convertcpp.lo' failed
make: *** [ext/intl/intl_convertcpp.lo] Error 1

你系统什么版本, ubuntu 19.10?
有可能是icu版本太高与当前php兼容性问题
选择php 7.3目前最新的7.3.14试试
美国VPS推荐: 遨游主机LinodeLOCVPSKVMLAVPS2EZ搬瓦工80VPSVultr美国VPS主机中国VPS推荐: 阿里云腾讯云。LNMP付费服务(代装/问题排查)QQ 503228080
 楼主| 发表于 2020-3-12 19:18:55 | 显示全部楼层



licess 发表于 2020-3-12 19:10
你系统什么版本, ubuntu 19.10?
有可能是icu版本太高与当前php兼容性问题
选择php 7.3目前最新的7.3.14 ...

我的ubuntu版本是Ubuntu 16.04.6 LTS,算是比较老的版本了
Linux下Nginx+MySQL+PHP自动安装工具:https://lnmp.org
 楼主| 发表于 2020-3-13 09:21:32 | 显示全部楼层

@军哥 我终于解决了,有些软件的dev版本漏装和intl版本不兼容导致的,谢谢军哥指点。
最后建议军哥在下一个版本中,把config.log在安装出现问题后,可以移到外面来,方便检查问题,原来config.log文件随着php的源文件一起删除了。

美国VPS、VPN、域名代购:http://shop63846532.taobao.com/

发表于 2020-3-13 12:06:14 | 显示全部楼层

boshi_no_1 发表于 2020-3-13 09:21
@军哥 我终于解决了,有些软件的dev版本漏装和intl版本不兼容导致的,谢谢军哥指点。
最后建议军哥在下一个 ...

从日志上看你icu版本是63,只有ubuntu 19.10是icu63,所以问你是不是ubuntu 19.10
不是ubuntu 19.10的话肯定就是系统上icu及相关的依赖包版本有问题
只要提供完整系统信息,只要有编译过程的错误信息基本上就能确定问题
您需要登录后才可以回帖 登录 | 注册

本版积分规则

小黑屋|手机版|Archiver|VPS侦探 ( 鲁ICP备16040043号-1 )

GMT+8, 2020-4-4 13:45 , Processed in 0.092649 second(s), 27 queries .

Powered by Discuz! X3.4

Copyright © 2001-2020, Tencent Cloud.

快速回复 返回顶部 返回列表