VPS侦探论坛

 找回密码
 注册
查看: 201|回复: 2

树莓派4安装LNMP报错

[复制链接]
发表于 2020-4-1 22:57:32 | 显示全部楼层 |阅读模式



  1. ============================= Check install ==============================
  2. Checking ...
  3. Error: Nginx install failed.
  4. Error: MySQL install failed.
  5. Error: PHP install failed.
  6. Sorry, Failed to install LNMP!
  7. Please visit https://bbs.vpser.net/forum-25-1.html feedback errors and logs.
  8. You can download /root/lnmp-install.log from your server,and upload lnmp-install.log to LNMP Forum.
复制代码
设备:树莓派4B
系统:Ubuntu18.04.4(ubuntu-18.04.4-preinstalled-server-arm64+raspi3)
稍微看了下可能包有问题?
日志:





本帖子中包含更多资源

您需要 登录 才可以下载或查看,没有帐号?注册

x
美国VPS推荐: 遨游主机LinodeLOCVPSKVMLAVPS2EZ搬瓦工80VPSVultr美国VPS主机中国VPS推荐: 阿里云腾讯云。LNMP付费服务(代装/问题排查)QQ 503228080
发表于 2020-4-2 09:06:57 | 显示全部楼层


Reading package lists...
Building dependency tree...
Reading state information...
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
gcc : Depends: cpp (>= 4:7.4.0-1ubuntu2.3) but it is not going to be installed
       Depends: gcc-7 (>= 7.4.0-1~) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
Reading package lists...
Building dependency tree...
Reading state information...
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
g++ : Depends: cpp (>= 4:7.4.0-1ubuntu2.3) but it is not going to be installed
       Depends: gcc (>= 4:7.4.0-1ubuntu2.3) but it is not going to be installed
       Depends: g++-7 (>= 7.4.0-1~) but it is not going to be installed
       Depends: gcc-7 (>= 7.4.0-1~) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
Reading package lists...
Building dependency tree...
Reading state information...
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
make-guile : Depends: guile-2.0-libs but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
Reading package lists...
Building dependency tree...
Reading state information...
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
cmake : Depends: libjsoncpp1 (>= 1.7.4) but it is not installable
         Depends: librhash0 (>= 1.2.6) but it is not installable
E: Unable to correct problems, you have held broken packages.

你系统上依赖关系有问题,有可能之前设置错了系统源版本或其他问题导致的依赖关系混乱
可以尝试安装aptitude,使用aptitude进行修复或恢复原初始镜像
Linux下Nginx+MySQL+PHP自动安装工具:https://lnmp.org
 楼主| 发表于 2020-4-2 10:15:12 | 显示全部楼层



licess 发表于 2020-4-2 09:06
你系统上依赖关系有问题,有可能之前设置错了系统源版本或其他问题导致的依赖关系混乱
可以尝试安装aptitu ...

好的,我试试,谢谢
美国VPS推荐: 遨游主机LinodeLOCVPSKVMLAVPS2EZ搬瓦工80VPSVultr美国VPS主机中国VPS推荐: 阿里云腾讯云。LNMP付费服务(代装/问题排查)QQ 503228080
您需要登录后才可以回帖 登录 | 注册

本版积分规则

小黑屋|手机版|Archiver|VPS侦探 ( 鲁ICP备16040043号-1 )

GMT+8, 2020-5-31 18:56 , Processed in 0.046063 second(s), 28 queries .

Powered by Discuz! X3.4

Copyright © 2001-2020, Tencent Cloud.

快速回复 返回顶部 返回列表