VPS侦探论坛

 找回密码
 注册
查看: 265|回复: 1

亚马逊云CentOS7.4一键安装包失败

[复制链接]
发表于 2020-4-26 22:06:11 | 显示全部楼层 |阅读模式



军哥,你好。
系统版本CentOS Linux release 7.4.1708 (Core),麻烦看一下是什么原因,谢谢!


本帖子中包含更多资源

您需要 登录 才可以下载或查看,没有帐号?注册

x
美国VPS推荐: 遨游主机LinodeLOCVPSKVMLAVPS2EZ搬瓦工80VPSVultr美国VPS主机中国VPS推荐: 阿里云腾讯云。LNMP付费服务(代装/问题排查)QQ 503228080
发表于 2020-4-27 10:29:48 | 显示全部楼层


已加载插件:fastestmirror
正在清理软件源: ultra-centos-7.4-base ultra-centos-7.4-extras
               : ultra-centos-7.4-updates ultra-centos-7.x-ius
               : ultra-centos-7.x-newrelic-monitoring ultra-centos-7.x-ultrarepo
Cleaning up everything
Maybe you want: rm -rf /var/cache/yum, to also free up space taken by orphaned data from disabled or removed repos
Cleaning up list of fastest mirrors
。。。。。
.....

已加载插件:fastestmirror
Loading mirror speeds from cached hostfile
正在解决依赖关系
--> 正在检查事务
---> 软件包 gcc.x86_64.0.4.8.5-16.el7_4.2 将被 安装
--> 正在处理依赖关系 libgomp = 4.8.5-16.el7_4.2,它被软件包 gcc-4.8.5-16.el7_4.2.x86_64 需要
--> 正在处理依赖关系 cpp = 4.8.5-16.el7_4.2,它被软件包 gcc-4.8.5-16.el7_4.2.x86_64 需要
--> 正在处理依赖关系 glibc-devel >= 2.2.90-12,它被软件包 gcc-4.8.5-16.el7_4.2.x86_64 需要
--> 正在处理依赖关系 libmpfr.so.4()(64bit),它被软件包 gcc-4.8.5-16.el7_4.2.x86_64 需要
--> 正在处理依赖关系 libmpc.so.3()(64bit),它被软件包 gcc-4.8.5-16.el7_4.2.x86_64 需要
--> 正在检查事务
---> 软件包 cpp.x86_64.0.4.8.5-16.el7_4.2 将被 安装
---> 软件包 gcc.x86_64.0.4.8.5-16.el7_4.2 将被 安装
--> 正在处理依赖关系 libgomp = 4.8.5-16.el7_4.2,它被软件包 gcc-4.8.5-16.el7_4.2.x86_64 需要
---> 软件包 glibc-devel.x86_64.0.2.17-196.el7_4.2 将被 安装
--> 正在处理依赖关系 glibc-headers = 2.17-196.el7_4.2,它被软件包 glibc-devel-2.17-196.el7_4.2.x86_64 需要
--> 正在处理依赖关系 glibc = 2.17-196.el7_4.2,它被软件包 glibc-devel-2.17-196.el7_4.2.x86_64 需要
--> 正在处理依赖关系 glibc-headers,它被软件包 glibc-devel-2.17-196.el7_4.2.x86_64 需要
---> 软件包 libmpc.x86_64.0.1.0.1-3.el7 将被 安装
---> 软件包 mpfr.x86_64.0.3.1.1-4.el7 将被 安装
--> 正在检查事务
---> 软件包 gcc.x86_64.0.4.8.5-16.el7_4.2 将被 安装
--> 正在处理依赖关系 libgomp = 4.8.5-16.el7_4.2,它被软件包 gcc-4.8.5-16.el7_4.2.x86_64 需要
---> 软件包 glibc-devel.x86_64.0.2.17-196.el7_4.2 将被 安装
--> 正在处理依赖关系 glibc = 2.17-196.el7_4.2,它被软件包 glibc-devel-2.17-196.el7_4.2.x86_64 需要
---> 软件包 glibc-headers.x86_64.0.2.17-196.el7_4.2 将被 安装
--> 正在处理依赖关系 glibc = 2.17-196.el7_4.2,它被软件包 glibc-headers-2.17-196.el7_4.2.x86_64 需要
--> 正在处理依赖关系 kernel-headers >= 2.2.1,它被软件包 glibc-headers-2.17-196.el7_4.2.x86_64 需要
--> 正在处理依赖关系 kernel-headers,它被软件包 glibc-headers-2.17-196.el7_4.2.x86_64 需要
--> 正在检查事务
---> 软件包 gcc.x86_64.0.4.8.5-16.el7_4.2 将被 安装
--> 正在处理依赖关系 libgomp = 4.8.5-16.el7_4.2,它被软件包 gcc-4.8.5-16.el7_4.2.x86_64 需要
---> 软件包 glibc-devel.x86_64.0.2.17-196.el7_4.2 将被 安装
--> 正在处理依赖关系 glibc = 2.17-196.el7_4.2,它被软件包 glibc-devel-2.17-196.el7_4.2.x86_64 需要
---> 软件包 glibc-headers.x86_64.0.2.17-196.el7_4.2 将被 安装
--> 正在处理依赖关系 glibc = 2.17-196.el7_4.2,它被软件包 glibc-headers-2.17-196.el7_4.2.x86_64 需要
---> 软件包 kernel-headers.x86_64.0.3.10.0-693.21.1.el7 将被 安装
--> 解决依赖关系完成
错误:软件包:glibc-devel-2.17-196.el7_4.2.x86_64 (ultra-centos-7.4-updates)
          需要:glibc = 2.17-196.el7_4.2
          已安装: glibc-2.17-222.el7.x86_64 (installed)
              glibc = 2.17-222.el7
          可用: glibc-2.17-196.el7.x86_64 (ultra-centos-7.4-base)
              glibc = 2.17-196.el7
          可用: glibc-2.17-196.el7_4.2.x86_64 (ultra-centos-7.4-updates)
              glibc = 2.17-196.el7_4.2
错误:软件包:glibc-headers-2.17-196.el7_4.2.x86_64 (ultra-centos-7.4-updates)
          需要:glibc = 2.17-196.el7_4.2
          已安装: glibc-2.17-222.el7.x86_64 (installed)
              glibc = 2.17-222.el7
          可用: glibc-2.17-196.el7.x86_64 (ultra-centos-7.4-base)
              glibc = 2.17-196.el7
          可用: glibc-2.17-196.el7_4.2.x86_64 (ultra-centos-7.4-updates)
              glibc = 2.17-196.el7_4.2
错误:软件包:gcc-4.8.5-16.el7_4.2.x86_64 (ultra-centos-7.4-updates)
          需要:libgomp = 4.8.5-16.el7_4.2
          已安装: libgomp-4.8.5-28.el7_5.1.x86_64 (installed)
              libgomp = 4.8.2-16.el7_5
              libgomp = 4.8.5-28.el7_5.1
          可用: libgomp-4.8.5-16.el7.x86_64 (ultra-centos-7.4-base)
              libgomp = 4.8.5-16.el7
              libgomp = 4.8.2-16.el7
          可用: libgomp-4.8.5-16.el7_4.1.x86_64 (ultra-centos-7.4-updates)
              libgomp = 4.8.5-16.el7_4.1
              libgomp = 4.8.2-16.el7_4
          可用: libgomp-4.8.5-16.el7_4.2.x86_64 (ultra-centos-7.4-updates)
              libgomp = 4.8.5-16.el7_4.2
              libgomp = 4.8.2-16.el7_4
您可以尝试添加 --skip-broken 选项来解决该问题
您可以尝试执行:rpm -Va --nofiles --nodigest

你系统依赖关系有问题肯定无法安装
可以尝试按 https://bbs.vpser.net/thread-17009-1-1.html 解决
yum install gcc 正常可以安装后再安装lnmp
Linux下Nginx+MySQL+PHP自动安装工具:https://lnmp.org
您需要登录后才可以回帖 登录 | 注册

本版积分规则

小黑屋|手机版|Archiver|VPS侦探 ( 鲁ICP备16040043号-1 )

GMT+8, 2020-9-30 22:55 , Processed in 0.051777 second(s), 27 queries .

Powered by Discuz! X3.4

Copyright © 2001-2020, Tencent Cloud.

快速回复 返回顶部 返回列表