VPS侦探论坛

 找回密码
 注册
查看: 189|回复: 1

lnmp1.6/1.7无法安装数据库

[复制链接]
发表于 2020-5-26 12:58:23 | 显示全部楼层 |阅读模式



系统:centos7.8x64
服务商:HostSolutions
内存cpu:1核1G
架构:ovz
服务器从1.5老版本升级到1.6后,原先服务器数据库为5.5,由于网站架构需要mysql5.7+所以使用lnmp自带升级器升级,升级失败后,先用自带的卸载工具卸载lnmp,然后手动删除了所有的lnmp的相关文件。使用1.6重新安装也是失败,尝试使用1.7也同样如此。
附上安装日志

补充内容 (2020-5-26 16:19):
确认服务器安装mysql5.5和5.6没问题,但是安装5.7或者从低版本升级都会有问题

本帖子中包含更多资源

您需要 登录 才可以下载或查看,没有帐号?注册

x
美国VPS推荐: 遨游主机LinodeLOCVPSKVMLAVPS2EZ搬瓦工80VPSVultr美国VPS主机中国VPS推荐: 阿里云腾讯云。LNMP付费服务(代装/问题排查)QQ 503228080
发表于 2020-5-26 20:39:22 | 显示全部楼层


[ 34%] Building CXX object sql/CMakeFiles/sql.dir/item_geofunc.cc.o
c++: internal compiler error: Killed (program cc1plus)
Please submit a full bug report,
with preprocessed source if appropriate.
See <http://bugzilla.redhat.com/bugzilla> for instructions.

mysql 5.7起对机器的配置要求都比较高,kvm的可以添加swap来缓解,但openvz的就不行了,多少内存就是多少
Linux下Nginx+MySQL+PHP自动安装工具:https://lnmp.org
您需要登录后才可以回帖 登录 | 注册

本版积分规则

小黑屋|手机版|Archiver|VPS侦探 ( 鲁ICP备16040043号-1 )

GMT+8, 2020-7-8 06:03 , Processed in 0.052002 second(s), 27 queries .

Powered by Discuz! X3.4

Copyright © 2001-2020, Tencent Cloud.

快速回复 返回顶部 返回列表