VPS侦探论坛

 找回密码
 注册
查看: 255|回复: 7

CentOS 8.1 安装 LNMP V1.6 出错 /usr/local/php/sbin/php-fpm

[复制链接]
发表于 2020-5-29 08:30:26 | 显示全部楼层 |阅读模式



本帖最后由 nanxiaobei 于 2020-5-29 08:31 编辑

Add php-fpm service at system startup...
Starting php-fpm /etc/init.d/php-fpm:行57: /usr/local/php/sbin/php-fpm: 没有那个文件或目录
failed
============================== Check install ==============================
Checking ...
Nginx: OK
Do not install MySQL/MariaDB.
Error: PHP install failed.


lnmp-install.log 下载地址:https://ww.lanzous.com/id3supe

美国VPS推荐: 遨游主机LinodeLOCVPSKVMLAVPS2EZ搬瓦工80VPSVultr美国VPS主机中国VPS推荐: 阿里云腾讯云。LNMP付费服务(代装/问题排查)QQ 503228080
发表于 2020-5-29 09:46:37 | 显示全部楼层


-I/root/lnmp1.6/src/php-7.3.11/Zend    -I/usr/local/include -g -O2 -fvisibility=hidden -DZEND_SIGNALS   -c /root/lnmp1.6/src/php-7.3.11/Zend/zend_execute.c -o Zend/zend_execute.lo
cc: 致命错误:已杀死 signal terminated program cc1
编译中断。
make: *** [Makefile:2303:Zend/zend_execute.lo] 错误 1

最主要的原因,php 7.x版本必须要有1GB,有swap的话要求低一点点的话也可以,具体看系统上是否有其他占用内存的应用
其次centos 8等新发行的版本建议使用lnmp 1.7进行安装
Linux下Nginx+MySQL+PHP自动安装工具:https://lnmp.org
 楼主| 发表于 2020-5-29 14:09:24 | 显示全部楼层



感谢。

我的是 512M 内存,不过我把系统换成 Ubuntu 18.04 后,安装 1.7beta 安装成功了,而 CentOS 8.1 就一直不行。

而我理解是 Ubuntu 占内存多,有点懵逼 ...
美国VPS推荐: 遨游主机LinodeLOCVPSKVMLAVPS2EZ搬瓦工80VPSVultr美国VPS主机中国VPS推荐: 阿里云腾讯云。LNMP付费服务(代装/问题排查)QQ 503228080
 楼主| 发表于 2020-5-31 09:05:01 | 显示全部楼层



换了个 1G 的 CentOS 还是安装失败,可能跟内存大小没关系,我怀疑
Linux下Nginx+MySQL+PHP自动安装工具:https://lnmp.org
发表于 2020-5-31 12:53:52 | 显示全部楼层

nanxiaobei 发表于 2020-5-31 09:05
换了个 1G 的 CentOS 还是安装失败,可能跟内存大小没关系,我怀疑

传日志看看

美国VPS、VPN、域名代购:http://shop63846532.taobao.com/

 楼主| 发表于 2020-5-31 15:35:30 | 显示全部楼层


log 下载:https://wws.lanzous.com/id6lsha
发表于 2020-5-31 19:41:47 | 显示全部楼层

nanxiaobei 发表于 2020-5-31 15:35
log 下载:https://wws.lanzous.com/id6lsha

上次你装的php 7.3,这次你装的php 7.4
安装要求你还是没看全,https://lnmp.org/install.html
PHP 7.4升级或安装必须CentOS 8+,Debian 8+,Ubuntu 16.04+且必须使用1.7!!!
MySQL 8.0升级或安装必须CentOS 8+,Debian 9+,Ubuntu 16.04+且必须使用1.7!!!

这都是强调过的基本条件
美国VPS推荐: 遨游主机LinodeLOCVPSKVMLAVPS2EZ搬瓦工80VPSVultr美国VPS主机中国VPS推荐: 阿里云腾讯云。LNMP付费服务(代装/问题排查)QQ 503228080
 楼主| 发表于 2020-6-1 03:46:39 | 显示全部楼层



licess 发表于 2020-5-31 19:41
上次你装的php 7.3,这次你装的php 7.4
安装要求你还是没看全,https://lnmp.org/install.html

好的感谢。。第一次注意到了,后来就忘了
Linux下Nginx+MySQL+PHP自动安装工具:https://lnmp.org
您需要登录后才可以回帖 登录 | 注册

本版积分规则

小黑屋|手机版|Archiver|VPS侦探 ( 鲁ICP备16040043号-1 )

GMT+8, 2020-8-4 02:19 , Processed in 0.052607 second(s), 26 queries .

Powered by Discuz! X3.4

Copyright © 2001-2020, Tencent Cloud.

快速回复 返回顶部 返回列表