VPS侦探论坛

 找回密码
 注册
查看: 139|回复: 2

deepin 20v 安装lnmp1.7失败

[复制链接]
发表于 2020-6-2 17:54:09 | 显示全部楼层 |阅读模式



只有nginx安装成功,文件限制只能放压缩的,劳烦大佬们看看

本帖子中包含更多资源

您需要 登录 才可以下载或查看,没有帐号?注册

x
美国VPS推荐: 遨游主机LinodeLOCVPSKVMLAVPS2EZ搬瓦工80VPSVultr美国VPS主机中国VPS推荐: 阿里云腾讯云。LNMP付费服务(代装/问题排查)QQ 503228080
 楼主| 发表于 2020-6-2 17:54:56 | 显示全部楼层


大佬们看看

Linux下Nginx+MySQL+PHP自动安装工具:https://lnmp.org
发表于 2020-6-2 20:49:22 | 显示全部楼层



命中:1 http://packages.deepin.com/deepin lion InRelease
命中:3 https://cdn-package-store6.deepin.com/appstore eagle InRelease
命中:4 http://dl.google.com/linux/chrome/deb stable InRelease
命中:2 https://uos.deepin.cn/printer eagle InRelease
正在读取软件包列表...

。。。。。。

有一些软件包无法被安装。如果您用的是 unstable 发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们已被从新到(Incoming)目录移出。
下列信息可能会对解决问题有所帮助:

下列软件包有未满足的依赖关系:
libncurses5-dev : 依赖: libtinfo5 (= 6.0+20161126-1+deb9u2) 但是 6.1+20181013-2+deb10u1+dde 正要被安装
                   依赖: libncurses5 (= 6.0+20161126-1+deb9u2) 但是 6.1+20181013-2+deb10u1+dde 正要被安装
                   依赖: libtinfo-dev (= 6.0+20161126-1+deb9u2) 但是它将不会被安装
E: 无法修正错误,因为您要求某些软件包保持现状,就是它们破坏了软件包间的依赖关系。

...
有一些软件包无法被安装。如果您用的是 unstable 发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们已被从新到(Incoming)目录移出。
下列信息可能会对解决问题有所帮助:

下列软件包有未满足的依赖关系:
libssl-dev : 依赖: libssl1.1 (= 1.1.0j-1~deb9u1) 但是 1.1.1c-1 正要被安装
E: 无法修正错误,因为您要求某些软件包保持现状,就是它们破坏了软件包间的依赖关系。
...
下列软件包有未满足的依赖关系:
libsasl2-dev : 依赖: libsasl2-2 (= 2.1.27~101-g0780600+dfsg-3) 但是 2.1.27+dfsg-1+deb10u1 正要被安装
E: 无法修正错误,因为您要求某些软件包保持现状,就是它们破坏了软件包间的依赖关系。

等等很多个依赖软件包都报错了,这个是deepin 20,codename是eagle,你系统源里设置了个lion,lion是15.11版本的,这是铁定会导致系统各种依赖关系混乱而无法安装的
最简单的方法重装,不拍麻烦的话修正好源后,aptitude install 软件包名 挨个修复
美国VPS推荐: 遨游主机LinodeLOCVPSKVMLAVPS2EZ搬瓦工80VPSVultr美国VPS主机中国VPS推荐: 阿里云腾讯云。LNMP付费服务(代装/问题排查)QQ 503228080
您需要登录后才可以回帖 登录 | 注册

本版积分规则

小黑屋|手机版|Archiver|VPS侦探 ( 鲁ICP备16040043号-1 )

GMT+8, 2020-8-4 02:11 , Processed in 0.070074 second(s), 27 queries .

Powered by Discuz! X3.4

Copyright © 2001-2020, Tencent Cloud.

快速回复 返回顶部 返回列表