VPS侦探论坛

 找回密码
 注册
查看: 141|回复: 4

一直是用lnmp升级php7.3然后升级lnmp1.7后升级php7.3.18后gd库没有

[复制链接]
发表于 2020-6-7 18:51:32 | 显示全部楼层 |阅读模式



本帖最后由 ww82ke 于 2020-6-7 18:56 编辑

怎么处理






本帖子中包含更多资源

您需要 登录 才可以下载或查看,没有帐号?注册

x
美国VPS推荐: 遨游主机LinodeLOCVPSKVMLAVPS2EZ搬瓦工80VPSVultr美国VPS主机中国VPS推荐: 阿里云腾讯云。LNMP付费服务(代装/问题排查)QQ 503228080
发表于 2020-6-8 08:55:07 | 显示全部楼层


发升级日志看一下,什么系统、版本

是否更改参数之类的操作

/usr/local/php/bin/php -i |grep configure 查看是否有--with-gd参数
Linux下Nginx+MySQL+PHP自动安装工具:https://lnmp.org
 楼主| 发表于 2020-6-8 09:54:30 | 显示全部楼层



licess 发表于 2020-6-8 08:55
发升级日志看一下,什么系统、版本

是否更改参数之类的操作

没有修改参数,但是显示 是--enable-gd



脚本文件没有修改过是这样的:

怎么回事,怎么处理?

本帖子中包含更多资源

您需要 登录 才可以下载或查看,没有帐号?注册

x
美国VPS推荐: 遨游主机LinodeLOCVPSKVMLAVPS2EZ搬瓦工80VPSVultr美国VPS主机中国VPS推荐: 阿里云腾讯云。LNMP付费服务(代装/问题排查)QQ 503228080
发表于 2020-6-8 16:35:57 | 显示全部楼层



php 7.4的编译参数是 --eanble-gd 确定没输错,php -v 查看版本

确定没错的话上传日志看一下
也可以重新下载再升级一下
Linux下Nginx+MySQL+PHP自动安装工具:https://lnmp.org
 楼主| 发表于 2020-6-8 18:37:11 | 显示全部楼层

licess 发表于 2020-6-8 16:35
php 7.4的编译参数是 --eanble-gd 确定没输错,php -v 查看版本

确定没错的话上传日志看一下

原来是使用LNMP1.7测试版的问题,重新下载使用正式版重新升级php后正常了,谢谢

美国VPS、VPN、域名代购:http://shop63846532.taobao.com/

您需要登录后才可以回帖 登录 | 注册

本版积分规则

小黑屋|手机版|Archiver|VPS侦探 ( 鲁ICP备16040043号-1 )

GMT+8, 2020-7-2 14:19 , Processed in 0.052276 second(s), 27 queries .

Powered by Discuz! X3.4

Copyright © 2001-2020, Tencent Cloud.

快速回复 返回顶部 返回列表