VPS侦探论坛

 找回密码
 注册
查看: 187|回复: 6

Hostyun CentOS 8 64bit 安装 Lnmp1.7 失败

[复制链接]
发表于 2020-6-9 16:29:28 | 显示全部楼层 |阅读模式



安装时对CentOS进行了升级

升级后安装Lnmp1.7 失败

Hostyun CentOS 8 64bit






本帖子中包含更多资源

您需要 登录 才可以下载或查看,没有帐号?注册

x
美国VPS推荐: 遨游主机LinodeLOCVPSKVMLAVPS2EZ搬瓦工80VPSVultr美国VPS主机中国VPS推荐: 阿里云腾讯云。LNMP付费服务(代装/问题排查)QQ 503228080
发表于 2020-6-9 18:15:30 | 显示全部楼层


Last metadata expiration check: 0:00:03 ago on Tue 09 Jun 2020 04:11:07 PM CST.
Error:
Problem: package gcc-8.3.1-4.5.el8.x86_64 requires glibc-devel >= 2.2.90-12, but none of the providers can be installed
  - package glibc-devel-2.28-72.el8_1.1.i686 requires glibc-headers, but none of the providers can be installed
  - package glibc-devel-2.28-72.el8_1.1.i686 requires glibc-headers = 2.28-72.el8_1.1, but none of the providers can be installed
  - package glibc-devel-2.28-72.el8_1.1.x86_64 requires glibc-headers, but none of the providers can be installed
  - package glibc-devel-2.28-72.el8_1.1.x86_64 requires glibc-headers = 2.28-72.el8_1.1, but none of the providers can be installed
  - package glibc-headers-2.28-72.el8_1.1.i686 requires kernel-headers, but none of the providers can be installed
  - package glibc-headers-2.28-72.el8_1.1.i686 requires kernel-headers >= 2.2.1, but none of the providers can be installed
  - package glibc-headers-2.28-72.el8_1.1.x86_64 requires kernel-headers, but none of the providers can be installed
  - package glibc-headers-2.28-72.el8_1.1.x86_64 requires kernel-headers >= 2.2.1, but none of the providers can be installed
  - conflicting requests
  - package kernel-headers-4.18.0-147.8.1.el8_1.x86_64 is excluded
(try to add '--skip-broken' to skip uninstallable packages or '--nobest' to use not only best candidate packages)
Last metadata expiration check: 0:00:04 ago on Tue 09 Jun 2020 04:11:07 PM CST.
Error:
Problem: package gcc-8.3.1-4.5.el8.x86_64 requires glibc-devel >= 2.2.90-12, but none of the providers can be installed
  - package glibc-devel-2.28-72.el8_1.1.i686 requires glibc-headers, but none of the providers can be installed
  - package glibc-devel-2.28-72.el8_1.1.i686 requires glibc-headers = 2.28-72.el8_1.1, but none of the providers can be installed
  - package glibc-devel-2.28-72.el8_1.1.x86_64 requires glibc-headers, but none of the providers can be installed
  - package glibc-devel-2.28-72.el8_1.1.x86_64 requires glibc-headers = 2.28-72.el8_1.1, but none of the providers can be installed
  - package gcc-c++-8.3.1-4.5.el8.x86_64 requires gcc = 8.3.1-4.5.el8, but none of the providers can be installed
  - package glibc-headers-2.28-72.el8_1.1.i686 requires kernel-headers, but none of the providers can be installed
  - package glibc-headers-2.28-72.el8_1.1.i686 requires kernel-headers >= 2.2.1, but none of the providers can be installed
  - package glibc-headers-2.28-72.el8_1.1.x86_64 requires kernel-headers, but none of the providers can be installed
  - package glibc-headers-2.28-72.el8_1.1.x86_64 requires kernel-headers >= 2.2.1, but none of the providers can be installed
  - conflicting requests
  - package kernel-headers-4.18.0-147.8.1.el8_1.x86_64 is excluded
(try to add '--skip-broken' to skip uninstallable packages or '--nobest' to use not only best candidate packages)

你自己手动 yum install glibc-devel glibc-headers kernel-headers 看一下是否报错
不报错再 yum install gcc 试一下
Linux下Nginx+MySQL+PHP自动安装工具:https://lnmp.org
 楼主| 发表于 2020-6-10 23:49:25 | 显示全部楼层



licess 发表于 2020-6-9 18:15
你自己手动 yum install glibc-devel glibc-headers kernel-headers 看一下是否报错
不报错再 yum install ...



No match for argument: kernel-headers
Error: Unable to find a match: kernel-headers
美国VPS推荐: 遨游主机LinodeLOCVPSKVMLAVPS2EZ搬瓦工80VPSVultr美国VPS主机中国VPS推荐: 阿里云腾讯云。LNMP付费服务(代装/问题排查)QQ 503228080
 楼主| 发表于 2020-6-11 00:21:50 | 显示全部楼层



licess 发表于 2020-6-9 18:15
你自己手动 yum install glibc-devel glibc-headers kernel-headers 看一下是否报错
不报错再 yum install ...

[root@XS1419818 ~]# yum --enablerepo=elrepo-kernel -y install kernel-ml-headers
Last metadata expiration check: 0:16:00 ago on Thu 11 Jun 2020 12:04:32 AM CST.
No match for argument: kernel-ml-headers
Error: Unable to find a match: kernel-ml-headers
Linux下Nginx+MySQL+PHP自动安装工具:https://lnmp.org
发表于 2020-6-11 08:39:03 | 显示全部楼层

kernel-headers是centos 8 baseos的包,是最基本的源,没找到这个包估计可能系统源配置有问题

美国VPS、VPN、域名代购:http://shop63846532.taobao.com/

 楼主| 发表于 2020-6-11 10:37:12 | 显示全部楼层

licess 发表于 2020-6-11 08:39
kernel-headers是centos 8 baseos的包,是最基本的源,没找到这个包估计可能系统源配置有问题 ...

谢谢军哥,在hostyun提交工单客服给的建议就是让我重装系统后再试;

使用官方提供的entOS 8 64bit系统目前只安装了以下
yum install epel-release
yum install -y tar
yum -y install wget
yum install screen

更新系统
yum update

对于客服给的建议我很无奈。
发表于 2020-6-11 13:16:30 | 显示全部楼层

xiancn 发表于 2020-6-11 10:37
谢谢军哥,在hostyun提交工单客服给的建议就是让我重装系统后再试;

使用官方提供的entOS 8 64bit系统目 ...

轮胎里有centos源设置教程可以自己搜索一下:CentOS更换源
美国VPS推荐: 遨游主机LinodeLOCVPSKVMLAVPS2EZ搬瓦工80VPSVultr美国VPS主机中国VPS推荐: 阿里云腾讯云。LNMP付费服务(代装/问题排查)QQ 503228080
您需要登录后才可以回帖 登录 | 注册

本版积分规则

小黑屋|手机版|Archiver|VPS侦探 ( 鲁ICP备16040043号-1 )

GMT+8, 2020-7-2 13:21 , Processed in 0.066266 second(s), 27 queries .

Powered by Discuz! X3.4

Copyright © 2001-2020, Tencent Cloud.

快速回复 返回顶部 返回列表