VPS侦探论坛

 找回密码
 注册
查看: 138|回复: 5

请问是否可以升级到redis的版本6.0.6?

[复制链接]
发表于 2020-8-18 12:35:45 | 显示全部楼层 |阅读模式



如题,因为redis新版修正了不少问题,希望能尽快升级,多谢
美国VPS推荐: 遨游主机LinodeLOCVPSKVMLAVPS2EZ搬瓦工80VPSVultr美国VPS主机中国VPS推荐: 阿里云腾讯云。LNMP付费服务(代装/问题排查)QQ 503228080
发表于 2020-8-18 13:24:21 | 显示全部楼层


停掉redis,并删除掉 /usr/local/redis/bin/redis-server 然后下载最新版的lnmp,再安装一次就是最新版的
Linux下Nginx+MySQL+PHP自动安装工具:https://lnmp.org
 楼主| 发表于 2020-8-18 14:54:53 | 显示全部楼层



您好,我服务器之前没安装过reids,删除了旧版lnmp1.7安装文件后,重新下载lnmp1.7,然后执行./addons.sh install redis

可是很奇怪,命令行上显示要安装6.0.6,可是后面却安装了5.0.9,但界面中还显示中间下载安装了5.3.1??,请问这是咱们安装脚本预期的行为吗?


Hint: It's a good idea to run 'make test' ;)

    INSTALL install
    INSTALL install
    INSTALL install
    INSTALL install
    INSTALL install
make[1]: 离开目录“/root/lnmp1.7/src/redis-5.0.9/src”
iptables: Saving firewall rules to /etc/sysconfig/iptables:[  OK  ]
Redirecting to /bin/systemctl reload iptables.service
Job for iptables.service invalid.
Notice: redis-5.3.1.tgz not found!!!download now...
--2020-08-18 13:58:15--  http://pecl.php.net/get/redis-5.3.1.tgz
正在解析主机 pecl.php.net (pecl.php.net)... 104.236.228.160
正在连接 pecl.php.net (pecl.php.net)|104.236.228.160|:80... 已连接。
已发出 HTTP 请求,正在等待回应... 200 OK
长度:264485 (258K) [application/octet-stream]
正在保存至: “redis-5.3.1.tgz”

100%[========================================================================================================================================>] 264,485     10.8KB/s 用时 22s   
美国VPS推荐: 遨游主机LinodeLOCVPSKVMLAVPS2EZ搬瓦工80VPSVultr美国VPS主机中国VPS推荐: 阿里云腾讯云。LNMP付费服务(代装/问题排查)QQ 503228080
 楼主| 发表于 2020-8-18 14:57:36 | 显示全部楼层



这个是安装一开始的时候,显示的要安装6.0.6,以及安装5.0.9的日志。。。


[root@VM_0_5_centos lnmp1.7]# ./addons.sh install redis

+-----------------------------------------------------------------------+
|            Addons script for LNMP V1.6, Written by Licess             |
+-----------------------------------------------------------------------+
|    A tool to Install cache,optimizer,accelerator...addons for LNMP    |
+-----------------------------------------------------------------------+
|           For more information please visit https://lnmp.org          |
+-----------------------------------------------------------------------+
====== Installing Redis ======
Install redis-6.0.6 Stable Version...

Press any key to start...or Press Ctrl+c to cancel

Notice: redis-5.0.9.tar.gz not found!!!download now...
--2020-08-18 13:54:49--  http://download.redis.io/releases/redis-5.0.9.tar.gz
正在解析主机 download.redis.io (download.redis.io)... 45.60.125.1
正在连接 download.redis.io (download.redis.io)|45.60.125.1|:80... 已连接。
已发出 HTTP 请求,正在等待回应... 200 OK
长度:1986574 (1.9M) [application/octet-stream]
正在保存至: “redis-5.0.9.tar.gz”

100%[========================================================================================================================================>] 1,986,574   12.9KB/s 用时 2m 3s  

2020-08-18 13:56:52 (15.7 KB/s) - 已保存 “redis-5.0.9.tar.gz” [1986574/1986574])

Uncompress redis-5.0.9.tar.gz...
cd redis-5.0.9...
cd src && make install
make[1]: 进入目录“/root/lnmp1.7/src/redis-5.0.9/src”
    CC Makefile.dep
make[1]: 离开目录“/root/lnmp1.7/src/redis-5.0.9/src”
make[1]: 进入目录“/root/lnmp1.7/src/redis-5.0.9/src”
Linux下Nginx+MySQL+PHP自动安装工具:https://lnmp.org
发表于 2020-8-18 19:33:33 | 显示全部楼层

ericliu 发表于 2020-8-18 14:54
您好,我服务器之前没安装过reids,删除了旧版lnmp1.7安装文件后,重新下载lnmp1.7,然后执行./addons.sh in ...

安装redis 5.0.9是因为你系统不满足redis 6.0.x的要求,redis 6.0.x对系统gcc要求至少 5.3以上版本
按你这个情况你系统肯定是centos 7或更低版本,centos系列至少要centos 8或自行升级gcc https://www.vpser.net 上都有gcc升级教程

5.3.1是php redis,不是一个东西

美国VPS、VPN、域名代购:http://shop63846532.taobao.com/

 楼主| 发表于 2020-8-19 10:04:22 | 显示全部楼层

明白了,非常感谢!
您需要登录后才可以回帖 登录 | 注册

本版积分规则

小黑屋|手机版|Archiver|VPS侦探 ( 鲁ICP备16040043号-1 )

GMT+8, 2020-10-1 10:32 , Processed in 0.145868 second(s), 26 queries .

Powered by Discuz! X3.4

Copyright © 2001-2020, Tencent Cloud.

快速回复 返回顶部 返回列表