VPS侦探论坛

 找回密码
 注册
查看: 193|回复: 3

安装imageMagick扩展出错

[复制链接]
发表于 2020-9-25 09:11:15 | 显示全部楼层 |阅读模式



  1. Package epel-release-6-8.noarch already installed and latest version
  2. Nothing to do
  3. Loaded plugins: fastestmirror, refresh-packagekit, security
  4. Setting up Install Process
  5. Loading mirror speeds from cached hostfile
  6. * base: mirrors.tuna.tsinghua.edu.cn
  7. * epel: mirrors.tuna.tsinghua.edu.cn
  8. * extras: mirrors.ustc.edu.cn
  9. * updates: mirrors.ustc.edu.cn
  10. Package libwebp-devel-0.4.3-3.el6.x86_64 already installed and latest version
  11. Nothing to do
  12. ImageMagick already exists.
  13. imagick-3.4.4.tgz [found]
  14. Uncompress imagick-3.4.4.tgz...
  15. cd imagick-3.4.4...
  16. Configuring for:
  17. PHP Api Version:         20180731
  18. Zend Module Api No:      20180731
  19. Zend Extension Api No:   320180731
  20. configure.ac:3: error: Autoconf version 2.68 or higher is required
  21. configure.ac:3: the top level
  22. autom4te: /usr/bin/m4 failed with exit status: 63
  23. include/imageMagick.sh: line 52: ./configure: No such file or directory
  24. make: *** No targets specified and no makefile found.  Stop.
  25. make: *** No targets specified and no makefile found.  Stop.
  26. make: *** No rule to make target `install'.  Stop.
  27. imagick install failed!
复制代码

lnmp版本是1.7
服务器系统是centos6.8






补充内容 (2020-9-25 09:24):
php版本是  PHP Version 7.3.19
美国VPS推荐: 遨游主机LinodeLOCVPSKVMLAVPS2EZ搬瓦工80VPSVultr美国VPS主机中国VPS推荐: 阿里云腾讯云。LNMP付费服务(代装/问题排查)QQ 503228080
 楼主| 发表于 2020-9-25 10:13:39 | 显示全部楼层


我查询了一下,好像不支持7.3的版本,我用Lnmp又重新安装了php.7.2.31版本在安装就可以了,
Linux下Nginx+MySQL+PHP自动安装工具:https://lnmp.org
 楼主| 发表于 2020-9-25 10:23:01 | 显示全部楼层



本帖最后由 hkcc 于 2020-9-25 10:27 编辑

说一下解决办法:
我目前的php是7.3安装不了,不知道是否不支持,反正我另外一台7.2版本的安装正常,现在这台是生产环境,我也不想在折腾了
1,安装多个版本的php,直接运行安装包下面的  ./install.sh mphp  选择php7.2.31,然后安装
2,安装完以后我是已经存在的网站,直接配置文件  /usr/local/nginx/conf/vhost/域名.conf ,找到大概30多行,
include enable-php-pathinfo.conf;  
修改为  include enable-php7.2.conf;
然后重新启动 lnmp restart
3,在重新安装 imageMagick 扩展
  ./addons.sh install imagemagick
这里在安装的时候会要求选择php的版本,选择刚才安装好的php7.2.31版本即可,然后就等他自动安装完成,最后 phpinfo

成功安装    imageMagick

=====================
官网安装扩展的文档地址:  https://lnmp.org/faq/addons.html

多PHP版本使用教程:   https://lnmp.org/faq/upgrade1-4.html



本帖子中包含更多资源

您需要 登录 才可以下载或查看,没有帐号?注册

x
美国VPS推荐: 遨游主机LinodeLOCVPSKVMLAVPS2EZ搬瓦工80VPSVultr美国VPS主机中国VPS推荐: 阿里云腾讯云。LNMP付费服务(代装/问题排查)QQ 503228080
发表于 2020-9-25 10:27:17 | 显示全部楼层



centos 6.8的autoconf太低,不满足imagick的要求,你修改 include/version.sh 将  Imagick_Ver='imagick-3.4.4' 改成 Imagick_Ver='imagick-3.4.3' 试一下
Linux下Nginx+MySQL+PHP自动安装工具:https://lnmp.org
您需要登录后才可以回帖 登录 | 注册

本版积分规则

小黑屋|手机版|Archiver|VPS侦探 ( 鲁ICP备16040043号-1 )

GMT+8, 2020-10-23 10:02 , Processed in 0.056038 second(s), 27 queries .

Powered by Discuz! X3.4

Copyright © 2001-2020, Tencent Cloud.

快速回复 返回顶部 返回列表