VPS侦探论坛

 找回密码
 注册
查看: 337|回复: 1

求救,php5.5升级到了php7.4

[复制链接]
发表于 2020-10-22 17:55:14 | 显示全部楼层 |阅读模式



php5.5升级到了php7.4,发现应用用不了,想降级回去,各种途径都失败,mphp,多版本也失败

本帖子中包含更多资源

您需要 登录 才可以下载或查看,没有帐号?注册

x
美国VPS推荐: 遨游主机LinodeLOCVPSKVMLAVPS2EZ搬瓦工80VPSVultr美国VPS主机中国VPS推荐: 阿里云腾讯云。LNMP付费服务(代装/问题排查)QQ 503228080
发表于 2020-10-22 20:08:33 | 显示全部楼层


上传的第二附件是升级到php 7.4的日志
多版本按日志错误
/usr/bin/ld: ext/intl/breakiterator/.libs/rulebasedbreakiterator_methods.o: undefined reference to symbol '_Znam@@GLIBCXX_3.4'
//usr/lib64/libstdc++.so.6: error adding symbols: DSO missing from command line
collect2: error: ld returned 1 exit status
make: *** [sapi/cli/php] 错误 1
有可能是升级过gcc之类的或动过编译所需的部分软件包

升级或降价失败,可以直接恢复原来的,升级脚本都会对所有文件进行备份,可以参考官网升级教程里面的恢复说明
Linux下Nginx+MySQL+PHP自动安装工具:https://lnmp.org
您需要登录后才可以回帖 登录 | 注册

本版积分规则

小黑屋|手机版|Archiver|VPS侦探 ( 鲁ICP备16040043号-1 )

GMT+8, 2020-11-28 04:58 , Processed in 0.051027 second(s), 27 queries .

Powered by Discuz! X3.4

Copyright © 2001-2020, Tencent Cloud.

快速回复 返回顶部 返回列表