VPS侦探论坛

 找回密码
 注册
查看: 308|回复: 2

lnmp1.7安装多php,里面没有自己需要的版本,怎么修改

[复制链接]
发表于 2020-12-10 11:02:32 | 显示全部楼层 |阅读模式



服务器配置:2核4G
系统版本:centos8.2 64位安装包版本:lnmp1.7
因为有一个网站需要特定的php版本才能使用,5.5.25,但咱们的默认的php安装版本里没有,所以我就想通过多php版本来安装,但上传了php-5.5.25.tar.bz2安装包到src这个文件夹下面,同时也修改了include下面version.sh文件里面的版本号,但在安装的时候,里面还是原来的php版本号。


请问怎么修改安装选项里面的版本号呢?我输入3,提示安装的版本还是5.4.45的,我在version.sh已经把3这个改成5.5.25了

请问修改上面这个界面的版本号要修改哪个文件呢?还望军哥指教,谢谢了。

本帖子中包含更多资源

您需要 登录 才可以下载或查看,没有帐号?注册

x
美国VPS推荐: 遨游主机LinodeLOCVPSKVMLAVPS2EZ搬瓦工80VPSVultr美国VPS主机中国VPS推荐: 阿里云腾讯云。LNMP付费服务(代装/问题排查)QQ 503228080
 楼主| 发表于 2020-12-10 14:39:20 | 显示全部楼层


已经搞好了,修改了main.sh里面的版本号就可以了
Linux下Nginx+MySQL+PHP自动安装工具:https://lnmp.org
发表于 2020-12-10 15:44:38 | 显示全部楼层



只要改了version.sh 并下载好了就可以了,这个界面上显示的不影响你自定义的版本,也可以自己修改 include/main.sh 前几行中的版本号
美国VPS推荐: 遨游主机LinodeLOCVPSKVMLAVPS2EZ搬瓦工80VPSVultr美国VPS主机中国VPS推荐: 阿里云腾讯云。LNMP付费服务(代装/问题排查)QQ 503228080
您需要登录后才可以回帖 登录 | 注册

本版积分规则

小黑屋|手机版|Archiver|VPS侦探 ( 鲁ICP备16040043号-1 )

GMT+8, 2021-5-14 15:38 , Processed in 0.051127 second(s), 27 queries .

Powered by Discuz! X3.4

Copyright © 2001-2021, Tencent Cloud.

快速回复 返回顶部 返回列表