VPS侦探论坛

 找回密码
 注册
查看: 216|回复: 1

CentOS 7.6 64位版,天翼云,lnmp安装失败

[复制链接]
发表于 2021-1-15 19:06:22 | 显示全部楼层 |阅读模式



CentOS 7.6 64位版,天翼云,lnmp安装失败

本帖子中包含更多资源

您需要 登录 才可以下载或查看,没有帐号?注册

x
美国VPS推荐: 遨游主机LinodeLOCVPSKVMLAVPS2EZ搬瓦工80VPSVultr美国VPS主机中国VPS推荐: 阿里云腾讯云。LNMP付费服务(代装/问题排查)QQ 503228080
发表于 2021-1-15 20:39:26 | 显示全部楼层


Resolving Dependencies
--> Running transaction check
---> Package gd-devel.x86_64 0:2.0.35-26.el7 will be installed
--> Processing Dependency: libpng-devel for package: gd-devel-2.0.35-26.el7.x86_64
--> Processing Dependency: freetype-devel for package: gd-devel-2.0.35-26.el7.x86_64
--> Processing Dependency: fontconfig-devel for package: gd-devel-2.0.35-26.el7.x86_64
--> Running transaction check
---> Package fontconfig-devel.x86_64 0:2.13.0-4.3.el7 will be installed
--> Processing Dependency: pkgconfig(uuid) for package: fontconfig-devel-2.13.0-4.3.el7.x86_64
--> Processing Dependency: pkgconfig(expat) for package: fontconfig-devel-2.13.0-4.3.el7.x86_64
---> Package freetype-devel.x86_64 0:2.8-14.el7 will be installed
---> Package libpng-devel.x86_64 2:1.5.13-7.el7_2 will be installed
--> Processing Dependency: libpng(x86-64) = 2:1.5.13-7.el7_2 for package: 2:libpng-devel-1.5.13-7.el7_2.x86_64
--> Running transaction check
---> Package expat-devel.x86_64 0:2.1.0-11.el7 will be installed
--> Processing Dependency: expat = 2.1.0-11.el7 for package: expat-devel-2.1.0-11.el7.x86_64
---> Package libpng-devel.x86_64 2:1.5.13-7.el7_2 will be installed
--> Processing Dependency: libpng(x86-64) = 2:1.5.13-7.el7_2 for package: 2:libpng-devel-1.5.13-7.el7_2.x86_64
---> Package libuuid-devel.x86_64 0:2.23.2-63.el7 will be installed
--> Running transaction check
---> Package expat.i686 0:2.1.0-11.el7 will be installed
--> Processing Dependency: libc.so.6(GLIBC_2.4) for package: expat-2.1.0-11.el7.i686
---> Package libpng-devel.x86_64 2:1.5.13-7.el7_2 will be installed
--> Processing Dependency: libpng(x86-64) = 2:1.5.13-7.el7_2 for package: 2:libpng-devel-1.5.13-7.el7_2.x86_64
--> Running transaction check
---> Package glibc.i686 0:2.17-307.el7.1 will be installed
--> Processing Dependency: libfreebl3.so(NSSRAWHASH_3.12.3) for package: glibc-2.17-307.el7.1.i686
--> Processing Dependency: libfreebl3.so for package: glibc-2.17-307.el7.1.i686
---> Package libpng-devel.x86_64 2:1.5.13-7.el7_2 will be installed
--> Processing Dependency: libpng(x86-64) = 2:1.5.13-7.el7_2 for package: 2:libpng-devel-1.5.13-7.el7_2.x86_64
--> Running transaction check
---> Package libpng-devel.x86_64 2:1.5.13-7.el7_2 will be installed
--> Processing Dependency: libpng(x86-64) = 2:1.5.13-7.el7_2 for package: 2:libpng-devel-1.5.13-7.el7_2.x86_64
---> Package nss-softokn-freebl.i686 0:3.44.0-8.el7_7 will be installed
--> Finished Dependency Resolution
Error: Package: 2:libpng-devel-1.5.13-7.el7_2.x86_64 (base)
           Requires: libpng(x86-64) = 2:1.5.13-7.el7_2
           Installed: 2:libpng-1.5.13-8.el7.x86_64 (@base)
               libpng(x86-64) = 2:1.5.13-8.el7
           Available: 2:libpng-1.5.13-7.el7_2.x86_64 (base)
               libpng(x86-64) = 2:1.5.13-7.el7_2
You could try using --skip-broken to work around the problem
** Found 1 pre-existing rpmdb problem(s), 'yum check' output follows:
glibc-headers-2.17-307.el7.1.x86_64 has missing requires of kernel-headers >= ('0', '2.2.1', None)

。。。。。。
Resolving Dependencies
--> Running transaction check
---> Package libcurl-devel.x86_64 0:7.29.0-57.el7_8.1 will be installed
--> Processing Dependency: libcurl = 7.29.0-57.el7_8.1 for package: libcurl-devel-7.29.0-57.el7_8.1.x86_64
--> Running transaction check
---> Package libcurl.i686 0:7.29.0-57.el7_8.1 will be installed
--> Processing Dependency: nss-pem(x86-32) >= 1.0.3-5 for package: libcurl-7.29.0-57.el7_8.1.i686
--> Processing Dependency: libssh2(x86-32) >= 1.8.0 for package: libcurl-7.29.0-57.el7_8.1.i686
--> Processing Dependency: libz.so.1 for package: libcurl-7.29.0-57.el7_8.1.i686
--> Processing Dependency: libssl3.so(NSS_3.4) for package: libcurl-7.29.0-57.el7_8.1.i686
---> Package openssl-libs.i686 1:1.0.2k-19.el7 will be installed
--> Running transaction check
---> Package libdb.i686 0:5.3.21-25.el7 will be installed
---> Package libsepol.i686 0:2.5-10.el7 will be installed
---> Package pcre.i686 0:8.32-17.el7 will be installed
--> Processing Dependency: libstdc++.so.6(GLIBCXX_3.4.9) for package: pcre-8.32-17.el7.i686
--> Processing Dependency: libstdc++.so.6(GLIBCXX_3.4) for package: pcre-8.32-17.el7.i686
--> Processing Dependency: libstdc++.so.6(CXXABI_1.3) for package: pcre-8.32-17.el7.i686
--> Processing Dependency: libstdc++.so.6 for package: pcre-8.32-17.el7.i686
--> Processing Dependency: libgcc_s.so.1(GCC_3.0) for package: pcre-8.32-17.el7.i686
--> Processing Dependency: libgcc_s.so.1 for package: pcre-8.32-17.el7.i686
---> Package sqlite.i686 0:3.7.17-8.el7_7.1 will be installed
--> Processing Dependency: libtinfo.so.5 for package: sqlite-3.7.17-8.el7_7.1.i686
--> Processing Dependency: libreadline.so.6 for package: sqlite-3.7.17-8.el7_7.1.i686
--> Processing Dependency: libncurses.so.5 for package: sqlite-3.7.17-8.el7_7.1.i686
--> Running transaction check
---> Package libgcc.i686 0:4.8.5-39.el7 will be installed
---> Package libstdc++.i686 0:4.8.5-39.el7 will be installed
---> Package ncurses-libs.i686 0:5.9-14.20130511.el7_4 will be installed
---> Package readline.i686 0:6.2-11.el7 will be installed
--> Finished Dependency Resolution
Error:  Multilib version problems found. This often means that the root
       cause is something else and multilib version checking is just
       pointing out that there is a problem. Eg.:
      
         1. You have an upgrade for nss which is missing some
            dependency that another package requires. Yum is trying to
            solve this by installing an older version of nss of the
            different architecture. If you exclude the bad architecture
            yum will tell you what the root cause is (which package
            requires what). You can try redoing the upgrade with
            --exclude nss.otherarch ... this should give you an error
            message showing the root cause of the problem.
      
         2. You have multiple architectures of nss installed, but
            yum can only see an upgrade for one of those architectures.
            If you don't want/need both architectures anymore then you
            can remove the one with the missing update and everything
            will work.
      
         3. You have duplicate versions of nss installed already.
            You can use "yum check" to get yum show these errors.
      
       ...you can also use --setopt=protected_multilib=false to remove
       this checking, however this is almost never the correct thing to
       do as something else is very likely to go wrong (often causing
       much more problems).
      
       Protected multilib versions: nss-3.44.0-7.el7_7.i686 != nss-3.53.1-3.el7_9.x86_64
Error: Protected multilib versions: nss-softokn-freebl-3.44.0-8.el7_7.i686 != nss-softokn-freebl-3.53.1-6.el7_9.x86_64
Error: Protected multilib versions: nss-util-3.44.0-4.el7_7.i686 != nss-util-3.53.1-1.el7_9.x86_64
Error: Protected multilib versions: nspr-4.21.0-1.el7.i686 != nspr-4.25.0-2.el7_9.x86_64
Error: Protected multilib versions: libcurl-7.29.0-57.el7_8.1.i686 != libcurl-7.29.0-59.el7.x86_64
Error: Protected multilib versions: nss-softokn-3.44.0-8.el7_7.i686 != nss-softokn-3.53.1-6.el7_9.x86_64
。。。。。
checking how to run the C preprocessor... /lib/cpp
configure: error: C preprocessor "/lib/cpp" fails sanity check

等等各种问题,有可能是你系统之前安装其他软件包导致的依赖关系有问题或他们家的系统模板有问题,如果动过系统内核如安安装了bbr但是未安装kernel-headers也会造成问题

可以尝试 yum install yum-utils
然后 package-cleanup --cleandupes
yum clean all
然后 yum install glibc-headers 看能否正常安装

PS:按目前形势来说放弃centos保平安,首选debian
Linux下Nginx+MySQL+PHP自动安装工具:https://lnmp.org
您需要登录后才可以回帖 登录 | 注册

本版积分规则

小黑屋|手机版|Archiver|VPS侦探 ( 鲁ICP备16040043号-1 )

GMT+8, 2021-3-2 06:22 , Processed in 0.089358 second(s), 27 queries .

Powered by Discuz! X3.4

Copyright © 2001-2020, Tencent Cloud.

快速回复 返回顶部 返回列表