VPS侦探论坛

 找回密码
 注册
查看: 281|回复: 1

lnmp1.8安装php8.0.1错误

[复制链接]
发表于 2021-1-18 00:26:30 | 显示全部楼层 |阅读模式



centos7.6,openssl升级至1.1.1i,ssh升级至8.4p1
安装lnmp1.8的php8.0报错

/usr/bin/ld: warning: libssl.so.10, needed by /usr/lib64/libssh2.so.1, may conflict with libssl.so.1.1
/usr/bin/ld: warning: libssl.so.10, needed by /usr/lib64/libssh2.so.1, may conflict with libssl.so.1.1
/usr/bin/ld: warning: libssl.so.10, needed by /usr/lib64/libssh2.so.1, may conflict with libssl.so.1.1
/usr/bin/ld: ext/openssl/openssl.o: undefined reference to symbol 'SSL_library_init@@libssl.so.10'
/usr/bin/ld: /usr/lib64/libssl.so.10: error adding symbols: DSO missing from command line
collect2: error: ld returned 1 exit status
make: *** [Makefile:307: sapi/cli/php] Error 1

美国VPS推荐: 遨游主机LinodeLOCVPSKVMLAVPS2EZ搬瓦工80VPSVultr美国VPS主机中国VPS推荐: 阿里云腾讯云。LNMP付费服务(代装/问题排查)QQ 503228080
发表于 2021-1-18 20:09:23 | 显示全部楼层


你openssl升级步骤可能有问题
Linux下Nginx+MySQL+PHP自动安装工具:https://lnmp.org
您需要登录后才可以回帖 登录 | 注册

本版积分规则

小黑屋|手机版|Archiver|VPS侦探 ( 鲁ICP备16040043号-1 )

GMT+8, 2021-3-2 19:17 , Processed in 0.046677 second(s), 26 queries .

Powered by Discuz! X3.4

Copyright © 2001-2020, Tencent Cloud.

快速回复 返回顶部 返回列表