VPS侦探论坛

 找回密码
 注册
查看: 281|回复: 2

[1.8]php8.0和现有apache配置文件不兼容

[复制链接]
发表于 2021-1-26 09:50:52 | 显示全部楼层 |阅读模式



oracle云,mysql 5.7+php8.0.1+apache2.4

安装过程知道最后才出错
  1. Job for httpd.service failed because the control process exited with error code.
  2. See "systemctl status httpd.service" and "journalctl -xe" for details.
复制代码

具体查看出错内容是
  1. httpd: Syntax error on line 444 of /usr/local/apache/conf/httpd.conf: Cannot load modules/libphp5.so into server: /usr/local/apache/modules/libphp5.so: cannot open shared object fil
复制代码
第444行的内容是
  1. LoadModule php5_module        modules/libphp5.so
复制代码


然后我稍微搜索了下,从php8.0开始编译出的apache模块不再带有大版本号,统一命名为libphp.so,猜测应该是这个原因导致的
https://bugs.php.net/bug.php?id=78681
https://github.com/php/php-src/commit/6e3600f41b95d97d11ef48f817e6389a4ee95091


美国VPS推荐: 遨游主机LinodeLOCVPSKVMLAVPS2EZ搬瓦工80VPSVultr美国VPS主机中国VPS推荐: 阿里云腾讯云。LNMP付费服务(代装/问题排查)QQ 503228080
发表于 2021-1-26 11:12:13 | 显示全部楼层


收到,稍后我就进行调整
Linux下Nginx+MySQL+PHP自动安装工具:https://lnmp.org
 楼主| 发表于 2021-1-27 14:31:39 | 显示全部楼层



另外就是现在imagick也是不支持8的,编译会报错,master有可能已经支持
美国VPS推荐: 遨游主机LinodeLOCVPSKVMLAVPS2EZ搬瓦工80VPSVultr美国VPS主机中国VPS推荐: 阿里云腾讯云。LNMP付费服务(代装/问题排查)QQ 503228080
您需要登录后才可以回帖 登录 | 注册

本版积分规则

小黑屋|手机版|Archiver|VPS侦探 ( 鲁ICP备16040043号-1 )

GMT+8, 2021-2-25 02:10 , Processed in 0.050826 second(s), 26 queries .

Powered by Discuz! X3.4

Copyright © 2001-2020, Tencent Cloud.

快速回复 返回顶部 返回列表