VPS侦探论坛

 找回密码
 注册
查看: 394|回复: 1

升级多版本php失败

[复制链接]
发表于 2021-3-29 19:40:46 | 显示全部楼层 |阅读模式



本帖最后由 niejh1 于 2021-3-29 19:42 编辑

checking whether to build with expat support... no
checking for libxml-2.0 >= 2.9.0... yes
checking whether to enable XMLReader support... yes
checking for libxml-2.0 >= 2.9.0... yes
checking whether to enable XMLWriter support... yes
checking for libxml-2.0 >= 2.9.0... yes
checking whether to build with XSL support... yes
checking for libxslt >= 1.1.0... yes
checking for libexslt... yes
checking whether to enable zend-test extension... no
checking for zip archive read/write support... yes
checking for libzip >= 0.11 libzip != 1.3.1 libzip != 1.7.0... no
configure: error: Package requirements (libzip >= 0.11 libzip != 1.3.1 libzip != 1.7.0) were not met:

Requested 'libzip >= 0.11' but version of libzip is 0.10.1

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables LIBZIP_CFLAGS
and LIBZIP_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.
make: *** No targets specified and no makefile found.  Stop.
make: *** No targets specified and no makefile found.  Stop.
make: *** No rule to make target `install'.  Stop.
Copy new php configure file...
Modify php.ini......
Install ZendGuardLoader for PHP 8.0...
unavailable now.
Creating new php-fpm configure file...
Copy php-fpm init.d file...
cp: cannot stat ‘/root/lnmp1.8/src/php-8.0.3/sapi/fpm/init.d.php-fpm’: No such file or directory
chmod: cannot access ‘/etc/init.d/php-fpm8.0’: No such file or directory
Add php-fpm8.0 service at system startup...
error reading information on service php-fpm8.0: No such file or directory
error reading information on service php-fpm8.0: No such file or directory
+-------------------------------------------+
|    Manager for LNMP, Written by Licess    |
+-------------------------------------------+
|              https://lnmp.org             |
+-------------------------------------------+
Starting LNMP...
Starting nginx...  done
Starting mariadb (via systemctl):  [  OK  ]
Starting php-fpm  done
Failed to install php-8.0.3, you can download /root/install-mphp8.0.log from your server, and upload install-mphp8.0.log to LNMP Forum.



本帖子中包含更多资源

您需要 登录 才可以下载或查看,没有帐号?注册

x
美国VPS推荐: 遨游主机LinodeLOCVPSKVMLAVPS2EZ搬瓦工80VPSVultr美国VPS主机中国VPS推荐: 阿里云腾讯云。LNMP付费服务(代装/问题排查)QQ 503228080
 楼主| 发表于 2021-3-29 21:07:41 | 显示全部楼层


原来是libzip版本太低了
Linux下Nginx+MySQL+PHP自动安装工具:https://lnmp.org
您需要登录后才可以回帖 登录 | 注册

本版积分规则

小黑屋|手机版|Archiver|VPS侦探 ( 鲁ICP备16040043号-1 )

GMT+8, 2021-7-29 07:15 , Processed in 0.048436 second(s), 27 queries .

Powered by Discuz! X3.4

Copyright © 2001-2021, Tencent Cloud.

快速回复 返回顶部 返回列表