VPS侦探论坛

 找回密码
 注册
查看: 174|回复: 1

安装lnmp环境mysql安装失败

[复制链接]
发表于 2021-6-25 17:55:44 | 显示全部楼层 |阅读模式



============================check files==================================
Notice: mysql-5.6.51.tar.gz not found!!!download now...
--2021-06-25 17:29:00--  https://soft.vpser.net/datebase/mysql/mysql-5.6.51.tar.gz
Resolving soft.vpser.net (soft.vpser.net)... 36.42.73.10, 183.131.200.94, 183.131.200.105, ...
Connecting to soft.vpser.net (soft.vpser.net)|36.42.73.10|:443... connected.
HTTP request sent, awaiting response... 200 OK
Length: 32411131 (31M) [application/octet-stream]
Saving to: ‘mysql-5.6.51.tar.gz’


mysql-5.6.51.tar.gz   0%[                    ]       0  --.-KB/s               
mysql-5.6.51.tar.gz   8%[>                   ]   2.67M  13.2MB/s               
mysql-5.6.51.tar.gz  22%[===>                ]   6.83M  17.0MB/s               
mysql-5.6.51.tar.gz  35%[======>             ]  10.91M  17.5MB/s               
mysql-5.6.51.tar.gz  48%[========>           ]  15.05M  18.2MB/s               
mysql-5.6.51.tar.gz  61%[===========>        ]  19.00M  18.5MB/s               
mysql-5.6.51.tar.gz  72%[=============>      ]  22.42M  18.0MB/s               
mysql-5.6.51.tar.gz  85%[================>   ]  26.44M  18.3MB/s               
mysql-5.6.51.tar.gz  98%[==================> ]  30.52M  18.5MB/s               
mysql-5.6.51.tar.gz 100%[===================>]  30.91M  18.5MB/s    in 1.7s   

2021-06-25 17:29:02 (18.5 MB/s) - ‘mysql-5.6.51.tar.gz’ saved [32411131/32411131]

============================check files==================================
Install dependent packages...
Modular dependency problems:

Problem 1: conflicting requests
  - nothing provides module(perl:5.26) needed by module perl-libwww-perl:6.34:8030020201223164340:b967a9a2-0.x86_64
  - nothing provides module(perl-IO-Socket-SSL:2.066) needed by module perl-libwww-perl:6.34:8030020201223164340:b967a9a2-0.x86_64
Problem 2: conflicting requests
  - nothing provides module(nginx) needed by module php:7.2:8020020200507003613:2c7ca891-0.x86_64
  - nothing provides module(httpd:2.4) needed by module php:7.2:8020020200507003613:2c7ca891-0.x86_64
No match for argument: mysql-server
No match for argument: mysql
No match for argument: mysql-libs
No match for argument: mariadb-server
No match for argument: mariadb
No match for argument: mariadb-libs
No packages marked for removal.
Dependencies resolved.
Nothing to do.
Complete!
error: package mysql is not installed
error: package mysql-libs is not installed
error: package mariadb is not installed
error: package mariadb-libs is not installed
Last metadata expiration check: 0:09:23 ago on Fri 25 Jun 2021 05:19:41 PM CST.
Package make-1:4.2.1-10.el8.x86_64 is already installed.
Dependencies resolved.
Nothing to do.
Complete!
Last metadata expiration check: 0:09:24 ago on Fri 25 Jun 2021 05:19:41 PM CST.
Package cmake-3.18.2-9.el8.x86_64 is already installed.
Dependencies resolved.
Nothing to do.
Complete!
Last metadata expiration check: 0:09:25 ago on Fri 25 Jun 2021 05:19:41 PM CST.
Package gcc-8.4.1-1.el8.x86_64 is already installed.
Dependencies resolved.
Nothing to do.
Complete!
Last metadata expiration check: 0:09:26 ago on Fri 25 Jun 2021 05:19:41 PM CST.
Package gcc-c++-8.4.1-1.el8.x86_64 is already installed.
Dependencies resolved.
Nothing to do.
Complete!
Last metadata expiration check: 0:09:27 ago on Fri 25 Jun 2021 05:19:41 PM CST.
No match for argument: gcc-g77
Error: Unable to find a match: gcc-g77
Last metadata expiration check: 0:09:28 ago on Fri 25 Jun 2021 05:19:41 PM CST.
Package flex-2.6.1-9.el8.x86_64 is already installed.
Dependencies resolved.
Nothing to do.
Complete!
Last metadata expiration check: 0:09:29 ago on Fri 25 Jun 2021 05:19:41 PM CST.
Package bison-3.0.4-10.el8.x86_64 is already installed.
Dependencies resolved.
Nothing to do.
Complete!
Last metadata expiration check: 0:09:30 ago on Fri 25 Jun 2021 05:19:41 PM CST.
Package wget-1.19.5-10.el8.x86_64 is already installed.
Dependencies resolved.
Nothing to do.
Complete!
Last metadata expiration check: 0:09:31 ago on Fri 25 Jun 2021 05:19:41 PM CST.
Package zlib-1.2.11-17.el8.x86_64 is already installed.
Dependencies resolved.
Nothing to do.
Complete!
Last metadata expiration check: 0:09:33 ago on Fri 25 Jun 2021 05:19:41 PM CST.
Package zlib-devel-1.2.11-17.el8.x86_64 is already installed.
Dependencies resolved.
Nothing to do.
Complete!
Last metadata expiration check: 0:09:34 ago on Fri 25 Jun 2021 05:19:41 PM CST.
Package openssl-1:1.1.1g-15.el8_3.x86_64 is already installed.
Dependencies resolved.
Nothing to do.
Complete!
Last metadata expiration check: 0:09:35 ago on Fri 25 Jun 2021 05:19:41 PM CST.
Package openssl-devel-1:1.1.1g-15.el8_3.x86_64 is already installed.
Dependencies resolved.
Nothing to do.
Complete!
Last metadata expiration check: 0:09:36 ago on Fri 25 Jun 2021 05:19:41 PM CST.
Package ncurses-6.1-7.20180224.el8.x86_64 is already installed.
Dependencies resolved.
Nothing to do.
Complete!
Last metadata expiration check: 0:09:37 ago on Fri 25 Jun 2021 05:19:41 PM CST.
Package ncurses-devel-6.1-7.20180224.el8.x86_64 is already installed.
Dependencies resolved.
Nothing to do.
Complete!
Last metadata expiration check: 0:09:38 ago on Fri 25 Jun 2021 05:19:41 PM CST.
Package libaio-devel-0.3.112-1.el8.x86_64 is already installed.
Dependencies resolved.
Nothing to do.
Complete!
Last metadata expiration check: 0:09:39 ago on Fri 25 Jun 2021 05:19:41 PM CST.
Package rpcgen-1.3.1-4.el8.x86_64 is already installed.
Dependencies resolved.
Nothing to do.
Complete!
Last metadata expiration check: 0:09:40 ago on Fri 25 Jun 2021 05:19:41 PM CST.
Package libtirpc-devel-1.1.4-4.el8.x86_64 is already installed.
Dependencies resolved.
Nothing to do.
Complete!
Last metadata expiration check: 0:09:41 ago on Fri 25 Jun 2021 05:19:41 PM CST.
Package patch-2.7.6-11.el8.x86_64 is already installed.
Dependencies resolved.
Nothing to do.
Complete!
Last metadata expiration check: 0:09:42 ago on Fri 25 Jun 2021 05:19:41 PM CST.
Package cyrus-sasl-devel-2.1.27-5.el8.x86_64 is already installed.
Dependencies resolved.
Nothing to do.
Complete!
Last metadata expiration check: 0:09:44 ago on Fri 25 Jun 2021 05:19:41 PM CST.
Package pkgconf-pkg-config-1.4.2-1.el8.x86_64 is already installed.
Dependencies resolved.
Nothing to do.
Complete!
Repo-id      : PowerTools
Repo-name    : CentOS-8 - PowerTools
Repo-baseurl : http://mirrors.cloud.aliyuncs.com/centos/8/PowerTools/x86_64/os/
Repo-filename: /etc/yum.repos.d/CentOS-PowerTools.repo
Last metadata expiration check: 0:09:46 ago on Fri 25 Jun 2021 05:19:41 PM CST.
Last metadata expiration check: 0:09:47 ago on Fri 25 Jun 2021 05:19:41 PM CST.
Package rpcgen-1.3.1-4.el8.x86_64 is already installed.
Dependencies resolved.
Nothing to do.
Complete!
[+] Installing mysql-5.6.51...
Uncompress mysql-5.6.51.tar.gz...
cd mysql-5.6.51...
cmake: symbol lookup error: cmake: undefined symbol: archive_write_add_filter_zstd
make: *** No targets specified and no makefile found.  Stop.
make: *** No targets specified and no makefile found.  Stop.
make: *** No rule to make target 'install'.  Stop.
groupadd: group 'mysql' already exists
useradd: user 'mysql' already exists
cp: cannot stat '/usr/local/mysql/var/*': No such file or directory
include/mysql.sh: line 509: /usr/local/mysql/scripts/mysql_install_db: No such file or directory
cp: cannot stat 'support-files/mysql.server': No such file or directory
chmod: cannot access '/etc/init.d/mysql': No such file or directory
include/mysql.sh: line 32: /etc/init.d/mysql: No such file or directory
include/mysql.sh: line 40: /etc/init.d/mysql: No such file or directory
include/mysql.sh: line 43: /usr/local/mysql/bin/mysqladmin: No such file or directory
failed, try other way...
include/mysql.sh: line 46: /etc/init.d/mysql: No such file or directory
include/mysql.sh: line 59: /usr/local/mysql/bin/mysql: No such file or directory
Set password failed!
include/mysql.sh: line 61: /usr/local/mysql/bin/mysql: No such file or directory
FLUSH PRIVILEGES failed!
include/mysql.sh: line 66: /etc/init.d/mysql: No such file or directory
include/main.sh: line 761: /usr/local/mysql/bin/mysql: No such file or directory
Update root password...
include/main.sh: line 761: /usr/local/mysql/bin/mysql: No such file or directory
... Failed!
Remove anonymous users...
include/main.sh: line 761: /usr/local/mysql/bin/mysql: No such file or directory
include/main.sh: line 761: /usr/local/mysql/bin/mysql: No such file or directory
... Failed!
Disallow root login remotely...
include/main.sh: line 761: /usr/local/mysql/bin/mysql: No such file or directory
... Failed!
Remove test database...
include/main.sh: line 761: /usr/local/mysql/bin/mysql: No such file or directory
... Failed!
Reload privilege tables...
include/main.sh: line 761: /usr/local/mysql/bin/mysql: No such file or directory
... Failed!
include/mysql.sh: line 96: /etc/init.d/mysql: No such file or directory
include/mysql.sh: line 97: /etc/init.d/mysql: No such file or directory
Add mysql service at system startup...
include/main.sh: line 805: /etc/init.d/mysql: No such file or directory
Clean database src directory...
Error: MySQL install failed.


美国VPS推荐: 遨游主机LinodeLOCVPSKVMLAVPS2EZ搬瓦工80VPSVultr美国VPS主机中国VPS推荐: 阿里云腾讯云。LNMP付费服务(代装/问题排查)QQ 503228080
发表于 2021-6-25 21:23:16 | 显示全部楼层


centos8说了无数遍了,安装要求也都明确注明了不要使用不要使用
Linux下Nginx+MySQL+PHP自动安装工具:https://lnmp.org
您需要登录后才可以回帖 登录 | 注册

本版积分规则

小黑屋|手机版|Archiver|VPS侦探 ( 鲁ICP备16040043号-1 )

GMT+8, 2021-7-25 14:54 , Processed in 0.047538 second(s), 26 queries .

Powered by Discuz! X3.4

Copyright © 2001-2021, Tencent Cloud.

快速回复 返回顶部 返回列表