VPS侦探论坛

 找回密码
 注册
查看: 398|回复: 2

擅自改造了一下lnmp1.8,提交上来给军哥审查

[复制链接]
发表于 2021-7-3 11:42:03 | 显示全部楼层 |阅读模式



http://144.76.13.134/lnmp1.8.1.tar.gz
由于论坛限制最大附件110kb,所以提供一个远程下载地址。


新增了一个11选项,数据库安装支持mariadb10.5.11选择安装
修改:mariadb的源码包为官方源码路径
elif [[ "${DBSelect}" =~ ^[6789]|10|11$ ]]; then
        Download_Files https://downloads.mariadb.org/interstitial/${Mariadb_Ver}/source/${Mariadb_Ver}.tar.gz

保留 ./lnmp1.8/src/对应的mariadb源码编译目录
由于我需要使用mroonga引擎,根据官方的要求,如果编译安装mroonga,需要结合mysql或mariadb编译安装时的源码目录进行相关处理。所以不得不修改lnmp脚本编译后自动删除的逻辑.



另外修改了mysql和mariadb高级版本必须大于1024的判断,改成了768
也就是^MySQL 5.6或^MariaDB 10 以上版本内存限制改小到768M。但这样做违背了军哥保证编译成功的需求,在编译时有可能出现内存不足的情况。但只要能正常编译安装成功后,数据库能正常启动,资源消耗并不会太大。


已经测试通过,mroonga可以在军哥的lnmp脚本配置的环境中,成功编译进入mysql5.7和mariadb11.5



本帖子中包含更多资源

您需要 登录 才可以下载或查看,没有帐号?注册

x
美国VPS推荐: 遨游主机LinodeLOCVPSKVMLAVPS2EZ搬瓦工80VPSVultr美国VPS主机中国VPS推荐: 阿里云腾讯云。LNMP付费服务(代装/问题排查)QQ 503228080
 楼主| 发表于 2021-7-3 11:47:39 | 显示全部楼层


实际上保险起见,建议使用军哥原版1nmp1.8 安装好mariadb10.4.19后,可以使用upgrade.sh 选择3 升级mariadb,版本号输入10.5.11 同样是官方源码路径下载编译升级,已测试没有任何问题。

但由于mroonga是个插件,比较特殊,需要原mariadb编译目录进行混合编译,所以军哥原版脚本会在编译后自动删除源码目录。所以我不得不改造了一下。

如果没有上述需求,不要使用我提交的这个改造版本,原版就能满足需求。

同时:我认同军哥的,centos8不要再使用,官方维护明年就会终止,centos7也会在两年后终止维护。一定要用centos,可以转换版本到centos stream 8 或者用debian等其他linux发行版
Linux下Nginx+MySQL+PHP自动安装工具:https://lnmp.org
发表于 2021-7-3 22:16:47 | 显示全部楼层



666                       
美国VPS推荐: 遨游主机LinodeLOCVPSKVMLAVPS2EZ搬瓦工80VPSVultr美国VPS主机中国VPS推荐: 阿里云腾讯云。LNMP付费服务(代装/问题排查)QQ 503228080
您需要登录后才可以回帖 登录 | 注册

本版积分规则

小黑屋|手机版|Archiver|VPS侦探 ( 鲁ICP备16040043号-1 )

GMT+8, 2021-7-25 17:50 , Processed in 0.053569 second(s), 27 queries .

Powered by Discuz! X3.4

Copyright © 2001-2021, Tencent Cloud.

快速回复 返回顶部 返回列表