VPS侦探论坛

 找回密码
 注册
查看: 274|回复: 3

lnmp1.7怎么升级zip模块?

[复制链接]
发表于 2021-9-20 19:54:32 | 显示全部楼层 |阅读模式



本帖最后由 dajf 于 2021-9-20 20:02 编辑

遇到了应用需要安装php zip拓展,在编译安装的时候出现这个问题
  1. checking for zip archive read/write support... yes, shared
  2. checking for libzip >= 0.11 libzip != 1.3.1 libzip != 1.7.0... no
  3. configure: error: Package requirements (libzip >= 0.11 libzip != 1.3.1 libzip != 1.7.0) were not met:

  4. Requested 'libzip >= 0.11' but version of libzip is 0.10.1

  5. Consider adjusting the PKG_CONFIG_PATH environment variable if you
  6. installed software in a non-standard prefix.

  7. Alternatively, you may set the environment variables LIBZIP_CFLAGS
  8. and LIBZIP_LIBS to avoid the need to call pkg-config.
  9. See the pkg-config man page for more details.
复制代码
怎么升级比较好,会不会影响到以后的自动更新
美国VPS推荐: 遨游主机LinodeLOCVPSKVMLAVPS2EZ搬瓦工80VPSVultr美国VPS主机中国VPS推荐: 阿里云腾讯云。LNMP付费服务(代装/问题排查)QQ 503228080
发表于 2021-9-21 16:54:06 | 显示全部楼层


用lnmp1.7的话自己去libzip下载个新版本的编译安装上就行了
用lnmp1.8的话centos7等版本会自动适配自动编译安装新版的libzip
Linux下Nginx+MySQL+PHP自动安装工具:https://lnmp.org
 楼主| 发表于 2021-9-22 21:59:36 | 显示全部楼层



licess 发表于 2021-9-21 16:54
用lnmp1.7的话自己去libzip下载个新版本的编译安装上就行了
用lnmp1.8的话centos7等版本会自动适配自动编译 ...

那我是只升级zip还是把Lnmp1.7升级到1.8呢?升级1.8会不会对VPS的配置有更高的要求?
美国VPS推荐: 遨游主机LinodeLOCVPSKVMLAVPS2EZ搬瓦工80VPSVultr美国VPS主机中国VPS推荐: 阿里云腾讯云。LNMP付费服务(代装/问题排查)QQ 503228080
发表于 2021-9-23 09:18:42 | 显示全部楼层



dajf 发表于 2021-9-22 21:59
那我是只升级zip还是把Lnmp1.7升级到1.8呢?升级1.8会不会对VPS的配置有更高的要求? ...

lnmp1.7升级1.8不会升级libzip
只有lnmp1.8新装或php 7.4及以上版本升级才会检查升级libzip
lnmp1.8要求和之前一样除非安装特别的版本,安装要求上都有说明
Linux下Nginx+MySQL+PHP自动安装工具:https://lnmp.org
您需要登录后才可以回帖 登录 | 注册

本版积分规则

小黑屋|手机版|Archiver|VPS侦探 ( 鲁ICP备16040043号-1 )

GMT+8, 2021-10-23 10:07 , Processed in 0.051111 second(s), 26 queries .

Powered by Discuz! X3.4

Copyright © 2001-2021, Tencent Cloud.

快速回复 返回顶部 返回列表