VPS侦探论坛

 找回密码
 注册
查看: 207|回复: 4

1.7和1.8都试了装不成功ubuntu20

[复制链接]
发表于 2021-11-10 23:11:10 | 显示全部楼层 |阅读模式



军哥好
系统信息如下
root@blackpeach:~# cat /etc/os-release
NAME="Ubuntu"
VERSION="20.04.3 LTS (Focal Fossa)"
ID=ubuntu
ID_LIKE=debian
PRETTY_NAME="Ubuntu 20.04.3 LTS"
VERSION_ID="20.04"
HOME_URL="https://www.ubuntu.com/"
SUPPORT_URL="https://help.ubuntu.com/"
BUG_REPORT_URL="https://bugs.launchpad.net/ubuntu/"
PRIVACY_POLICY_URL="https://www.ubuntu.com/legal/terms-and-policies/privacy-policy"
VERSION_CODENAME=focal
UBUNTU_CODENAME=focal

版本是阿里云的
镜像ID:ubuntu_20_04_x64_20G_alibase_20210927.vhd麻烦了~

本帖子中包含更多资源

您需要 登录 才可以下载或查看,没有帐号?注册

x
美国VPS推荐: 遨游主机LinodeLOCVPSKVMLAVPS2EZ搬瓦工80VPSVultr美国VPS主机中国VPS推荐: 阿里云腾讯云。LNMP付费服务(代装/问题排查)QQ 503228080
 楼主| 发表于 2021-11-10 23:17:35 | 显示全部楼层


PHP选的是7.4
Mysql选的是5.7
内存优化选的是2
Nginx按装是成功的
Linux下Nginx+MySQL+PHP自动安装工具:https://lnmp.org
 楼主| 发表于 2021-11-11 00:13:07 | 显示全部楼层



本帖最后由 gipqggtfnq 于 2021-11-11 00:16 编辑

重新换了系统 ,这是1.8的报错传输链接:https://cowtransfer.com/s/107c4787cbcc42 或 打开【奶牛快传】cowtransfer.com 使用传输口令:16bx86 提取;
美国VPS推荐: 遨游主机LinodeLOCVPSKVMLAVPS2EZ搬瓦工80VPSVultr美国VPS主机中国VPS推荐: 阿里云腾讯云。LNMP付费服务(代装/问题排查)QQ 503228080
发表于 2021-11-11 11:36:34 | 显示全部楼层



Reading package lists...
Building dependency tree...
Reading state information...
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
libssl-dev : Depends: libssl1.1 (= 1.1.1f-1ubuntu2.8) but 1.1.1f-1ubuntu2.9 is to be installed
E: Unable to correct problems, you have held broken packages.

你系统上依赖关系有问题导致的,Ubuntu 20.04正常系统自带libssl版本是1.1.1f-1ubuntu2.8,但是你系统上是1.1.1f-1ubuntu2.9造成依赖关系混乱
可以尝试使用 apt install libssl1.1=1.1.1f-1ubuntu2.8 进行修复
再 apt install libssl-dev 安装正常不报错后再安装lnmp
Linux下Nginx+MySQL+PHP自动安装工具:https://lnmp.org
 楼主| 发表于 2021-11-11 18:12:13 | 显示全部楼层

licess 发表于 2021-11-11 11:36
你系统上依赖关系有问题导致的,Ubuntu 20.04正常系统自带libssl版本是1.1.1f-1ubuntu2.8,但是你系统上是 ...

非常感谢~可以了

美国VPS、VPN、域名代购:http://shop63846532.taobao.com/

您需要登录后才可以回帖 登录 | 注册

本版积分规则

小黑屋|手机版|Archiver|VPS侦探 ( 鲁ICP备16040043号-1 )

GMT+8, 2021-12-5 18:42 , Processed in 0.086096 second(s), 17 queries .

Powered by Discuz! X3.4

Copyright © 2001-2021, Tencent Cloud.

快速回复 返回顶部 返回列表