VPS侦探论坛

 找回密码
 注册
查看: 111|回复: 3

想知道lnmp1.2升级到1.4的影响

[复制链接]
发表于 2021-11-24 15:16:58 | 显示全部楼层 |阅读模式



服务器多个项目有的只能用低版本的PHP 现在有个新项目需要PHP7+ 需要升级到lnmp1.4或更高使用多版本PHP 请问那个版本合适还不对我以前的项目造成影响  
美国VPS推荐: 遨游主机LinodeLOCVPSKVMLAVPS2EZ搬瓦工80VPSVultr美国VPS主机中国VPS推荐: 阿里云腾讯云。LNMP付费服务(代装/问题排查)QQ 503228080
发表于 2021-11-24 19:21:52 | 显示全部楼层


直接安装多php版本,然后再升级lnmp管理脚本,另外建议升级一下nginx 要不然用新版本的lnmp管理脚本生成的nginx配置文件有些新特性无法在lnmp 1.2上运行会报错
建议直接使用lnmp 1.8
Linux下Nginx+MySQL+PHP自动安装工具:https://lnmp.org
 楼主| 发表于 2021-11-25 08:39:18 | 显示全部楼层



licess 发表于 2021-11-24 19:21
直接安装多php版本,然后再升级lnmp管理脚本,另外建议升级一下nginx 要不然用新版本的lnmp管理脚本生成的n ...

我这1.2版本的之前装了PHP5.3 现在想再装个7.0 好像1.2不支持安装命令 然后我打算升级到高的版本 但是我又有之前的项目 请问如果升级了 会对我之前的项目造成影响吗        

本帖子中包含更多资源

您需要 登录 才可以下载或查看,没有帐号?注册

x
美国VPS推荐: 遨游主机LinodeLOCVPSKVMLAVPS2EZ搬瓦工80VPSVultr美国VPS主机中国VPS推荐: 阿里云腾讯云。LNMP付费服务(代装/问题排查)QQ 503228080
发表于 2021-11-25 14:14:29 | 显示全部楼层



php开发er 发表于 2021-11-25 08:39
我这1.2版本的之前装了PHP5.3 现在想再装个7.0 好像1.2不支持安装命令 然后我打算升级到高的版本 但是我 ...

1.2不支持多php版本,1.4开始才有的
是否影响在你发的另外帖子里已经做过回复了
Linux下Nginx+MySQL+PHP自动安装工具:https://lnmp.org
您需要登录后才可以回帖 登录 | 注册

本版积分规则

小黑屋|手机版|Archiver|VPS侦探 ( 鲁ICP备16040043号-1 )

GMT+8, 2021-12-3 06:22 , Processed in 0.049272 second(s), 17 queries .

Powered by Discuz! X3.4

Copyright © 2001-2021, Tencent Cloud.

快速回复 返回顶部 返回列表